summaryrefslogtreecommitdiff
path: root/pcr/gws/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-08-21 17:11:15 -0300
committerGaming4JC <g4jc@openmailbox.org>2015-08-23 17:46:39 -0400
commit1c0aa71e650b8034758cb73de697ff13d6b3de77 (patch)
tree3625ac18269203060d1b9d00f37737bd6933d10c /pcr/gws/PKGBUILD
parente98abb221cfa278eaeb15549817774cf6ffa481a (diff)
downloadabslibre-1c0aa71e650b8034758cb73de697ff13d6b3de77.tar.gz
abslibre-1c0aa71e650b8034758cb73de697ff13d6b3de77.tar.bz2
abslibre-1c0aa71e650b8034758cb73de697ff13d6b3de77.zip
gws: add new package to [pcr] -> https://labs.parabola.nu/issues/785
Diffstat (limited to 'pcr/gws/PKGBUILD')
-rw-r--r--pcr/gws/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/pcr/gws/PKGBUILD b/pcr/gws/PKGBUILD
new file mode 100644
index 000000000..f737d4316
--- /dev/null
+++ b/pcr/gws/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer (Arch): Fabien Dubosson <fabien.dubosson@gmail.com>
+
+pkgname="gws"
+pkgver="0.1.8"
+pkgrel="1"
+pkgdesc="Colorful KISS helper for git workspaces"
+url="https://github.com/StreakyCobra/gws"
+license=('MIT')
+arch=('any')
+depends=('bash>4.0' 'git')
+changelog="ChangeLog"
+source=("https://github.com/StreakyCobra/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('f6da0de648b5af5ce818e109f39f003f')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ install -D -m755 'src/gws' "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m755 'completions/zsh' "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
+ install -D -m755 'completions/bash' "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+}
+
+# vim:set ts=4 sw=4 et: