summaryrefslogtreecommitdiff
path: root/pcr/gegl-devel/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2017-07-10 22:22:47 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2017-07-10 22:22:47 -0500
commit6e45902cdd95d76642801b0c990d571347111d0e (patch)
tree3f664fc49f87c6397bb96d2d2256af453e68a714 /pcr/gegl-devel/PKGBUILD
parent2035e79003e5ac82590cb16ebee0bfbbbceeb543 (diff)
downloadabslibre-6e45902cdd95d76642801b0c990d571347111d0e.tar.gz
abslibre-6e45902cdd95d76642801b0c990d571347111d0e.tar.bz2
abslibre-6e45902cdd95d76642801b0c990d571347111d0e.zip
Removing gegl-{devel,git}. Use gegl instead
Diffstat (limited to 'pcr/gegl-devel/PKGBUILD')
-rw-r--r--pcr/gegl-devel/PKGBUILD61
1 files changed, 0 insertions, 61 deletions
diff --git a/pcr/gegl-devel/PKGBUILD b/pcr/gegl-devel/PKGBUILD
deleted file mode 100644
index 41fe2bd27..000000000
--- a/pcr/gegl-devel/PKGBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Maintainer: Márcio Silva <coadde@parabola.nu>
-# based of gegl
-
-_pkgname=gegl
-pkgname=gegl-devel
-pkgver=0.3.10
-pkgrel=1
-pkgdesc="Graph based image processing framework"
-arch=('i686' 'x86_64' 'armv7h')
-url="http://www.gegl.org/"
-license=('GPL3' 'LGPL3')
-depends=('babl-devel' 'libspiro' 'json-glib')
-makedepends=('intltool' 'ruby' 'lua' 'libraw' 'openexr' 'mesa' 'glu' 'ffmpeg' 'librsvg'
- 'jasper' 'libtiff' 'exiv2' 'vala' 'python2' 'suitesparse' 'lensfun'
- 'gobject-introspection' 'git')
-optdepends=('libraw: raw plugin'
- 'openexr: openexr plugin'
- 'ffmpeg: ffmpeg plugin'
- 'suitesparse: matting-levin plugin'
- 'librsvg: svg plugin'
- 'jasper: jasper plugin'
- 'libtiff: tiff plugin'
- 'lua: lua plugin'
- 'lensfun: lens-correct plugin')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("git://git.gnome.org/gegl#tag=GEGL_${pkgver//./_}")
-sha256sums=('SKIP')
-
-prepare() {
- mkdir path
- ln -s /usr/bin/python2 path/python
-
- cd ${_pkgname}
- NOCONFIGURE=1 ./autogen.sh
-}
-
-build() {
- export PATH="$srcdir/path:$PATH" PYTHON=/usr/bin/python2
- cd ${_pkgname}
- ./configure --prefix=/usr --with-sdl --with-librsvg \
- --with-libavformat --with-jasper --disable-docs \
- --enable-workshop
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
-}
-
-check() {
- export PATH="$srcdir/path:$PATH" PYTHON=/usr/bin/python2
- cd ${_pkgname}
- make -k check || :
-}
-
-package() {
- export PATH="$srcdir/path:$PATH" PYTHON=/usr/bin/python2
- cd ${_pkgname}
- make DESTDIR="${pkgdir}" install
-}