summaryrefslogtreecommitdiff
path: root/pcr/freefilesync/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-03-15 20:42:51 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-03-15 20:42:51 -0500
commit3d4432cd8369ab100aa910fd86dac9bf99cb6661 (patch)
treeafb191e2dfe5430d60d5892712479f505b417b1c /pcr/freefilesync/PKGBUILD
parent80aa208f007906f21c92571bd4764102ae846a12 (diff)
downloadabslibre-3d4432cd8369ab100aa910fd86dac9bf99cb6661.tar.gz
abslibre-3d4432cd8369ab100aa910fd86dac9bf99cb6661.tar.bz2
abslibre-3d4432cd8369ab100aa910fd86dac9bf99cb6661.zip
freefilesync-9.8-1: updating version
Diffstat (limited to 'pcr/freefilesync/PKGBUILD')
-rw-r--r--[-rwxr-xr-x]pcr/freefilesync/PKGBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/pcr/freefilesync/PKGBUILD b/pcr/freefilesync/PKGBUILD
index 96c4b2f6e..456d6f407 100755..100644
--- a/pcr/freefilesync/PKGBUILD
+++ b/pcr/freefilesync/PKGBUILD
@@ -1,16 +1,17 @@
+
# Contributor (Arch): chenxing <cxcxcxcx AT gmail DOT com>
# Contributor (Arch): Michael Burkhard <Michael DOT Burkhard AT web DOT de>
# Maintainer (Arch): alexmo82 <25396682 AT live DOT it>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=freefilesync
-pkgver=9.1
-pkgrel=0
+pkgver=9.8
+pkgrel=1
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.freefilesync.org/"
license=('GPLv3')
-depends=(wxgtk webkitgtk2 boost-libs)
+depends=(wxgtk webkit2gtk boost-libs)
makedepends=(boost)
source=(
"FreeFileSync_${pkgver}_Source.zip::https://www.freefilesync.org/download_redirect.php?file=FreeFileSync_${pkgver}_Source.zip" #ffs
@@ -19,23 +20,27 @@ source=(
RealTimeSync.desktop
rtsicon.png
)
-md5sums=(
- '362eb9c7bfb8638119a8ba7a75c99fa4' #ffs source
- 'eab0ccfc6a88e229a0f07507b93cfcff' #FreeFileSync.desktop
- '1f452dff6f970d95839411008d86250b' #ffsicon.png
- 'ab266177f69d16ad9f4099ae4edd77a2' #RealTimeSync.desktop
- 'ee5587fa0a8d906ad416564e4daf5a06' #rtsicon.png
+
+sha256sums=(
+ '77a59586284a518d6df6c0cc934c3efa434f247acce70452ab9fe37e7747b96d' #ffs source
+ 'b381bb9dbda25c3c08a67f18072a2761abe34339ddf3318e1758eb7c349f1a3b' #FreeFileSync.desktop
+ '31df3fa1f1310de14bbd379f891d4f8ed2df5b0d68913eb52c88b3be682933fb' #ffsicon.png
+ '1502efdbf1638856a18ab9916e0431bf6a53471792cb2daa380345bac33f67c4' #RealTimeSync.desktop
+ 'f28042587dbe99cf5d6bef2c1be4b026488e418e4ba8332b3016d246b7053a4e' #rtsicon.png
)
+
+DLAGENTS=('https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -A Mozilla -o %o %u')
prepare() {
# wxgtk < 3.1.0
sed -i 's/m_listBoxHistory->GetTopItem()/0/g' FreeFileSync/Source/ui/main_dlg.cpp
+
# gcc 6.3.1
- sed -i 's!static_assert!//static_assert!' zen/scope_guard.h
+ sed -i 's!static_assert!//static_assert!' zen/scope_guard.h
# warn_static(string)
- sed -i 's!-O3 -DN!-D"warn_static(arg)= " -O3 -DN!' FreeFileSync/Source/Makefile
- sed -i 's!-O3 -DN!-D"warn_static(arg)= " -O3 -DN!' FreeFileSync/Source/RealTimeSync/Makefile
+ sed -i 's!-O3 -DN!-D"warn_static(arg)= " -O3 -DN!' FreeFileSync/Source/Makefile
+ sed -i 's!-O3 -DN!-D"warn_static(arg)= " -O3 -DN!' FreeFileSync/Source/RealTimeSync/Makefile
# linker error
sed -i 's#inline##g' FreeFileSync/Source/ui/version_check_impl.h
@@ -45,6 +50,9 @@ prepare() {
}
build() {
+### speed up compile on multithread machines
+ MAKEFLAGS="-j$(nproc)"
+
### just in case of compile errors
VER=`g++ -dumpversion`
MAC=`g++ -dumpmachine`