summaryrefslogtreecommitdiff
path: root/pcr/emacs-newlisp/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-12-31 17:29:39 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-12-31 17:29:39 -0300
commit6f102d1647580e0bb9513c124b26a64c77da4f15 (patch)
tree0340f1f588be251183fe2b251bdba778f2c85c22 /pcr/emacs-newlisp/PKGBUILD
parent433900b14f11dc9ee55b72e8e5946bf47f65b636 (diff)
parentb6cb10de275cea63bab0bee2a98342afa4fdc4ee (diff)
downloadabslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.tar.gz
abslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.tar.bz2
abslibre-6f102d1647580e0bb9513c124b26a64c77da4f15.zip
Merge branch 'master' of ssh://gparabola/srv/git/abslibre
Diffstat (limited to 'pcr/emacs-newlisp/PKGBUILD')
-rw-r--r--pcr/emacs-newlisp/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/pcr/emacs-newlisp/PKGBUILD b/pcr/emacs-newlisp/PKGBUILD
new file mode 100644
index 000000000..25dcbc219
--- /dev/null
+++ b/pcr/emacs-newlisp/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jan Kròávek <wamba@centrum.cz>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer : Parabola GNU / Linux-libre Aurélien DESBRIÈRES <aurelien@cwb.IO>
+
+pkgname=emacs-newlisp
+pkgver=0.25
+pkgrel=5
+arch=('any')
+pkgdesc="Emacs mode for Newlisp."
+url="http://artfulcode.net/projects"
+depends=('emacs')
+makedepends=('unzip')
+license=('GPL')
+source=(http://www.artfulcode.net/wp-content/uploads/2008/12/newlisp-mode.zip)
+noextract=newlisp-mode.zip
+install=emacs-newlisp.install
+
+build() {
+ cd $srcdir
+ unzip -quo newlisp-mode.zip || return 1
+ cd $srcdir/newlisp-mode || return 1
+ install -d $pkgdir/usr/share/emacs/site-lisp/newlisp-mode
+ install -Dm644 *.el $pkgdir/usr/share/emacs/site-lisp/newlisp-mode
+}