summaryrefslogtreecommitdiff
path: root/pcr/emacs-magit/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-02-02 16:26:15 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-02-02 16:26:15 +0100
commitd752650652eab21d5661a91295f54012ce830b5a (patch)
tree4699f4827b41b1c88c2bff560222fb04c10c0a2a /pcr/emacs-magit/PKGBUILD
parent6a1dd1ce906fc523fa4b775088605de55ad9a372 (diff)
downloadabslibre-d752650652eab21d5661a91295f54012ce830b5a.tar.gz
abslibre-d752650652eab21d5661a91295f54012ce830b5a.tar.bz2
abslibre-d752650652eab21d5661a91295f54012ce830b5a.zip
pcr/emacs-magit: added in favour of emacs-magit-git
Diffstat (limited to 'pcr/emacs-magit/PKGBUILD')
-rw-r--r--pcr/emacs-magit/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/pcr/emacs-magit/PKGBUILD b/pcr/emacs-magit/PKGBUILD
new file mode 100644
index 000000000..8dcf0785c
--- /dev/null
+++ b/pcr/emacs-magit/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer (AUR): Esben Haabendal <esben@haabendal.dk>
+# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+
+# parabola changes and rationale:
+# - added replaces for previous pkgname 'emacs-magit-git' (2018-02-02)
+
+pkgname=emacs-magit
+pkgver=2.11.0
+pkgrel=1
+pkgdesc="It's Magit! A Emacs mode for Git."
+arch=('any')
+_github_org="magit"
+_github_repo="magit"
+url="http://github.com/${_github_org}/${_github_repo}"
+license=('GPL3')
+depends=('emacs' 'git' 'emacs-dash>=2.13.0' 'emacs-with-editor-git>=2.6.0')
+provides=('emacs-magit' 'emacs-magit-popup')
+conflicts=('emacs-magit-git' 'emacs-magit-popup')
+replaces=('emacs-magit-git')
+install="${pkgname}.install"
+source=("git+https://github.com/${_github_org}/${_github_repo}.git#tag=$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/${_github_repo}"
+ make LOAD_PATH="-L /usr/share/emacs/site-lisp -L /usr/share/emacs/site-lisp/dash -L ${srcdir}/magit/lisp" \
+ lisp docs
+}
+
+package() {
+ cd "$srcdir/${_github_repo}"
+ make PREFIX="/usr" DESTDIR="${pkgdir}" install
+}