summaryrefslogtreecommitdiff
path: root/pcr/cowpatty/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-06-14 19:20:46 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-06-14 19:20:46 -0400
commitf7fd1d99d87f11c41cf09f881b1aeb950a3c8e13 (patch)
tree95910fb3078e1136e35aaa6d9f0f251cdb4ca1a8 /pcr/cowpatty/PKGBUILD
parent09c1bb45d89c78a9fd80c7a500cb29a0908dc668 (diff)
parentcd640e7ca0a8968edf887d03db8224334f663e84 (diff)
downloadabslibre-f7fd1d99d87f11c41cf09f881b1aeb950a3c8e13.tar.gz
abslibre-f7fd1d99d87f11c41cf09f881b1aeb950a3c8e13.tar.bz2
abslibre-f7fd1d99d87f11c41cf09f881b1aeb950a3c8e13.zip
Merge branch 'master' of git://projects.parabolagnulinux.org/abslibre
Diffstat (limited to 'pcr/cowpatty/PKGBUILD')
-rw-r--r--pcr/cowpatty/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/pcr/cowpatty/PKGBUILD b/pcr/cowpatty/PKGBUILD
new file mode 100644
index 000000000..c29c53ad8
--- /dev/null
+++ b/pcr/cowpatty/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor (Arch) : CRT <crt.011@gmail.com>
+# Contributor (Arch) : Sébastien Duquette <ekse.0x@gmail.com>
+# Contributor (Arch) : icarus <icarus.roaming@gmail.com>
+# Contributor (Arch) : Stephane Travostino <stephane.travostino@gmail.com>
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+pkgname=cowpatty
+pkgver=4.6
+pkgrel=5
+pkgdesc="Wireless WPA/WPA2 PSK handshake cracking utility"
+arch=('i686' 'x86_64')
+url="http://www.wirelessdefence.org/Contents/coWPAttyMain.htm"
+license=('GPL')
+depends=('openssl' 'libpcap')
+options=('docs' '!makeflags')
+source=("http://www.wirelessdefence.org/Contents/Files/cowpatty-$pkgver.tgz")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ make strip
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" BINDIR="/usr/bin/" install
+ install -D -m644 dict "$pkgdir"/usr/share/cowpatty/dict
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
+}