summaryrefslogtreecommitdiff
path: root/pcr/cjdns-git/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2015-07-19 02:03:06 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2015-07-19 02:03:06 -0500
commit8ebf0b2021235b35b931ec351796e0131fbd32e0 (patch)
treecee341770c2300b679f1bda6db51c6b088b12de1 /pcr/cjdns-git/PKGBUILD
parent8cf25b143a477db98db59cf0cf4f0560b8222f33 (diff)
downloadabslibre-8ebf0b2021235b35b931ec351796e0131fbd32e0.tar.gz
abslibre-8ebf0b2021235b35b931ec351796e0131fbd32e0.tar.bz2
abslibre-8ebf0b2021235b35b931ec351796e0131fbd32e0.zip
cjdns-git-0.3.3382-2: updating version
Diffstat (limited to 'pcr/cjdns-git/PKGBUILD')
-rw-r--r--pcr/cjdns-git/PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/pcr/cjdns-git/PKGBUILD b/pcr/cjdns-git/PKGBUILD
index c5efa1c8e..1b079d175 100644
--- a/pcr/cjdns-git/PKGBUILD
+++ b/pcr/cjdns-git/PKGBUILD
@@ -6,8 +6,8 @@
_pkgname=cjdns
pkgname=$_pkgname-git
-pkgver=0.3.3357
-pkgrel=1
+pkgver=0.3.3382
+pkgrel=2
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
license=('GPL3')
@@ -17,9 +17,10 @@ depends=('glibc')
makedepends=('git' 'nodejs' 'python2')
optdepends=(
'cjdnsify: allows you to run some programs bound to your cjdns address'
- 'libnacl: speed up the build process by skipping the need to compile cnacl'
'cjdns-git-sysvinit: support for sysvinit (rc.d)'
)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
source=("git+$url#branch=crashey")
sha512sums=('SKIP')
@@ -35,8 +36,8 @@ build() {
package() {
cd $_pkgname
- install -Dm755 'cjdroute' "$pkgdir/usr/bin/cjdroute"
- install -Dm755 'contrib/sh/run-cjdroute.sh' "$pkgdir/usr/bin/run-cjdroute"
- install -Dm644 "contrib/systemd/$_pkgname.service" "$pkgdir/usr/lib/systemd/system/$_pkgname.service"
- install -Dm644 'doc/man/cjdroute.conf.5' "$pkgdir/usr/share/man/man5/cjdroute.conf.5"
+ install -Dm755 cjdroute "$pkgdir/usr/bin/cjdroute"
+ install -Dm755 contrib/sh/run-cjdroute.sh "$pkgdir/usr/bin/run-cjdroute"
+ install -Dm644 contrib/systemd/$_pkgname.service "$pkgdir/usr/lib/systemd/system/$_pkgname.service"
+ install -Dm644 doc/man/cjdroute.conf.5 "$pkgdir/usr/share/man/man5/cjdroute.conf.5"
}