summaryrefslogtreecommitdiff
path: root/pcr/chm2pdf/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-01-02 16:04:44 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-01-02 16:04:44 -0200
commit1bf5038b88434788f223abbfe4d40711980662f8 (patch)
tree820b68fff118e27405a8265e929539f133183a42 /pcr/chm2pdf/PKGBUILD
parent018aa5ccf0a2fdd350d7cfe2f2022e4ed8290429 (diff)
parent593a1335dd0bb92ac9f1e2a7a2ca12b3b3f06cd5 (diff)
downloadabslibre-1bf5038b88434788f223abbfe4d40711980662f8.tar.gz
abslibre-1bf5038b88434788f223abbfe4d40711980662f8.tar.bz2
abslibre-1bf5038b88434788f223abbfe4d40711980662f8.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'pcr/chm2pdf/PKGBUILD')
-rw-r--r--pcr/chm2pdf/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/pcr/chm2pdf/PKGBUILD b/pcr/chm2pdf/PKGBUILD
new file mode 100644
index 000000000..16586e732
--- /dev/null
+++ b/pcr/chm2pdf/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Rodrigo Coacci <rcoacci@gmail.com>
+# Contributor: fes0
+# Maintainer : Parabola GNU / Linux-libre Aurélien Desbrières <aurelien@cwb.IO>
+
+pkgname=chm2pdf
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="A simple Python script that converts CHM files into PDF files."
+arch=('any')
+license=('GPL2')
+url="http://code.google.com/p/chm2pdf/"
+depends=('chmlib' 'python2' 'python2-pychm' 'htmldoc')
+optdepends=('beautiful-soup: A Python HTML/XML parser designed for quick turnaround projects like screen-scraping')
+source=('http://chm2pdf.googlecode.com/files/chm2pdf-0.9.1.tar.gz')
+
+
+build() {
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $srcdir/$pkgname-$pkgver/chm2pdf
+ cd $srcdir/$pkgname-$pkgver
+ python2 setup.py install --root=$startdir/pkg
+}
+