summaryrefslogtreecommitdiff
path: root/pcr/bup/PKGBUILD
diff options
context:
space:
mode:
authoraurelien <tek@localhost.localdomain>2012-11-13 17:00:03 +0100
committeraurelien <tek@localhost.localdomain>2012-11-13 17:00:03 +0100
commitcf319581703bfe2836e7df909dd5f9c0ab0d54e5 (patch)
tree43f3f7b82a28ea3440929e83da45f82968c3ba2c /pcr/bup/PKGBUILD
parent5ae2d0f4bb7b2d29aca46139292207252616ac1f (diff)
downloadabslibre-cf319581703bfe2836e7df909dd5f9c0ab0d54e5.tar.gz
abslibre-cf319581703bfe2836e7df909dd5f9c0ab0d54e5.tar.bz2
abslibre-cf319581703bfe2836e7df909dd5f9c0ab0d54e5.zip
version i686 of the build of end of October 201
Diffstat (limited to 'pcr/bup/PKGBUILD')
-rw-r--r--pcr/bup/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/pcr/bup/PKGBUILD b/pcr/bup/PKGBUILD
new file mode 100644
index 000000000..bdc2abeeb
--- /dev/null
+++ b/pcr/bup/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bram Schoenmakers <me@bramschoenmakers.nl>
+# Contributor: henning mueller <henning@orgizm.net>
+# Maintainer : Parabola GNU / Linux-libre Aurélien Desbrières <aurelien@cwb.io>
+
+# If you'd like to have documentation, please set the variable below to 1.
+# This implies installing pandoc, which in turn depends on many Haskell packages.
+_havedocs=0
+
+pkgname=bup
+pkgver=0.25rc1
+_pkgver=0.25-rc1
+pkgrel=2
+pkgdesc="Backup tool using git pack files."
+arch=('i686' 'x86_64')
+url="http://github.com/apenwarr/bup"
+license=('GPL')
+depends=('python2-fuse' 'par2cmdline')
+[ $_havedocs = 1 ] && makedepends=('haskell-pandoc')
+source=("https://github.com/apenwarr/${pkgname}/archive/${pkgname}-${_pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${_pkgver}"
+
+ find . -name \*.py | xargs sed -i 's:env python:env python2:'
+ sed -i 's:PYTHON=python:PYTHON=python2:' Makefile
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${_pkgver}"
+ make DESTDIR=$pkgdir install
+}
+md5sums=('9d9af10900d84e2951aa64631ff4860d')