summaryrefslogtreecommitdiff
path: root/pcr/apt/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@openmailbox.org>2017-04-05 12:51:41 -0300
committerDavid P <megver83@openmailbox.org>2017-04-05 12:51:41 -0300
commitc0abfd67d43374f576f0e9cf9113a17164261a81 (patch)
tree58d7b9afdf46f46dda0422cebaa07dfabe73951d /pcr/apt/PKGBUILD
parent4d05f83ddbb340a80684e47d3d6bcc567a8ecff8 (diff)
downloadabslibre-c0abfd67d43374f576f0e9cf9113a17164261a81.tar.gz
abslibre-c0abfd67d43374f576f0e9cf9113a17164261a81.tar.bz2
abslibre-c0abfd67d43374f576f0e9cf9113a17164261a81.zip
Added apt to [pcr]
Diffstat (limited to 'pcr/apt/PKGBUILD')
-rw-r--r--pcr/apt/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/pcr/apt/PKGBUILD b/pcr/apt/PKGBUILD
new file mode 100644
index 000000000..f9b1fead1
--- /dev/null
+++ b/pcr/apt/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: David P. <megver83@openmailbox.org>
+# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
+# Contributor: Mark Weiman <mark.weiman@markzz.com>
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+# Contributor: Tony Lambiris <tony@critialstack.com>
+
+pkgname=apt
+pkgver=1.3.2
+pkgrel=3
+pkgdesc="Command-line package manager used on Debian-based systems"
+arch=('armv7h' 'i686' 'x86_64')
+url="http://packages.debian.org"
+license=('GPL2')
+depends=('gnupg' 'curl' 'xz')
+makedepends=('cmake' 'dpkg' 'docbook-xsl' 'doxygen' 'po4a' 'gtest' 'w3m')
+checkdepends=()
+optdepends=()
+provides=('libapt-inst' 'libapt-pkg' 'libapt-pkg-dev' "apt-utils")
+conflicts=(apt-git)
+replaces=(apt-git)
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://anonscm.debian.org/git/apt/apt.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ # docbook xsl is stored with the version on Arch
+ DOCBOOK_XSL_VER=`ls -d /usr/share/xml/docbook/xsl-stylesheets-* | xargs basename`
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DDOCBOOK_XSL="/usr/share/xml/docbook/${DOCBOOK_XSL_VER}" \
+ .
+
+ sed -i -e "s|stylesheet/docbook-xsl|$DOCBOOK_XSL_VER=t|" doc/*.xsl
+ sed -i -e "s|stylesheet/nwalsh|$DOCBOOK_XSL_VER=|" doc/*.xsl
+
+ make -j $(nproc) all
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: