summaryrefslogtreecommitdiff
path: root/pcr/apertium-en-es-git/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-10 11:37:45 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-10 11:37:45 +0100
commit15f77009c7a5c47704dbf0b40f8a77cc358e08cc (patch)
tree88b26decc2f761562330c557ccefc0d3713b707d /pcr/apertium-en-es-git/PKGBUILD
parentb0824c408f48b44802c5cae146d9ea3aaa5229c1 (diff)
downloadabslibre-15f77009c7a5c47704dbf0b40f8a77cc358e08cc.tar.gz
abslibre-15f77009c7a5c47704dbf0b40f8a77cc358e08cc.tar.bz2
abslibre-15f77009c7a5c47704dbf0b40f8a77cc358e08cc.zip
pcr/lttoolbox: updated to 3.5.0
Diffstat (limited to 'pcr/apertium-en-es-git/PKGBUILD')
-rw-r--r--pcr/apertium-en-es-git/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/pcr/apertium-en-es-git/PKGBUILD b/pcr/apertium-en-es-git/PKGBUILD
new file mode 100644
index 000000000..f7f20e95d
--- /dev/null
+++ b/pcr/apertium-en-es-git/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor (AUR): Kevin Brubeck Unhammer <unhammer@fsfe.org>
+# Maintainer (AUR): Kevin Brubeck Unhammer <unhammer@fsfe.org>
+
+# parabola changes and rationale:
+# no changes
+# NOTE: the AUR PKGBUILD patches the autotools files
+# but it was using a version of 'apertium-en-es' from 2011
+# so i did not take the patches
+
+
+pkgname=apertium-en-es-git
+pkgver=d0a72e428a23081aaf479d00f30d63053a149cce
+pkgrel=1
+pkgdesc="Apertium translation pair for English and Spanish"
+url="http://apertium.org"
+license=('GPL2')
+makedepends=('apertium-lex-tools')
+depends=('apertium>=3.4')
+arch=('i686' 'x86_64' 'armv7h')
+source=(https://github.com/apertium/apertium-en-es/archive/${pkgver}.zip)
+md5sums=('e07b933c9b3afb7526e342dfa05f7999')
+sha256sums=('ddee8430463c796a85b3c6fb42735dc7352941a403564f5808e7479ba7895d27')
+
+_builddir="${pkgname/%-git}-$pkgver"
+
+
+build()
+{
+ cd "$srcdir/$_builddir"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package()
+{
+ cd "$srcdir/$_builddir"
+
+ make DESTDIR="$pkgdir/" install
+}