summaryrefslogtreecommitdiff
path: root/pcr-testing/python-mailman-client/PKGBUILD
diff options
context:
space:
mode:
authorBruno Cichon <ebrasca@librepanther.com>2018-10-01 01:51:29 +0200
committerBruno Cichon <ebrasca@librepanther.com>2018-10-01 01:51:29 +0200
commit9bdcd4c3d22da95e94780454614436082e0eea7d (patch)
treec8755fe8c20be0043d67099bfb357c904c513cff /pcr-testing/python-mailman-client/PKGBUILD
parent56f955aca6231693fe797de4793f77ed58ab116e (diff)
parent60149d4be1633dd72cba35fcfc29bcf9f117e6fd (diff)
downloadabslibre-9bdcd4c3d22da95e94780454614436082e0eea7d.tar.gz
abslibre-9bdcd4c3d22da95e94780454614436082e0eea7d.tar.bz2
abslibre-9bdcd4c3d22da95e94780454614436082e0eea7d.zip
Merge branch 'master' of git://git.parabola.nu/abslibre/abslibre
Diffstat (limited to 'pcr-testing/python-mailman-client/PKGBUILD')
-rw-r--r--pcr-testing/python-mailman-client/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/pcr-testing/python-mailman-client/PKGBUILD b/pcr-testing/python-mailman-client/PKGBUILD
new file mode 100644
index 000000000..29d4b87ad
--- /dev/null
+++ b/pcr-testing/python-mailman-client/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: bill-auger <bill-auger@programmer.net>
+# Maintainer (AUR): Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+
+pkgname=('python-mailman-client' 'python2-mailman-client')
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Library that provides official Python bindings for the GNU Mailman 3 REST API"
+arch=(any)
+url=https://gitlab.com/mailman/mailmanclient
+license=('LGPL')
+options=(!emptydirs)
+
+makedepends=('python-setuptools' 'python2-setuptools')
+
+_upstream_name='mailmanclient'
+_release="${_upstream_name}-${pkgver}"
+source=(https://gitlab.com/mailman/${_upstream_name}/-/archive/${pkgver}/${_release}.tar.gz)
+sha256sums=('12fdfd96ec46a3c38bf1227787f97d9547dec3d8501a26177c98b1a67a5e9999')
+
+
+package_python-mailmanclient()
+{
+ depends=('python' 'python-six' 'python-httplib2')
+
+ cd "$srcdir/${_release}"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-mailmanclient()
+{
+ depends=('python2' 'python2-six' 'python2-httplib2')
+
+ cd "$srcdir/${_release}"
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}