summaryrefslogtreecommitdiff
path: root/nonprism/kdenetwork-kopete-libre-nonprism/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-12-23 02:13:57 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-12-23 02:17:47 -0200
commita70d3b5735ef66f045d45d26da8adc05b1841133 (patch)
tree79a3849baded6c27cb1f01cd7bf25775a7892c79 /nonprism/kdenetwork-kopete-libre-nonprism/PKGBUILD
parent9e17f935d4121eb2915297b1ea91d74b56390914 (diff)
downloadabslibre-a70d3b5735ef66f045d45d26da8adc05b1841133.tar.gz
abslibre-a70d3b5735ef66f045d45d26da8adc05b1841133.tar.bz2
abslibre-a70d3b5735ef66f045d45d26da8adc05b1841133.zip
kde packages: updating libre and nonprism packages to 4.12.0 version
* add description for kdelibs-libre package
Diffstat (limited to 'nonprism/kdenetwork-kopete-libre-nonprism/PKGBUILD')
-rw-r--r--nonprism/kdenetwork-kopete-libre-nonprism/PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/nonprism/kdenetwork-kopete-libre-nonprism/PKGBUILD b/nonprism/kdenetwork-kopete-libre-nonprism/PKGBUILD
index 7927661a6..cd932ac3e 100644
--- a/nonprism/kdenetwork-kopete-libre-nonprism/PKGBUILD
+++ b/nonprism/kdenetwork-kopete-libre-nonprism/PKGBUILD
@@ -1,17 +1,17 @@
-# $Id: PKGBUILD 201125 2013-12-06 12:34:37Z svenstaro $
+# $Id: PKGBUILD 201659 2013-12-17 13:52:43Z andrea $
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
_pkgname=kdenetwork-kopete
pkgname=kdenetwork-kopete-libre-nonprism
-pkgver=4.11.4
+pkgver=4.12.0
pkgrel=1
pkgdesc='Instant Messenger, without skype and support for unsafe and dangerous for privacy protocols'
url='http://kde.org/applications/internet/kopete/'
arch=('i686' 'x86_64' 'mips64el')
license=('GPL' 'LGPL' 'FDL')
groups=('kde' 'kdenetwork')
-depends=('kdebase-runtime' 'kdepimlibs' 'qca-ossl' 'libotr3' 'libidn'
+depends=('kdebase-runtime' 'kdepimlibs' 'qca-ossl' 'libotr' 'libidn'
'qimageblitz' 'mediastreamer' 'jsoncpp')
makedepends=('cmake' 'automoc4' 'boost')
install=${_pkgname}.install
@@ -19,18 +19,11 @@ replaces=$_pkgname
conflicts=$_pkgname
provides=$_pkgname=$pkgver
source=("http://download.kde.org/stable/${pkgver}/src/kopete-${pkgver}.tar.xz"
- 'libotr3.patch'
- 'mediastreamer29.patch'
'libre-nonprism.patch')
-sha1sums=('d8bc0c386d9f846e2d5f05d7dfa421fdcb2ac537'
- '9c3b0ee15538fbfa36aa0a4748b1f6b5a7905384'
- '317683a5c2acd0a0058c5ab42f6006e9db511ef3'
- '3c46e5c80ef0cd3f6fe9fb6d5cb8c252c6792208')
+sha1sums=('c1ef611b27079388e48e558a65e2de80db93d875')
prepare() {
cd kopete-${pkgver}
- patch -p2 -i "${srcdir}"/libotr3.patch
- patch -p1 -i "${srcdir}"/mediastreamer29.patch
# Based on http://bzr.trisquel.info/package-helpers/trunk/annotate/head%3A/helpers/natty/make-kdenetwork, revision 34.
sed -i 's/Skype protocol" ON/Skype protocol" OFF/g' protocols/CMakeLists.txt
rm -rf protocols/skype
@@ -52,10 +45,11 @@ prepare() {
sed -i 's/meanwhile protocol" ON/meanwhile protocol" OFF/g' protocols/CMakeLists.txt
rm -rf protocols/meanwhile
patch -p1 -i "${srcdir}"/libre-nonprism.patch
+ cd ..
+ mkdir build
}
build() {
- mkdir build
cd build
cmake ../kopete-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \