summaryrefslogtreecommitdiff
path: root/nonprism/eog-plugins-nonprism/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-08-22 01:10:43 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-08-22 01:10:43 -0300
commit2ef21ab69fcb517b1fccd361c8602196f711dfe2 (patch)
tree5a054255429dbc551ab31e39a71e44d3f1395846 /nonprism/eog-plugins-nonprism/PKGBUILD
parent768f69fa081129ae5e9f7943890d41c9f050d3bf (diff)
parentae249fc1a7d70ff6c855bce83e449b87525d7e46 (diff)
downloadabslibre-2ef21ab69fcb517b1fccd361c8602196f711dfe2.tar.gz
abslibre-2ef21ab69fcb517b1fccd361c8602196f711dfe2.tar.bz2
abslibre-2ef21ab69fcb517b1fccd361c8602196f711dfe2.zip
Merge branch 'master' of ssh://projects.parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'nonprism/eog-plugins-nonprism/PKGBUILD')
-rw-r--r--nonprism/eog-plugins-nonprism/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/nonprism/eog-plugins-nonprism/PKGBUILD b/nonprism/eog-plugins-nonprism/PKGBUILD
new file mode 100644
index 000000000..010f3eb7b
--- /dev/null
+++ b/nonprism/eog-plugins-nonprism/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
+
+_pkgname=eog-plugins
+pkgname=eog-plugins-nonprism
+pkgver=3.8.1
+pkgrel=2
+pkgdesc="Plugins for Eye of Gnome, without libgdata support"
+arch=('i686' 'x86_64')
+url="http://www.gnome.org/"
+license=('GPL2')
+depends=('eog' 'libchamplain')
+makedepends=('intltool')
+provides=("$_pkgname=$pkgver")
+conflicts=$_pkgname
+replaces=$_pkgname
+install=eog-plugins.install
+options=('!libtool')
+source=(http://download.gnome.org/sources/$_pkgname/${pkgver%.*}/$_pkgname-$pkgver.tar.xz)
+sha256sums=('5cf8dab5b6622b9e712da4094185112cc84baa96f2775cc76bf654b1c443cfb9')
+
+build() {
+ cd $_pkgname-$pkgver
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
+ --sysconfdir=/etc --localstatedir=/var
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: