summaryrefslogtreecommitdiff
path: root/nonprism/empathy/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-01-29 22:24:17 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-01-29 22:24:17 -0300
commitef198c172fe6db8f2df7aa53b7619c7e9f0403e6 (patch)
treeb1514ec3f5e53d14b150ce600e4520cab51f82a2 /nonprism/empathy/PKGBUILD
parenta4b56212bb9f2cef37090fb36f8d92baaea1c369 (diff)
downloadabslibre-ef198c172fe6db8f2df7aa53b7619c7e9f0403e6.tar.gz
abslibre-ef198c172fe6db8f2df7aa53b7619c7e9f0403e6.tar.bz2
abslibre-ef198c172fe6db8f2df7aa53b7619c7e9f0403e6.zip
empathy-3.12.12+69+g841af5f32-1.nonprism1: updating version
Diffstat (limited to 'nonprism/empathy/PKGBUILD')
-rw-r--r--nonprism/empathy/PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/nonprism/empathy/PKGBUILD b/nonprism/empathy/PKGBUILD
index 64959327c..66aaf1e68 100644
--- a/nonprism/empathy/PKGBUILD
+++ b/nonprism/empathy/PKGBUILD
@@ -1,28 +1,29 @@
-# $Id: PKGBUILD 277244 2016-09-28 12:12:15Z jgc $
-# Maintainer (Arch): Ionut Biru <ibiru@archlinux.org>
+# $Id: PKGBUILD 287526 2017-01-26 20:18:11Z heftig $
+# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
pkgname=empathy
-pkgver=3.12.12+35+g8311b76
+pkgver=3.12.12+69+g841af5f32
pkgrel=1.nonprism1
pkgdesc="A GNOME instant messaging client using the Telepathy framework, without geoclue2 support"
url="https://wiki.gnome.org/Apps/Empathy"
arch=(i686 x86_64)
license=(GPL2)
-depends=(clutter-gst clutter-gtk folks gcr iso-codes libcanberra libpulse webkitgtk
+depends=(clutter-gst clutter-gtk folks gcr iso-codes libcanberra libpulse webkit2gtk
telepathy-farstream telepathy-glib telepathy-logger telepathy-mission-control
geocode-glib cheese libchamplain libgudev)
-makedepends=(intltool itstool docbook-xsl python python2 gnome-common git)
+makedepends=(intltool itstool docbook-xsl python gnome-common git)
optdepends=('telepathy-gabble: XMPP/Jabber support'
'telepathy-idle: IRC support'
'telepathy-salut: Link-local XMPP support'
'telepathy-rakia: SIP support'
'telepathy-haze: libpurple support')
-options=(!makeflags)
groups=(gnome)
-_commit=8311b765895d092c178ba81a36dd3956503ef351 # master
-source=("git://git.gnome.org/empathy#commit=$_commit")
-sha256sums=('SKIP')
+_commit=841af5f329c37fd36fa4104c8a430e4ec03f1448 # master
+source=("git+https://git.gnome.org/browse/empathy#commit=$_commit"
+ "git+https://git.gnome.org/browse/telepathy-account-widgets")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd $pkgname
@@ -31,12 +32,18 @@ pkgver() {
prepare() {
cd $pkgname
+
+ git submodule init
+ git config --local submodule.telepathy-account-widgets.url "$srcdir/telepathy-account-widgets"
+ git submodule update
+
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd $pkgname
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
+ export LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
+ ./configure --prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/lib/empathy \
--disable-static \