summaryrefslogtreecommitdiff
path: root/nonprism/choqok-nonprism/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-08-20 05:46:16 -0300
committerMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-08-20 05:46:16 -0300
commit2ed05b86c1e20354ef5e3ce5917b0b89fb7fb117 (patch)
treea8fdc85060ede142acc07a2b44a806070a679631 /nonprism/choqok-nonprism/PKGBUILD
parentf0728c45baf0ebca5b17e28d8d5cfbbbb4f8fd8d (diff)
downloadabslibre-2ed05b86c1e20354ef5e3ce5917b0b89fb7fb117.tar.gz
abslibre-2ed05b86c1e20354ef5e3ce5917b0b89fb7fb117.tar.bz2
abslibre-2ed05b86c1e20354ef5e3ce5917b0b89fb7fb117.zip
updating claws-mail-libre{,-nonprism} and adding choqok-nonprism to nonprism repo
Diffstat (limited to 'nonprism/choqok-nonprism/PKGBUILD')
-rw-r--r--nonprism/choqok-nonprism/PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/nonprism/choqok-nonprism/PKGBUILD b/nonprism/choqok-nonprism/PKGBUILD
new file mode 100644
index 000000000..7ca3af81d
--- /dev/null
+++ b/nonprism/choqok-nonprism/PKGBUILD
@@ -0,0 +1,59 @@
+# $Id$
+# Maintainer: Peter Richard Lewis <plewis@aur.archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Emanuele Rossi <newdna1510@yahoo.it>
+# Contributor: Bram Schoenmakers <me@bramschoenmakers.nl>
+# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
+
+_pkgname=choqok
+pkgname=choqok-nonprism
+pkgver=1.3
+pkgrel=4
+pkgdesc="A Twitter/identi.ca/laconica client for KDE"
+url='http://choqok.gnufolks.org/'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('kdebase-runtime' 'qjson' 'qoauth' 'qca-ossl')
+makedepends=('cmake' 'automoc4')
+optdepends=('kdebase-konqueror: proxy support')
+install="${_pkgname}.install"
+source=("http://downloads.sourceforge.net/${_pkgname}/${_pkgname}-${pkgver}.tar.bz2")
+md5sums=('87eea4f2c23467fb021e3e6b794eb37d')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # remove twitter service and keep only twitterapi (choqok software) for status.net and open collaboration services
+ sed -i '\|add_subdirectory(twitter)|d' microblogs/CMakeLists.txt
+ sed -i 's|twitter[.]com|status.net|' microblogs/laconica/laconicamicroblog.cpp
+ sed -i 's|twitter[.]com|status.net|' microblogs/laconica/laconicasearch.cpp
+
+ # remove uploaders plugin (with only nonprivacy services)
+ sed -i '\|add_subdirectory(uploaders)|d' plugins/CMakeLists.txt
+ sed -i 's|Comment||' plugins/searchaction/choqok_searchaction.desktop
+
+ # remove twitter on docbook
+ sed -i 's| and Twitter.com||
+ s| and another with the alias|.</para>|
+ s|while a post using Twitter is called a tweet||
+ \|Twitter|d;\|twitter|d' doc/index.docbook
+}
+
+build() {
+ cd "${srcdir}"
+ mkdir build
+ cd build
+ cmake ../${_pkgname}-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/build
+ make DESTDIR="${pkgdir}" install
+
+ # This is already installed by kdepimlibs >= 4.9.80
+ rm "${pkgdir}"/usr/share/apps/cmake/modules/FindQtOAuth.cmake
+}
+