summaryrefslogtreecommitdiff
path: root/libre/xtensa-unknown-elf-gcc/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2018-04-09 22:25:13 -0300
committerDavid P <megver83@parabola.nu>2018-04-09 22:25:13 -0300
commitb94a647b28b14632b0d2033b4543009eea69f151 (patch)
tree38ead2f31df21a526d6d31d258c224a62c089c25 /libre/xtensa-unknown-elf-gcc/PKGBUILD
parented667219682a523e1d192e36c7a37f5cea504c72 (diff)
downloadabslibre-b94a647b28b14632b0d2033b4543009eea69f151.tar.gz
abslibre-b94a647b28b14632b0d2033b4543009eea69f151.tar.bz2
abslibre-b94a647b28b14632b0d2033b4543009eea69f151.zip
upgpkg: libre/xtensa-unknown-elf-{gcc,binutils}
Diffstat (limited to 'libre/xtensa-unknown-elf-gcc/PKGBUILD')
-rw-r--r--libre/xtensa-unknown-elf-gcc/PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/libre/xtensa-unknown-elf-gcc/PKGBUILD b/libre/xtensa-unknown-elf-gcc/PKGBUILD
index 3887ba706..3c447c384 100644
--- a/libre/xtensa-unknown-elf-gcc/PKGBUILD
+++ b/libre/xtensa-unknown-elf-gcc/PKGBUILD
@@ -8,7 +8,7 @@ _target=xtensa-unknown-elf
pkgname=$_target-gcc
pkgver=7.3.1
_islver=0.18
-pkgrel=1
+pkgrel=2
_snapshot=7-20180125
pkgdesc='The GNU Compiler Collection - C and C++ frontends'
arch=('x86_64' 'i686' 'armv7h')
@@ -19,9 +19,11 @@ makedepends=(gmp mpfr)
options=(!emptydirs !strip)
source=(#https://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.bz2
https://gcc.gnu.org/pub/gcc/snapshots/$_snapshot/gcc-$_snapshot.tar.xz
- http://isl.gforge.inria.fr/isl-$_islver.tar.bz2)
+ http://isl.gforge.inria.fr/isl-$_islver.tar.bz2
+ https://raw.githubusercontent.com/qca/open-ath9k-htc-firmware/master/local/patches/gcc.patch)
sha512sums=('87558e9cf6d44df0c45e2bde8ef4d4a8b77716382ae0cd787b80bb4650a0a033d2b815a3b3eaa1798a16d66afca0d38c83a268bed0b26bdf013a483f04923298'
- '85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94')
+ '85d0b40f4dbf14cb99d17aa07048cdcab2dc3eb527d2fbb1e84c41b2de5f351025370e57448b63b2b8a8cf8a0843a089c3263f9baee1542d5c2e1cb37ed39d94'
+ '7637408259cef4b14a2f41690bbc769ad0dc6cf4d1c782405526aeb58f68193269af6882b23fb57c3521174e45709ed2d54f0af1f835646e70a3bfd9f626aad9')
if [ -n "$_snapshot" ]; then
_basedir=gcc-$_snapshot
@@ -42,6 +44,8 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" "$srcdir"/$_basedir/{libiberty,gcc}/configure
+
+ patch -p1 -i ../gcc.patch
rm -rf $srcdir/gcc-build
mkdir $srcdir/gcc-build
@@ -54,6 +58,8 @@ build() {
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
CFLAGS=${CFLAGS/-pipe/}
CXXFLAGS=${CXXFLAGS/-pipe/}
+
+ # --disable-linker-build-id: https://bugs.archlinux.org/task/34902
$srcdir/$_basedir/configure \
--prefix=/usr \
@@ -65,7 +71,7 @@ build() {
--with-system-zlib --with-isl --enable-__cxa_atexit \
--disable-libunwind-exceptions --enable-clocale=gnu \
--disable-libstdcxx-pch --disable-libssp \
- --enable-gnu-unique-object --enable-linker-build-id \
+ --enable-gnu-unique-object --disable-linker-build-id \
--enable-lto --enable-plugin --enable-install-libiberty \
--with-linker-hash-style=gnu --enable-gnu-indirect-function \
--disable-multilib --disable-werror \