summaryrefslogtreecommitdiff
path: root/libre/xtensa-unknown-elf-binutils/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2018-04-09 22:25:13 -0300
committerDavid P <megver83@parabola.nu>2018-04-09 22:25:13 -0300
commitb94a647b28b14632b0d2033b4543009eea69f151 (patch)
tree38ead2f31df21a526d6d31d258c224a62c089c25 /libre/xtensa-unknown-elf-binutils/PKGBUILD
parented667219682a523e1d192e36c7a37f5cea504c72 (diff)
downloadabslibre-b94a647b28b14632b0d2033b4543009eea69f151.tar.gz
abslibre-b94a647b28b14632b0d2033b4543009eea69f151.tar.bz2
abslibre-b94a647b28b14632b0d2033b4543009eea69f151.zip
upgpkg: libre/xtensa-unknown-elf-{gcc,binutils}
Diffstat (limited to 'libre/xtensa-unknown-elf-binutils/PKGBUILD')
-rw-r--r--libre/xtensa-unknown-elf-binutils/PKGBUILD85
1 files changed, 41 insertions, 44 deletions
diff --git a/libre/xtensa-unknown-elf-binutils/PKGBUILD b/libre/xtensa-unknown-elf-binutils/PKGBUILD
index e50dc2fe8..914ee306d 100644
--- a/libre/xtensa-unknown-elf-binutils/PKGBUILD
+++ b/libre/xtensa-unknown-elf-binutils/PKGBUILD
@@ -1,75 +1,72 @@
# Maintainer (Arch): Allan McRae <allan@archlinux.org>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
-# Maintainer: Márcio Silva <coadde@hyperbola.info>
+# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
# Maintainer: Luke R. <g4jc@openmailbox.org>
+# Maintainer: David P. <megver83@parabola.nu>
-pkgname=xtensa-unknown-elf-binutils
-pkgver=2.27
-_pkgverpatch=$pkgver
-pkgrel=1.92
+_target=xtensa-unknown-elf
+pkgname=$_target-binutils
+pkgver=2.29.1
+pkgrel=2
pkgdesc="A set of programs to assemble and manipulate binary and object files"
-arch=('i686' 'x86_64' 'armv7h')
+arch=('x86_64' 'i686' 'armv7h')
url="https://www.gnu.org/software/binutils/"
license=('GPL')
groups=('cross-devel')
-depends=('glibc>=2.24-2' 'zlib')
-checkdepends=('dejagnu' 'bc')
-options=('staticlibs' '!distcc' '!ccache')
-source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig}
- https://repo.parabola.nu/other/binutils/$_pkgverpatch/binutils-xtensa.patch)
-validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93') # Tristan Gingold <gingold@adacore.com>
-sha512sums=('cf276f84935312361a2ca077e04d0b469d23a3aed979d8ba5d92ea590904ffb2c2e7ed12cc842822bfc402836be86f479660cef3791aa62f3753d8a1a6f564cb'
+depends=('zlib')
+source=("https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2"{,.sig}
+ 'https://github.com/qca/open-ath9k-htc-firmware/raw/master/local/patches/binutils.patch')
+sha512sums=('4063d34555526922376ccceb3f14b43e287442e82a8038cf50f4f51ad97d438c672c0e310ca4b856c9aff5aa9911073e256e8298a7a3f1844eeb60b90d955592'
'SKIP'
'e10ed358794d7aa32ac25087afd804dc4c3028c4664d7608eb86147f041561d16209afa6501bc8a19e02386674011d567640175f6b8bf89275c243dc3b3a9980')
+validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
+ '3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
prepare() {
cd binutils-$pkgver
-
- # hack! - libiberty configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
-
- # open-ath9k-htc-firmware patch
- patch -p1 -i ${srcdir}/binutils-xtensa.patch
-
- mkdir ${srcdir}/binutils-build
+ patch -p1 -i ../binutils.patch
}
build() {
- cd binutils-build
+ cd binutils-$pkgver
- ../binutils-$pkgver/configure \
- --prefix=/usr \
- --with-lib-path=/usr/lib:/usr/local/lib \
- --with-bugurl=https://labs.parabola.nu/ \
- --enable-threads \
- --with-pic \
- --enable-ld=default \
- --enable-gold \
- --enable-plugins \
- --enable-deterministic-archives \
- --disable-werror \
- --disable-gdb \
- --disable-nls \
- --target=xtensa-unknown-elf --with-sysroot=/usr/xtensa-unknown-elf
+ if [ "${CARCH}" != "i686" ]; then
+ # enabling gold linker at i686 makes the install fail
+ enable_gold='--enable-gold'
+ fi
- # check the host environment and makes sure all the necessary tools are available
- make configure-host
+ ./configure --target=$_target \
+ --with-sysroot=/usr/$_target \
+ --prefix=/usr \
+ --disable-multilib \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --disable-nls \
+ --enable-ld=default \
+ $enable_gold \
+ --enable-plugins \
+ --enable-deterministic-archives
- make tooldir=/usr
+ make
}
check() {
- cd binutils-build
+ cd binutils-$pkgver
# unset LDFLAGS as testsuite makes assumptions about which ones are active
- # ignore failures in gold testsuite...
+ # do not abort on errors - manually check log files
make -k LDFLAGS="" check || true
}
package() {
- cd binutils-build
- make prefix=${pkgdir}/usr install
+ cd binutils-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ # Remove file conflicting with host binutils and manpages for MS Windows tools
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,nlmconv,windres,windmc}*
# Remove info documents that conflict with host version
- rm -rf ${pkgdir}/usr/share/info
+ rm -r "$pkgdir"/usr/share/info
}