summaryrefslogtreecommitdiff
path: root/libre/xorg-fonts-type1-libre/PKGBUILD
diff options
context:
space:
mode:
authorMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-06-21 03:59:49 -0300
committerMárcio Alexandre Silva Delgado <coadde@lavabit.com>2013-06-21 03:59:49 -0300
commitc21f5170cf7f58becfd63c3f4be4bfe8e8bf7755 (patch)
tree4ebe38fd72b700eac8b05d456b2348ab6b42fcc0 /libre/xorg-fonts-type1-libre/PKGBUILD
parent5bb09e8eb70b20a612c3f2cb795a8a61980ae4e3 (diff)
parentad8ee0a3286648535e7987cfaa38ecb274a7542f (diff)
downloadabslibre-c21f5170cf7f58becfd63c3f4be4bfe8e8bf7755.tar.gz
abslibre-c21f5170cf7f58becfd63c3f4be4bfe8e8bf7755.tar.bz2
abslibre-c21f5170cf7f58becfd63c3f4be4bfe8e8bf7755.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'libre/xorg-fonts-type1-libre/PKGBUILD')
-rw-r--r--libre/xorg-fonts-type1-libre/PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/libre/xorg-fonts-type1-libre/PKGBUILD b/libre/xorg-fonts-type1-libre/PKGBUILD
index 3e52ef85a..4904a4477 100644
--- a/libre/xorg-fonts-type1-libre/PKGBUILD
+++ b/libre/xorg-fonts-type1-libre/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 71695 2010-03-08 13:31:38Z jgc $
+# $Id: PKGBUILD 150375 2012-02-17 09:54:09Z allan $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=xorg-fonts-type1-libre
pkgver=7.4
-pkgrel=1
-pkgdesc="X.org Type1 fonts without Adobe fonts"
+pkgrel=2
+pkgdesc="X.org Type1 fonts, without nonfree fonts"
arch=(any)
license=('custom')
url="http://xorg.freedesktop.org/"
@@ -20,15 +20,25 @@ md5sums=('27c55f6a938e7153c59fb551b2f491f9'
build() {
cd "${srcdir}"
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
for dir in *; do
if [ -d "${dir}" ]; then
pushd "${dir}"
./configure --prefix=/usr \
- --with-fontdir=/usr/share/fonts/Type1 || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.${dir%-*}" || return 1
+ --with-fontdir=/usr/share/fonts/Type1
+ make
+ popd
+ fi
+ done
+}
+
+package() {
+ cd "${srcdir}"
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ for dir in *; do
+ if [ -d "${dir}" ]; then
+ pushd "${dir}"
+ make DESTDIR="${pkgdir}" install
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.${dir%-*}"
popd
fi
done