summaryrefslogtreecommitdiff
path: root/libre/uboot4extlinux-omap3/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2020-08-14 16:11:22 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2020-08-14 16:16:39 +0200
commit67c574bbda146dbaf74221f9c520973d633bab62 (patch)
tree4f1747297f7a26a7e62b0964fcc01afe20b0bd34 /libre/uboot4extlinux-omap3/PKGBUILD
parent17abe9678b3b6e0610fe40e67484d225bcddc706 (diff)
downloadabslibre-67c574bbda146dbaf74221f9c520973d633bab62.tar.gz
abslibre-67c574bbda146dbaf74221f9c520973d633bab62.tar.bz2
abslibre-67c574bbda146dbaf74221f9c520973d633bab62.zip
libre: Merge uboot4extlinux{am335x,omap3}, uboot-omap4_panda: into uboot4extlinux-ti-soc
uboot4extlinux-am335x and uboot4extlinux-omap3 were almost identical, the only difference was the extlinux.conf file. So they were migrated together in a single package for all TI SOCs. I think having a single package saves maintenance time: We only have one package to update for all the supported boards. One downside is that it can increase the compilation time, but in overal it probably saves a lot of time. Another downside is that we cannot test the package separately for each boards and have to test all the boards for each new update. However since we are very close to upstream u-boot, there is very few probability of having breakages that we don't know about. Factorizing the package can also increase confidence that it will work on the boards we don't have, by testing on the boards we have. For instance I've only been able to test this package on the following boards as I don't have any of the other boards: - Beagleboard XM - Beaglebone Green The support for the Pandaborad from uboot-omap4_panda was added along the way to furthurer unify u-boot packages. In addition the version was updated and some whitespace fixes were done. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'libre/uboot4extlinux-omap3/PKGBUILD')
-rw-r--r--libre/uboot4extlinux-omap3/PKGBUILD85
1 files changed, 0 insertions, 85 deletions
diff --git a/libre/uboot4extlinux-omap3/PKGBUILD b/libre/uboot4extlinux-omap3/PKGBUILD
deleted file mode 100644
index 786e33996..000000000
--- a/libre/uboot4extlinux-omap3/PKGBUILD
+++ /dev/null
@@ -1,85 +0,0 @@
-# U-Boot: BeagleBoard
-# Maintainer: André Silva <emulatorman@hyperbola.info>
-# Contributor: Jookia <166291@gmail.com>
-# Contributor: Márcio Silva <coadde@hyperbola.info>
-
-pkgbase=uboot4extlinux-omap3
-pkgname=('uboot4extlinux-omap3_beagle')
-pkgver=2020.04
-pkgrel=1
-arch=('armv7h')
-url="http://git.denx.de/u-boot.git/"
-license=('GPL')
-makedepends=('bc' 'bison' 'dtc' 'flex' 'python' 'python2' 'swig')
-backup=(boot/extlinux/extlinux.conf)
-source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
- '0001-omap34xx-SPL-enable-MMC-raw-boot-with-u-boot.img.patch'
- 'extlinux.conf')
-sha256sums=('fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372'
- 'SKIP'
- 'SKIP')
-
-boards=('omap3_beagle')
-
-prepare() {
- cd u-boot-${pkgver}
-
- # The default is 0x300 512b blocks which forces u-boot.img to be locarted at
- # 384k on the microSD. As u-boot.img is big, it often goes over the 1MB empty
- # space that is created by default when partitioning block devices. That
- # corrupts the first partition. Using 0x200 leaves more space to u-boot.img
- # and is well aligned to 128k.
- echo 'CONFIG_SYS_MMCSD_RAW_MODE_U_BOOT_SECTOR=0x200' >> configs/omap3_beagle_defconfig
-
- # See the 0001-omap34xx-SPL-enable-MMC-raw-boot-with-u-boot.img.patch for
- # rationale for this configuration
- echo '# CONFIG_SPL_RAW_IMAGE_SUPPORT is not set' >> configs/omap3_beagle_defconfig
-
- # We want to enable users to use both RAW mode and filesystems to install
- # u-boot, but as filesystems are more complicated due to constraints that
- # need to be respected for it to work we default to raw block. This patch
- # restores the ability of using RAW block mode. RAW partitions have not been
- # tested yet and may or may not work but they have constraints as well.
- patch -Np1 -i ../0001-omap34xx-SPL-enable-MMC-raw-boot-with-u-boot.img.patch
-}
-
-build() {
- cd u-boot-${pkgver}
-
- unset CFLAGS CXXFLAGS LDFLAGS
-
- for i in ${boards[@]}; do
- mkdir -p ../bin_${i}
- make distclean
- make ${i}_defconfig
- echo 'CONFIG_IDENT_STRING=" Parabola GNU/Linux-libre"' >> .config
- make EXTRAVERSION=-${pkgrel}
- mv -f MLO u-boot.img ../bin_${i}
- done
-}
-
-package_uboot4extlinux-omap3_beagle() {
- pkgdesc="U-Boot with Extlinux support for various BeagleBoards"
-
- install=${pkgbase}.install
- provides=('uboot4extlinux-omap3')
- conflicts=('grub-omap3_beagle'
- 'grub-omap3_beagle_xm'
- 'grub-omap3_beagle_xm_ab'
- 'uboot-omap3_beagle')
-
- install -d "${pkgdir}"/boot/extlinux
- install -d "${pkgdir}"/boot/u-boot/images/
-
- install -Dm644 \
- bin_omap3_beagle/MLO \
- bin_omap3_beagle/u-boot.img \
- "${pkgdir}"/boot/u-boot/images/
-
- install -Dm644 extlinux.conf "${pkgdir}"/boot/extlinux
-
- # Package documentation as well
- install -d "${pkgdir}"/usr/share/doc/u-boot
- # The README might be converted to ReStructuredText at some point and be moved because of that
- install -Dm644 u-boot-${pkgver}/doc/README.omap3 "${pkgdir}"/usr/share/doc/u-boot/
-}