summaryrefslogtreecommitdiff
path: root/libre/uboot-wandboard/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 03:54:44 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2016-03-02 03:54:44 -0300
commitb32b93d29dd6eeabc87cb9938c66c2139604f867 (patch)
tree68512849a7431b281ed0ea2b567c5a75d6416a09 /libre/uboot-wandboard/PKGBUILD
parent4c540714d37103329a5411d4d9e446a3eb323c01 (diff)
downloadabslibre-b32b93d29dd6eeabc87cb9938c66c2139604f867.tar.gz
abslibre-b32b93d29dd6eeabc87cb9938c66c2139604f867.tar.bz2
abslibre-b32b93d29dd6eeabc87cb9938c66c2139604f867.zip
uboot-wandboard: add new package to [libre]
Diffstat (limited to 'libre/uboot-wandboard/PKGBUILD')
-rw-r--r--libre/uboot-wandboard/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/libre/uboot-wandboard/PKGBUILD b/libre/uboot-wandboard/PKGBUILD
new file mode 100644
index 000000000..858fb4de6
--- /dev/null
+++ b/libre/uboot-wandboard/PKGBUILD
@@ -0,0 +1,43 @@
+# U-Boot: Wandboard
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+pkgname=uboot-wandboard
+pkgver=2015.10
+pkgrel=1.parabola1
+pkgdesc="U-Boot for Wandboard"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+license=('GPL')
+makedepends=('bc')
+depends=('linux-libre')
+replaces=('uboot-wandboard-solo' 'uboot-wandboard-dual' 'uboot-wandboard-quad' 'uboot-wandboard-linux-libre')
+conflicts=('uboot4extlinux-wandboard' 'uboot4grub-wandboard')
+install=${pkgname}.install
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
+ '0001-parabola-arm-modifications.patch')
+md5sums=('7c203b0fc3390a122d8e8b75f147eac5'
+ '87a2643750ab2152c6c91415e3949807')
+
+prepare() {
+ cd u-boot-${pkgver}
+ patch -Np1 -i ../0001-parabola-arm-modifications.patch
+}
+
+build() {
+ cd u-boot-${pkgver}
+
+ unset LDFLAGS
+
+ make distclean
+ make wandboard_defconfig
+ make
+}
+
+package() {
+ cd u-boot-${pkgver}
+
+ mkdir -p "${pkgdir}"/boot
+ cp SPL u-boot.img "${pkgdir}"/boot
+}