summaryrefslogtreecommitdiff
path: root/libre/systemd/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-03-13 03:41:24 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-03-13 03:41:24 -0500
commitadb1d0db1ac5a7eb1e6480a49e1981cddb431017 (patch)
tree7648cc8dd9fd9b59de6b02787b49bf8568663aab /libre/systemd/PKGBUILD
parent5fed6ef4ba36f621ad6ff0ab01a32e718641a4f2 (diff)
downloadabslibre-adb1d0db1ac5a7eb1e6480a49e1981cddb431017.tar.gz
abslibre-adb1d0db1ac5a7eb1e6480a49e1981cddb431017.tar.bz2
abslibre-adb1d0db1ac5a7eb1e6480a49e1981cddb431017.zip
systemd-238.0-3.parabola1: updating version
Diffstat (limited to 'libre/systemd/PKGBUILD')
-rw-r--r--libre/systemd/PKGBUILD145
1 files changed, 77 insertions, 68 deletions
diff --git a/libre/systemd/PKGBUILD b/libre/systemd/PKGBUILD
index 3e4ad21f1..2730a5c5f 100644
--- a/libre/systemd/PKGBUILD
+++ b/libre/systemd/PKGBUILD
@@ -9,12 +9,10 @@ pkgname=('systemd' 'libsystemd' 'systemd-sysvcompat')
# We split Arch's libsystemd into the following:
_libsystemd=('libsystemd-standalone' 'libudev' 'nss-systemd' 'nss-myhostname' 'nss-mymachines' 'nss-resolve')
pkgname+=("${_libsystemd[@]}")
-# latest commit on stable branch
-_commit='46659f7deb962f55c728e70597e37c2a3ab6326d'
-# Bump this to latest major release for signed tag verification,
-# the commit count is handled by pkgver() function.
-pkgver=237.0
-pkgrel=2
+# Can be from either systemd or systemd-stable
+_commit='738ab7502afb7663d9aacdd73e79025aa7cd0a9b'
+pkgver=238.0
+pkgrel=3
pkgrel+=.parabola1
arch=('x86_64')
arch+=('i686' 'armv7h')
@@ -27,9 +25,11 @@ makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
makedepends_i686=('gnu-efi-libs')
makedepends_x86_64=('gnu-efi-libs')
options=('strip')
-validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4') # Lennart Poettering <lennart@poettering.net>
-source=('git://github.com/systemd/systemd-stable.git'
- 'git://github.com/systemd/systemd.git' # pull in for tags, backports & reverts
+validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
+ '5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
+source=('git+https://github.com/systemd/systemd-stable'
+ 'git+https://github.com/systemd/systemd'
+ '0001-Use-Arch-device-access-groups.patch'
'initcpio-hook-udev'
'initcpio-install-systemd'
'initcpio-install-udev'
@@ -37,9 +37,15 @@ source=('git://github.com/systemd/systemd-stable.git'
'loader.conf'
'splash-parabola.bmp'
'systemd-user.pam'
+ 'systemd-hook'
+ 'systemd-binfmt.hook'
+ 'systemd-catalog.hook'
+ 'systemd-daemon-reload.hook'
'systemd-hwdb.hook'
+ 'systemd-sysctl.hook'
'systemd-sysusers.hook'
'systemd-tmpfiles.hook'
+ 'systemd-udev-reload.hook'
'systemd-update.hook'
'0001-FSDG-man-Refer-to-the-operating-system-as-GNU-Linux.patch'
'0002-FSDG-os-release-Default-PRETTY_NAME-to-GNU-Linux-ins.patch'
@@ -50,6 +56,7 @@ source=('git://github.com/systemd/systemd-stable.git'
'0007-FSDG-bootctl-Say-Systemd-Boot-Manager-instead-of-Lin.patch')
sha512sums=('SKIP'
'SKIP'
+ '9348683829190628e25b7b3300fd880c426d555bde330d5fc5150a9a54b3ad9d4d1f2e69ea1dc6d6f086693dacc53c5af30f1fa7ad9b479791fd77bcdafa430e'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
'86d7cacd7536b1069c82bbbb08de7ec81e7f0f18a19fc2b06fabe90db4700623eb3540b75121080d325672d92e26912632ae4f93fd3c0bb48eb3e5eedd88352c'
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
@@ -57,27 +64,36 @@ sha512sums=('SKIP'
'6c6f579644ea2ebb6b46ee274ab15110718b0de40def8c30173ba8480b045d403f2aedd15b50ad9b96453f4ad56920d1350ff76563755bb9a80b10fa7f64f1d9'
'a50bc85061a9a16d776235099867bc1a17c17dddb74c1ecf5614c849735a9779c5e34e5ddca8ca6af4b59a40f57c08ecf219b98cab09476ddb0f110e6a35e45c'
'b90c99d768dc2a4f020ba854edf45ccf1b86a09d2f66e475de21fe589ff7e32c33ef4aa0876d7f1864491488fd7edb2682fc0d68e83a6d4890a0778dc2d6fe19'
- '2c1f765e7cefc50f07ad994634ea25d9396e6b9c0de46e58f18377e642a471517a0dbf5eb547070a38c6ecf84ec8e030f650a6cee010871cd7a466a32534adda'
- '7d49a948f5d58f662a7d81544254528257ef8c0a08ca560834f09a7cdf566161d2df4d419ebbc2983196cd45c9eeefcd0c4c2c554376916dce42e895262afc30'
- 'e521d92674597f82d589b83c378c50c92c881fdb84c436c8b26f7a3436a4c91a20585824a5563933f6868a3023b9ee2fdc7bd58e04bb47c25a0a36e296308fd3'
- '10190fba9f39a8f4b620a0829e0ba8ed63bb4dbeca712966011ee7807880d01ab2abff1a80baafeb6674db70526a473fe585db8190e864f318fc4d6068552618'
+ 'eb7bb8ac1fa474c4ef603a22ee93b9142552a7752e6346c41950de4eaaff1ec8aa57f1cedbc2990a4ddcc3390f2d6cfb5ac6096fffa0e0a6d473684bb98f3bbe'
+ '46f93725bc94381300535737fd0186a3c096fa83661179eab0c450c7b164a87d9a5dd9abcf6ae98bdeb4bf50a4ba4f1944769948c236e4814f166ff03b0ee177'
+ '4cff2ebd962e26e2f516d8b4ac45c839dbfa54dd0588b423c224a328b9f7c62306ca7b2f6cb55240c564caf9972d5bcd2e0efaf2de49d64729aeb3bc1560c9eb'
+ '872de70325e9798f0b5a77e991c85bd2ab6de24d9b9ba4e35002d2dd5df15f8b30739a0042a624776177ffc14a838cde7ee98622016ed41df3efda9a659730b2'
+ '471342b8d0e05533908cda5d6a906050a51e3181beda1239e91d717029ee40a9eaed714996a445417d87c4e31b7f8522a665de176077fe0536d538369594996d'
+ '3b11e8956169e6d80eca6e6de1b3e42641454d9d7be48961d400754f2242077d69fb7bfbeb0904f35ce569511036a7c9614a4a1cc3096fba993f46ae65e02895'
+ 'bf3225011760695040e9f7be2560348e68e86eac0295f5a17a6f7e3dda7ad7c008812a15904e2071b53d5f8048891602c8a9a18608ac64930f2d8cc4fac2a319'
+ 'ff1429a7c88e21d578c25d07e8cd9568577feb5a940fe39a7a815cf8431c57ca951ac6b394c53d2cdeb4efc645572c0b1b670a48cafcc405db41a6602b548e35'
+ 'e4a9d7607fe93daf1d45270971c8d8455c4bfc2c0bea8bcad05aeb89847edee23cd1a41073a72042622acf417018fe254f5bfc137604fe2c71292680bf67a1c2'
+ '209b01b044877cc986757fa4009a92ea98f480306c2530075d153203c3cd2b3afccab6aacc1453dee8857991e04270572f1700310705d7a0f4d5bed27fab8c67'
'107d2e36544aa8ef1c6e86339fbc811acb6e1d15eb0edca9f463bdd1b0e91fa8d85cf8c9e70eeaf4196e2f942e30310b672859191f3093c4806546ae30140fb9'
'7445f9802cc194e27238cc89954c1035b0bf0c32b2702a7cbf463f701c4f87a416d7f3f75cc3eb9abe276ac7e49d377451c3727523544568420e348d47c1ef4c'
'7b969dc665281eb43871cf399398ddc25a16f533919dfbf721e2a2eb922cde6936c42400083ef39d5cc873a0b2bf749897c9bb1aaa38624315b8e5810f82efca'
'fbcc54a62b6f3f7ec1dfad8317160c3057f145e542a423a2fd6b5c141012929aeb977491afe35b16c4903b5fd0d1469f3d87d1c8a036b4d6b623ac7dbe682ff5'
'4e86eac4132d5bd712061d09c14141d91e6bfd2f3879a1fc4a92a15fa77d01552de5c9ebae4a67be2b2a54223a53f2538ba03d4fa0c96ecd1e62a4e8cf341fd1'
- '44aefd4b9dd6b5c3d57ff1647cd21a88cd5dc4eb2edab5c0232eb4e8ecd35dc778564699580011bf2c092d4fcf9bbe7f9e6db5088345eedb1895c64eb1e3a5d3'
+ 'b94fc1dee0707aec7c94a1e9e709f98a54018f94b44159b95b4a7fd01446bdd30a6b2d440926448c10a33e62092d6cf8e051ef27f26a369797bafbef093418bb'
'6a16666f18b7075a68733376f4b1fe34dd2aa29eaf43e693a98e303b9c5202317636816cb4a914d5141801026d1693dd4de2f79e0950aa777e8de6e4879cd9d0')
_backports=(
+ # core: do not free heap-allocated strings (#8391) (FS#57741)
+ '5cbaad2f6795088db56063d20695c6444595822f'
)
_reverts=(
)
-_validate_tag() {
+_validate_tag() (
local success fingerprint trusted status tag=v${pkgver%.*}
+ cd "$srcdir/$pkgbase-stable"
parse_gpg_statusfile /dev/stdin < <(git verify-tag --raw "$tag" 2>&1)
if (( ! success )); then
@@ -100,7 +116,7 @@ _validate_tag() {
esac
return 0
-}
+)
pkgver() {
local version count
@@ -115,21 +131,22 @@ pkgver() {
prepare() {
cd "$pkgbase-stable"
- git remote add upstream ../systemd/
- git fetch --all
-
- git checkout "${_commit}"
+ git remote add -f upstream ../systemd
+ git checkout "$_commit"
_validate_tag || return
- local _commit
- for _commit in "${_backports[@]}"; do
- git cherry-pick -n "$_commit"
+ local c
+ for c in "${_backports[@]}"; do
+ git cherry-pick -n "$c"
done
- for _commit in "${_reverts[@]}"; do
- git revert -n "$_commit"
+ for c in "${_reverts[@]}"; do
+ git revert -n "$c"
done
+ # Replace cdrom/dialout/tape groups with optical/uucp/storage
+ patch -Np1 -i ../0001-Use-Arch-device-access-groups.patch
+
# apply FSDG patches
local _patch
for _patch in "$srcdir"/????-FSDG-*.patch; do
@@ -199,12 +216,17 @@ build() {
done
install -dm755 "$srcdir/dest/systemd-sysvcompat"/usr/share/man/man8
- mv "$srcdir/dest/systemd"/usr/share/man/man8/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8 \
+ mv "$srcdir/dest/systemd"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
-t "$srcdir/dest/systemd-sysvcompat"/usr/share/man/man8
rmdir "$srcdir/dest"/systemd/usr/{share/man/man3,lib/pkgconfig,include}
}
+check() {
+ cd build
+ meson test
+}
+
package_systemd() {
pkgdesc="system and service manager"
license=('GPL2' 'LGPL2.1')
@@ -230,64 +252,52 @@ package_systemd() {
etc/systemd/resolved.conf
etc/systemd/user.conf
etc/udev/udev.conf)
- install="systemd.install"
+ install=systemd.install
cp -rT -d --no-preserve=ownership,timestamp "$srcdir/dest/$pkgbase" "$pkgdir"
# don't write units to /etc by default. some of these will be re-enabled on
# post_install.
- rm -r "$pkgdir/etc/systemd/system/"*.wants
- rm -r "$pkgdir/etc/systemd/system/"*.service
+ rm -rv "$pkgdir"/etc/systemd/system/*
+
+ # we'll create this on installation
+ rmdir "$pkgdir"/var/log/journal/remote
+
+ # avoid a potential conflict with [core]/filesystem
+ rm "$pkgdir"/usr/share/factory/etc/nsswitch.conf
+ sed -i '/^C \/etc\/nsswitch\.conf/d' "$pkgdir"/usr/lib/tmpfiles.d/etc.conf
- # add back tmpfiles.d/legacy.conf
- install -m644 "$pkgbase-stable/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
+ # add back tmpfiles.d/legacy.conf, normally omitted without sysv-compat
+ install -m644 $pkgbase-stable/tmpfiles.d/legacy.conf "$pkgdir"/usr/lib/tmpfiles.d
- # Replace dialout/tape/cdrom group in rules with uucp/storage/optical group
- sed -i 's#GROUP="dialout"#GROUP="uucp"#g;
- s#GROUP="tape"#GROUP="storage"#g;
- s#GROUP="cdrom"#GROUP="optical"#g' "$pkgdir"/usr/lib/udev/rules.d/*.rules
- sed -i 's/dialout/uucp/g;
- s/tape/storage/g;
- s/cdrom/optical/g' "$pkgdir"/usr/lib/sysusers.d/basic.conf
+ # ship default policy to leave services disabled
+ echo 'disable *' >"$pkgdir"/usr/lib/systemd/system-preset/99-default.preset
# add mkinitcpio hooks
- install -Dm644 "$srcdir/initcpio-install-systemd" "$pkgdir/usr/lib/initcpio/install/systemd"
- install -Dm644 "$srcdir/initcpio-install-udev" "$pkgdir/usr/lib/initcpio/install/udev"
- install -Dm644 "$srcdir/initcpio-hook-udev" "$pkgdir/usr/lib/initcpio/hooks/udev"
+ install -Dm644 initcpio-install-systemd "$pkgdir"/usr/lib/initcpio/install/systemd
+ install -Dm644 initcpio-install-udev "$pkgdir"/usr/lib/initcpio/install/udev
+ install -Dm644 initcpio-hook-udev "$pkgdir"/usr/lib/initcpio/hooks/udev
# ensure proper permissions for /var/log/journal
# The permissions are stored with named group by tar, so this works with
# users and groups populated by systemd-sysusers. This is only to prevent a
# warning from pacman as permissions are set by systemd-tmpfiles anyway.
- chown root:systemd-journal "$pkgdir/var/log/journal"
- chmod 2755 "$pkgdir/var/log/journal"
+ install -d -o root -g systemd-journal -m 2755 "$pkgdir"/var/log/journal
- # match directory owner/group and mode from extra/polkit
- chown root:102 "$pkgdir"/usr/share/polkit-1/rules.d
- chmod 0750 "$pkgdir"/usr/share/polkit-1/rules.d
-
- # we'll create this on installation
- rmdir "$pkgdir/var/log/journal/remote"
-
- # ship default policy to leave services disabled
- echo 'disable *' >"$pkgdir"/usr/lib/systemd/system-preset/99-default.preset
-
- # allow core/filesystem to pristine nsswitch.conf
- rm "$pkgdir/usr/share/factory/etc/nsswitch.conf"
- sed -i '/^C \/etc\/nsswitch\.conf/d' "$pkgdir/usr/lib/tmpfiles.d/etc.conf"
+ # match directory owner/group and mode from [extra]/polkit
+ install -d -o root -g 102 -m 750 "$pkgdir"/usr/share/polkit-1/rules.d
# add example bootctl configuration
- install -Dm644 "$srcdir/parabola.conf" "$pkgdir"/usr/share/systemd/bootctl/parabola.conf
- install -Dm644 "$srcdir/loader.conf" "$pkgdir"/usr/share/systemd/bootctl/loader.conf
- install -Dm644 "$srcdir/splash-parabola.bmp" "$pkgdir"/usr/share/systemd/bootctl/splash-parabola.bmp
+ install -Dm644 parabola.conf "$pkgdir"/usr/share/systemd/bootctl/parabola.conf
+ install -Dm644 loader.conf "$pkgdir"/usr/share/systemd/bootctl/loader.conf
+ install -Dm644 splash-parabola.bmp "$pkgdir"/usr/share/systemd/bootctl/splash-parabola.bmp
- install -Dm644 "$srcdir/systemd-hwdb.hook" "$pkgdir/usr/share/libalpm/hooks/systemd-hwdb.hook"
- install -Dm644 "$srcdir/systemd-sysusers.hook" "$pkgdir/usr/share/libalpm/hooks/systemd-sysusers.hook"
- install -Dm644 "$srcdir/systemd-tmpfiles.hook" "$pkgdir/usr/share/libalpm/hooks/systemd-tmpfiles.hook"
- install -Dm644 "$srcdir/systemd-update.hook" "$pkgdir/usr/share/libalpm/hooks/systemd-update.hook"
+ # pacman hooks
+ install -Dm755 systemd-hook "$pkgdir"/usr/share/libalpm/scripts/systemd-hook
+ install -Dm644 -t "$pkgdir"/usr/share/libalpm/hooks *.hook
# overwrite the systemd-user PAM configuration with our own
- install -Dm644 systemd-user.pam "$pkgdir/etc/pam.d/systemd-user"
+ install -Dm644 systemd-user.pam "$pkgdir"/etc/pam.d/systemd-user
}
package_libsystemd() {
@@ -355,12 +365,11 @@ package_systemd-sysvcompat() {
cp -rT -d --no-preserve=ownership,timestamp "$srcdir/dest/$pkgname" "$pkgdir"
- install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir"/usr/bin
+ ln -s ../lib/systemd/systemd "$pkgdir"/usr/bin/init
for tool in runlevel reboot shutdown poweroff halt telinit; do
- ln -s 'systemctl' "$pkgdir/usr/bin/$tool"
+ ln -s systemctl "$pkgdir"/usr/bin/$tool
done
-
- ln -s '../lib/systemd/systemd' "$pkgdir/usr/bin/init"
}
# vim: ft=sh syn=sh et