summaryrefslogtreecommitdiff
path: root/libre/systemd/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2017-08-15 12:27:59 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2017-08-15 12:27:59 -0500
commit8522ed614e9e89a18f2c9308b8678ccf0b00ea39 (patch)
tree058e160467f8c8f0ec80a2d1a1cd03c553128186 /libre/systemd/PKGBUILD
parentfe70831db7feff09e64f0397297cf9c1d81de5ae (diff)
downloadabslibre-8522ed614e9e89a18f2c9308b8678ccf0b00ea39.tar.gz
abslibre-8522ed614e9e89a18f2c9308b8678ccf0b00ea39.tar.bz2
abslibre-8522ed614e9e89a18f2c9308b8678ccf0b00ea39.zip
systemd-234.11-6.parabola1: updating version
Diffstat (limited to 'libre/systemd/PKGBUILD')
-rw-r--r--libre/systemd/PKGBUILD95
1 files changed, 43 insertions, 52 deletions
diff --git a/libre/systemd/PKGBUILD b/libre/systemd/PKGBUILD
index 03b4355d0..d860c72b2 100644
--- a/libre/systemd/PKGBUILD
+++ b/libre/systemd/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer (Arch): Dave Reisner <dreisner@archlinux.org>
# Maintainer (Arch): Tom Gundersen <teg@jklm.no>
# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgbase=systemd
pkgname=('systemd' 'libsystemd' 'systemd-sysvcompat')
pkgname+=('libsystemd-standalone' 'libudev' 'nss-myhostname' 'nss-mymachines' 'nss-resolve')
# latest commit on stable branch
-_commit='27c7bc970d9e7ffe060688a8dd77b7747503a564'
+_commit='d52e2bb9c20216972754c054e8534bca28baab66'
# Bump this to latest major release for signed tag verification,
# the commit count is handled by pkgver() function.
-pkgver=233.75
-pkgrel=3
+pkgver=234.11
+pkgrel=6
pkgrel+=.parabola1
arch=('i686' 'x86_64')
arch+=('armv7h')
@@ -18,7 +19,8 @@ url="https://www.github.com/systemd/systemd"
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn' 'libgcrypt'
'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
- 'python-lxml' 'quota-tools' 'shadow' 'git')
+ 'python-lxml' 'quota-tools' 'shadow' 'git'
+ 'meson')
makedepends_i686=('gnu-efi-libs')
makedepends_x86_64=('gnu-efi-libs')
options=('strip')
@@ -45,7 +47,7 @@ source=("git://github.com/systemd/systemd-stable.git#commit=${_commit}"
sha512sums=('SKIP'
'SKIP'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
- '691acebb243b9cd7fb63272662f34bdb9aead710c69aee9361ab2322f9f108600ad5b0214fc00b7cb2d9c95db8abd748030625d60d6567efd98663c56ba28c65'
+ 'a70a779828e03c91275df1e046f78bdface08e2a8df0245a3f6e8d5904e3dbbe5d498cbf7f32d5ce61f2fb0d0a3d440d47ce9e41352a5547d80fa1bc29687159'
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
'70b3f1d6aaa9cd4b6b34055a587554770c34194100b17b2ef3aaf4f16f68da0865f6b3ae443b3252d395e80efabd412b763259ffb76c902b60e23b6b522e3cc8'
'6c6f579644ea2ebb6b46ee274ab15110718b0de40def8c30173ba8480b045d403f2aedd15b50ad9b96453f4ad56920d1350ff76563755bb9a80b10fa7f64f1d9'
@@ -67,21 +69,19 @@ validpgpkeys=(
)
_backports=(
- # build-sys: make RPM macros installation path configurable
- 'ff2e33db54719bfe8feea833571652318c6d197c'
- # resolved: do not start LLMNR or mDNS stack when no network enables them
- '2c7ef56459bf6fe7761595585aa4eed5cd183f27^..2c7ef56459bf6fe7761595585aa4eed5cd183f27^2'
- # networkd: RFC compliant autonomous prefix handling (#5636)
- '6554550f35a7976f9110aff94743d3576d5f02dd'
- # core: do not print color console message about gc-ed jobs
- '047d7219fde661698d3487fc49e9878c61eefd77'
+ # cryptsetup: fix infinite timeout (#6486)
+ '0864d311766498563331f486909a0d950ba7de87'
+
+ # process-util: add getpid_cached() as a caching wrapper for getpid()
+ '5c30a6d2b805ae9b5dd0ad003b9ee86b8965bc47'
+ # tree-wide: make use of getpid_cached() wherever we can
+ 'df0ff127758809a45105893772de76082d12a26d'
+
+ # call chase_symlinks without the /sysroot prefix (#6411) (FS#54958)
+ '98eda38aed6a10c4f6d6ad0cac6e5361e87de52b'
)
_reverts=(
- # core: store the invocation ID in the per-service keyring
- 'b3415f5daef49642be3d5f417b8880c078420ff7'
- # core: run each system service with a fresh session keyring
- '74dd6b515fa968c5710b396a7664cac335e25ca8'
)
_validate_tag() {
@@ -137,29 +137,20 @@ prepare() {
git revert -n "$_commit"
done
- # nss-resolve: drop the internal fallback to libnss_dns
- git show '5486a31d287f26bcd7c0a4eb2abfa4c074b985f1' -- \
- 'Makefile.am' 'src/nss-resolve/nss-resolve.c' | git apply --index
-
- # Resolved packet size (#6214) (FS#54619, CVE-2017-9445)
- git show '751ca3f1de316ca79b60001334dbdf54077e1d01' \
- 'db848813bae4d28c524b3b6a7dad135e426659ce' \
- '88795538726a5bbfd9efc13d441cb05e1d7fc139' \
- '64a21fdaca7c93f1c30b21f6fdbd2261798b161a' \
- -- . ':!src/resolve/meson.build' | git apply --index
+ # core: store the invocation ID in the per-service keyring
+ # core: run each system service with a fresh session keyring
+ git show 'b3415f5daef49642be3d5f417b8880c078420ff7' \
+ '74dd6b515fa968c5710b396a7664cac335e25ca8' \
+ -- . ':!src/test/test-id128.c' | git apply --reverse --index
# apply FSDG patches
local _patch
for _patch in "$srcdir"/????-FSDG-*.patch; do
patch -Np1 -i "$_patch"
done
-
- ./autogen.sh
}
build() {
- cd "$pkgbase-stable"
-
local timeservers=({0..3}.arch.pool.ntp.org)
if [ "$CARCH" = "armv7h" ]; then
@@ -168,39 +159,39 @@ build() {
CXXFLAGS+=" -fno-lto"
fi
- local configure_options=(
- --libexecdir=/usr/lib
- --localstatedir=/var
- --sysconfdir=/etc
-
- --enable-lz4
- --disable-audit
- --disable-ima
-
- --with-sysvinit-path=
- --with-sysvrcnd-path=
- --with-ntp-servers="${timeservers[*]}"
- --with-default-dnssec=no
- --with-dbuspolicydir=/usr/share/dbus-1/system.d
- --without-kill-user-processes
- --with-rpmmacrosdir=no
+ local meson_options=(
+ --buildtype=release
+ -Db_lto=true
+
+ -Daudit=false
+ -Dima=false
+ -Dlz4=true
+
+ -Ddbuspolicydir=/usr/share/dbus-1/system.d
+ -Ddefault-dnssec=no
# TODO(dreisner): consider changing this to unified
- --with-default-hierarchy=hybrid
+ -Ddefault-hierarchy=hybrid
+ -Ddefault-kill-user-processes=false
+ -Dfallback-hostname='parabola'
+ -Dntp-servers="${timeservers[*]}"
+ -Drpmmacrosdir=no
+ -Dsysvinit-path=
+ -Dsysvrcnd-path=
)
if [ "$CARCH" != "armv7h" ]; then
- configure_options+=(--enable-gnuefi)
+ meson_options+=(-Dgnuefi=true)
fi
- ./configure "${configure_options[@]}"
+ meson "$pkgbase-stable" build "${meson_options[@]}"
- make
+ ninja -C build
# Go ahead and split the package now. It's easier this way, because
# we can use mv instead of awkward, error-prone rm/cp pairs.
rm -rf "$srcdir/dest"
# Put things in the main systemd package by default
- make DESTDIR="$srcdir/dest/systemd" install
+ DESTDIR="$srcdir/dest/systemd" ninja -C build install
install -dm755 "$srcdir/dest/libsystemd"/usr/{lib/pkgconfig,share/man/man3,include}
mv -T "$srcdir/dest"/{systemd,libsystemd}/usr/include/systemd