summaryrefslogtreecommitdiff
path: root/libre/python-reportlab-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-04 21:38:52 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-04 21:38:52 -0300
commitad9f6d848f9b0fa975cffa7c919d02c404586ae3 (patch)
treedf129aeb062dfbd99145b714446d2cda40fe4807 /libre/python-reportlab-libre/PKGBUILD
parent6a928e2a05c80478bc9ff7ca0fe97140f33600ea (diff)
downloadabslibre-ad9f6d848f9b0fa975cffa7c919d02c404586ae3.tar.gz
abslibre-ad9f6d848f9b0fa975cffa7c919d02c404586ae3.tar.bz2
abslibre-ad9f6d848f9b0fa975cffa7c919d02c404586ae3.zip
python-reportlab: remove libre suffix and add complex pkgrel
Diffstat (limited to 'libre/python-reportlab-libre/PKGBUILD')
-rw-r--r--libre/python-reportlab-libre/PKGBUILD67
1 files changed, 0 insertions, 67 deletions
diff --git a/libre/python-reportlab-libre/PKGBUILD b/libre/python-reportlab-libre/PKGBUILD
deleted file mode 100644
index 40a2e2ef4..000000000
--- a/libre/python-reportlab-libre/PKGBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# $Id: PKGBUILD 110391 2014-04-28 19:17:21Z jelle $
-# Maintainer (Arch):
-# Contributor (Arch): Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
-# Contributor (Arch): William Rea <sillywilly@gmail.com>
-# Maintainer: fauno <fauno@kiwwwi.com.ar>
-# Contributor: borgo <nomail>
-# Contributor: André Silva <emulatorman@parabola.nu>
-
-pkgbase=python-reportlab-libre
-pkgname=(python2-reportlab-libre python-reportlab-libre)
-_origname=reportlab
-pkgver=3.1.8
-pkgrel=1
-pkgdesc="A proven industry-strength PDF generating solution, without nonfree Adobe T1 fonts support"
-arch=('i686' 'x86_64' 'mips64el')
-url="http://www.reportlab.org/rl_toolkit.html"
-depends=('freetype2')
-checkdepends=('python' 'python2' 'python2-pillow' 'python-pillow')
-license=('custom')
-source=("https://pypi.python.org/packages/source/r/reportlab/reportlab-$pkgver.tar.gz"
- 'free-fonts.patch')
-md5sums=(820a9fda647078503597b85cdba7ed7f
- eb3ac47734efb05b939fb88026aff8ed)
-
-prepare() {
- cd $srcdir
- cp -rf ${_origname}-$pkgver "${_origname}2-$pkgver"
-
- _reportlab_source=("${_origname}-$pkgver" "${_origname}2-$pkgver")
-
- for x in ${_reportlab_source[@]}; do
- cd $srcdir/$x
-
- # remove nonfree Adobe T1 fonts support
- patch -p1 -i $srcdir/free-fonts.patch
-
- # Parabola contains those fonts from the ttf-bitstream-vera package
- rm -fv src/reportlab/fonts/{bitstream-vera-license.txt,Vera*}
- done
-}
-
-package_python2-reportlab-libre() {
- conflicts+=('python2-reportlab' 'python-reportlab<=2.5-2')
- replaces+=('python2-reportlab' 'python-reportlab<=2.5-2')
- provides=("python2-reportlab=$pkgver")
- depends=('python2')
- cd "$srcdir/${_origname}2-$pkgver"
- python2 setup.py install --root=$pkgdir --optimize=1
- install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/$_pkgname/license.txt
-}
-
-package_python-reportlab-libre() {
- conflicts+=('python-reportlab' 'python-reportlab-libre<=2.5-2')
- replaces+=('python-reportlab' 'python-reportlab-libre<=2.5-2')
- provides=("python-reportlab=$pkgver")
- depends=('python3')
- cd "$srcdir/${_origname}-$pkgver"
- python3 setup.py install --root=$pkgdir --optimize=1
- install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/$_pkgname/license.txt
-}
-
-
-check() {
- cd ${srcdir}/${_origname}-${pkgver}
- python2 setup.py tests
- python setup.py tests
-}