summaryrefslogtreecommitdiff
path: root/libre/parley/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-17 18:40:23 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-17 18:40:41 +0100
commit0559cf69f878b44584787f85db8d0b571690da82 (patch)
tree6f751e016d69230cc4ab081611dc48de95a5140d /libre/parley/PKGBUILD
parent458b582de444324da88363c2437b850cc1decd5c (diff)
downloadabslibre-0559cf69f878b44584787f85db8d0b571690da82.tar.gz
abslibre-0559cf69f878b44584787f85db8d0b571690da82.tar.bz2
abslibre-0559cf69f878b44584787f85db8d0b571690da82.zip
libre/parley: added liberated version
Diffstat (limited to 'libre/parley/PKGBUILD')
-rw-r--r--libre/parley/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/libre/parley/PKGBUILD b/libre/parley/PKGBUILD
new file mode 100644
index 000000000..2504818a6
--- /dev/null
+++ b/libre/parley/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
+# Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
+# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=parley
+pkgver=17.12.1
+pkgrel=1.parabola1
+pkgdesc="Vocabulary Trainer, without qt5-webengine"
+url="https://kde.org/applications/education/parley/"
+arch=(x86_64)
+license=(GPL LGPL FDL)
+groups=(kde-applications kdeedu)
+depends=(kross knewstuff libkeduvocdocument qt5-webkit kcmutils)
+makedepends=(extra-cmake-modules kdoctools python)
+replaces=(kdeedu-parley)
+conflicts=(kdeedu-parley)
+source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
+ "libre.patch")
+sha256sums=('da2d3b6dcb7a858556a67c63957388b287c614ca5f290747f471b397359c38a5'
+ 'SKIP'
+ 'fa35b14d8c35cedf63685e5e9a8157dbc0bb5339c75a1356fb59359974c08e57')
+validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
+ F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
+
+prepare() {
+ mkdir -p build
+
+ # remove qt5-webengine references
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/libre.patch
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}