summaryrefslogtreecommitdiff
path: root/libre/p7zip-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-17 22:06:03 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-17 22:06:03 -0300
commitdd4a2c7a7603bc8dca3a1cf9179a09b2da120739 (patch)
tree4b682b0c4ffa642bb0c121efeba518a7f20af0d4 /libre/p7zip-libre/PKGBUILD
parent7e5148db4a1f4255d78a6e466be762ecf6d85674 (diff)
downloadabslibre-dd4a2c7a7603bc8dca3a1cf9179a09b2da120739.tar.gz
abslibre-dd4a2c7a7603bc8dca3a1cf9179a09b2da120739.tar.bz2
abslibre-dd4a2c7a7603bc8dca3a1cf9179a09b2da120739.zip
p7zip-libre-9.20.1-9.2: fix freedom issue #516 => https://labs.parabola.nu/issues/516
Diffstat (limited to 'libre/p7zip-libre/PKGBUILD')
-rw-r--r--libre/p7zip-libre/PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/libre/p7zip-libre/PKGBUILD b/libre/p7zip-libre/PKGBUILD
index f53c3a28d..101847382 100644
--- a/libre/p7zip-libre/PKGBUILD
+++ b/libre/p7zip-libre/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=p7zip-libre
_pkgname=${pkgname%-libre}
pkgver=9.20.1
-pkgrel=9.1
+pkgrel=9.2
pkgdesc='Command-line version of the 7zip compressed file archiver, without nonfree unrar support'
url='http://p7zip.sourceforge.net/'
license=('GPL')
@@ -21,25 +21,29 @@ optdepends=('wxgtk2.8: GUI'
'desktop-file-utils: desktop entries')
makedepends=('yasm' 'nasm' 'wxgtk2.8')
mksource=("http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}_${pkgver}_src_all.tar.bz2"
- 'p7zip-libre.patch')
+ 'p7zip-libre.patch' 'parent-folder-icon.patch')
source=("https://repo.parabolagnulinux.org/other/${pkgname}/${pkgname}_${pkgver}_src_all.tar.bz2"
'7zFM.desktop')
mksha1sums=('1cd567e043ee054bf08244ce15f32cb3258306b7'
- '8fc0e6e80aeec371a8c80e7a6082594ac6d08aed')
-sha1sums=('82a54887878e3fd90bfbd3c66d2ce3b6a3532a95'
+ '8fc0e6e80aeec371a8c80e7a6082594ac6d08aed'
+ '335a4a38d457d2b0166538d514ffd3c183bbb37f')
+sha1sums=('c6394aef55328b267152a2450f4fc842fcb8be50'
'f2c370d6f1b286b7ce9a2804e22541b755616a40')
options=('!makeflags')
install=install
mksource() {
- cd "${srcdir}/${_pkgname}_${pkgver}"
- msg "Removing unRar"
-# Generate patch
-# sed -e '/Rar/d' -i makefile*
-# find -name '*Rar*' -print0 | xargs -0 rm -rvf
-# Remove Rar mentions in CPP/7zip/Bundles/Format7zFree/makefile
- patch -Np1 -i ../p7zip-libre.patch
+ cd "${srcdir}/${_pkgname}_${pkgver}"
+ msg "Removing unRar"
+ # Generate patch
+ # sed -e '/Rar/d' -i makefile*
+ # find -name '*Rar*' -print0 | xargs -0 rm -rvf
+ # Remove Rar mentions in CPP/7zip/Bundles/Format7zFree/makefile
+ patch -Np1 -i ../p7zip-libre.patch
+ msg 'Replacing the parent folder icon'
+ rm CPP/7zip/UI/FileManager/res/ParentFolder.h
+ patch -Np1 -i ../parent-folder-icon.patch
}
prepare() {