summaryrefslogtreecommitdiff
path: root/libre/openmw/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2018-01-15 19:21:55 +0100
committerAndreas Grapentin <andreas@grapentin.org>2018-01-15 19:21:55 +0100
commit66f14a9940c108b81337920dd766ac8863ced4f2 (patch)
treeb30e73f074d585aa6605141ec5dc7eaacbe5d805 /libre/openmw/PKGBUILD
parenta14fd54a63bc63295ff54ae19699c17a4621c711 (diff)
downloadabslibre-66f14a9940c108b81337920dd766ac8863ced4f2.tar.gz
abslibre-66f14a9940c108b81337920dd766ac8863ced4f2.tar.bz2
abslibre-66f14a9940c108b81337920dd766ac8863ced4f2.zip
libre/openmw: updated to 0.43.0
Diffstat (limited to 'libre/openmw/PKGBUILD')
-rw-r--r--libre/openmw/PKGBUILD36
1 files changed, 19 insertions, 17 deletions
diff --git a/libre/openmw/PKGBUILD b/libre/openmw/PKGBUILD
index 72e070d5b..920db706a 100644
--- a/libre/openmw/PKGBUILD
+++ b/libre/openmw/PKGBUILD
@@ -1,32 +1,34 @@
+# $Id:
# Maintainer (Arch): Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor (Arch): Sandy Carter <bwrsandman@gmail.com>
# Maintainer: André Silva <emulatorman@hyperbola.info>
-
pkgname=openmw
-pkgver=0.41.0
-pkgrel=4.parabola1
-pkgdesc="A libre engine reimplementation for Morrowind-based role-playing games, without wizard installation support to install nonfree assets from Morrowind to run Morrowind"
-arch=('i686' 'x86_64')
+pkgver=0.43.0
+pkgrel=2.parabola1
+pkgdesc="A libe engine reimplementation for the role-playing game Morrowind, without without wizard installation support to install nonfree assets from Morrowind to run Morrowind"
+arch=('x86_64' 'i686' 'armv7h')
url="http://www.openmw.org"
license=('GPL3' 'MIT' 'custom')
depends=('openal' 'openscenegraph' 'mygui' 'bullet' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt')
-makedepends=('cmake' 'boost' 'doxygen')
+makedepends=('cmake' 'boost' 'doxygen' 'ninja')
source=("https://github.com/OpenMW/openmw/archive/openmw-${pkgver}.tar.gz")
-sha512sums=('a47a7af3c6d3252e22206eb776069ef87f698acbe133b0e0294db307486c28cb300085fcf45b436af541dbb22f6d45f2ee3998e50a1c711f667f8a738813255d')
+sha512sums=('e902dd2274c05838bb1171f07d7a673fc7b85d1290a9e01c8ab89f1c279bd236332ecdc0f2b7944ec7209a0e6022ff472639b5724bf26904e3a2d338c7be401a')
build() {
- cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DDESIRED_QT_VERSION=5 \
- -DBUILD_ESSIMPORTER=OFF \
- -DBUILD_WIZARD=OFF
- make
+ mkdir -p build
+ cd build
+ cmake "../$pkgname-$pkgname-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DDESIRED_QT_VERSION=5 \
+ -DBUILD_ESSIMPORTER=OFF \
+ -DBUILD_WIZARD=OFF \
+ -GNinja
+ ninja
}
package() {
- cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C build install
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: