summaryrefslogtreecommitdiff
path: root/libre/openexr/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2021-04-29 22:07:06 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2021-05-07 16:52:28 -0400
commitc7a960207bea9287dec18a40a01fcf74b607c59e (patch)
tree9d32cc317def799e39ac586d1a84ec4185880281 /libre/openexr/PKGBUILD
parenta9f77f74ff4f118f0cb816dbd798402ba728170d (diff)
downloadabslibre-c7a960207bea9287dec18a40a01fcf74b607c59e.tar.gz
abslibre-c7a960207bea9287dec18a40a01fcf74b607c59e.tar.bz2
abslibre-c7a960207bea9287dec18a40a01fcf74b607c59e.zip
[openexr]: remove package
no longer ships PDF files no longer installs any docs/ files
Diffstat (limited to 'libre/openexr/PKGBUILD')
-rw-r--r--libre/openexr/PKGBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/libre/openexr/PKGBUILD b/libre/openexr/PKGBUILD
deleted file mode 100644
index 021f6b2d3..000000000
--- a/libre/openexr/PKGBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Maintainer (Arch): Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-# Contributor: André Silva <emulatorman@hyperbola.info>
-# Contributor: grizzlyuser <grizzlyuser@protonmail.com>
-
-# parabola changes and rationale
-# * removed documentation with embedded non-free fonts
-
-pkgname=openexr
-pkgver=2.5.5
-pkgrel=1
-pkgrel+=.parabola1
-pkgdesc="An high dynamic-range image file format library"
-pkgdesc+=", without embedded nonfree fonts in the documentation"
-url="https://www.openexr.com/"
-arch=('x86_64')
-arch+=('i686' 'armv7h')
-license=('BSD3')
-depends=('zlib')
-makedepends=('cmake' 'python' 'boost' 'freeglut' 'python-numpy' 'chrpath')
-optdepends=('boost-libs: python support' 'python: python support')
-optdepends+=('libreoffice-still: for reading documentation')
-conflicts=('ilmbase')
-replaces=('ilmbase')
-source=($pkgname-$pkgver.tar.gz::"https://github.com/openexr/openexr/archive/v$pkgver.tar.gz")
-source+=(install-odt-docs-not-pdf.patch)
-sha256sums=('59e98361cb31456a9634378d0f653a2b9554b8900f233450f2396ff495ea76b3')
-sha256sums+=('fd0cc640265605b6a25db3dd901641be3adebfa2b748e6b559cffcba1e5ceb94')
-
-prepare() {
- cd $pkgname-$pkgver
-
- # remove documentation with embedded non-free fonts
- find . -name *.pdf -exec rm -v '{}' \;
- patch -p1 < "$srcdir"/install-odt-docs-not-pdf.patch
-}
-
-build() {
- cmake -B build -S $pkgname-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr
- cmake --build build
-}
-
-package() {
- DESTDIR="${pkgdir}" cmake --install build
- install -D -m644 $pkgname-$pkgver/LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
-
-# Install missing python module
- _pythonpath=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`
- install -Dm755 build/python3*/imathnumpy.so -t "$pkgdir"/$_pythonpath
-}