summaryrefslogtreecommitdiff
path: root/libre/notsystemd/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-09-12 18:32:37 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-09-12 22:33:19 -0400
commit73934ba2e660313bde6f191d3de7632a41db6cc5 (patch)
tree9625c1003c63a357647ff7f75bf6b79bb07fa88e /libre/notsystemd/PKGBUILD
parent9ffca5fbaf194023453084db2907b58f50fe36a0 (diff)
downloadabslibre-73934ba2e660313bde6f191d3de7632a41db6cc5.tar.gz
abslibre-73934ba2e660313bde6f191d3de7632a41db6cc5.tar.bz2
abslibre-73934ba2e660313bde6f191d3de7632a41db6cc5.zip
libre/notsystemd: update to 233.1
Diffstat (limited to 'libre/notsystemd/PKGBUILD')
-rw-r--r--libre/notsystemd/PKGBUILD171
1 files changed, 97 insertions, 74 deletions
diff --git a/libre/notsystemd/PKGBUILD b/libre/notsystemd/PKGBUILD
index 6533a801e..51fdd6128 100644
--- a/libre/notsystemd/PKGBUILD
+++ b/libre/notsystemd/PKGBUILD
@@ -3,22 +3,30 @@
# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
_pkgname=systemd
+# latest commit on stable branch
+_commit='27c7bc970d9e7ffe060688a8dd77b7747503a564'
+# Bump this to latest major release for signed tag verification,
+# the commit count is handled by pkgver() function.
+_pkgver=233.75
+_pkgrel=3
+_pkgrel+=.parabola1
+
pkgname=notsystemd
-_sdver=232
-_patchver=1
-pkgver=${_sdver}.${_patchver}
-pkgrel=8.parabola2
-arch=('i686' 'x86_64' 'armv7h')
+pkgver=233.1
+pkgrel=1
+arch=('i686' 'x86_64')
+arch+=('armv7h')
url="https://repo.parabola.nu/other/${pkgname}"
license=('GPL2' 'LGPL2.1')
-makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf>=3.1' 'lz4' 'xz' 'pam' 'libelf'
+makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn' 'libgcrypt'
- 'libmicrohttpd' 'libxslt' 'util-linux' 'linux-libre-api-headers'
+ 'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
'python-lxml' 'quota-tools' 'shadow' 'git')
makedepends_i686=('gnu-efi-libs')
makedepends_x86_64=('gnu-efi-libs')
options=('strip')
-source=("git://github.com/systemd/systemd.git#tag=v$_sdver"
+source=("git://github.com/systemd/systemd-stable.git#commit=${_commit}"
+ 'git://github.com/systemd/systemd.git' # pull in for tags
"https://repo.parabola.nu/other/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
'initcpio-hook-udev'
'initcpio-install-systemd'
@@ -31,21 +39,20 @@ source=("git://github.com/systemd/systemd.git#tag=v$_sdver"
'systemd-sysusers.hook'
'systemd-tmpfiles.hook'
'systemd-update.hook'
- '0001-disable-RestrictAddressFamilies-on-i686.patch'
- '0001-Revert-nspawn-try-to-bind-mount-resolved-s-resolv.co.patch'
- '0001-nspawn-don-t-hide-bind-tmp-mounts.patch'
'0001-FSDG-man-Refer-to-the-operating-system-as-GNU-Linux.patch'
'0002-FSDG-os-release-Default-to-PRETTY_NAME-GNU-Linux-ins.patch'
'0003-FSDG-os-release-Default-to-NAME-GNU-Linux-instead-of.patch'
'0004-FSDG-os-release-Default-ID-to-gnu-linux-instead-of-l.patch'
- '0005-FSDG-systemd-resolved-Default-to-hostname-gnu-linux-.patch'
- '0006-FSDG-man-Use-FSDG-operating-systems-as-examples.patch')
+ '0005-FSDG-systemd-resolved-Fallback-hostname-to-gnu-linux.patch'
+ '0006-FSDG-man-Use-FSDG-operating-systems-as-examples.patch'
+ '0007-FSDG-bootctl-Say-Systemd-Boot-Manager-instead-of-Lin.patch')
sha512sums=('SKIP'
- '7753651b0bf4103e4effa22eedcb3edab734c6ccedf20cd757ae0b1f8b4a70297043ed1dba35eef077feeb6412323688df4f197701aae32c414ed8f1482fa61b'
+ 'SKIP'
+ '39cda5d4adaae64f57a6e566e7127ef2c18cbb5a106100431d9aa562a298e8555d7a374e81b7f66d1ef8514d1d8eb489f7f2fc452d12291944c2d5de7eb2e029'
'SKIP'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
- '52af734947a768758d5eb3f18e31a1cfec6699eca6fa10e40b90c7f11991509186c0a696e3490af3eaba80064ea4cb93e041579abf05addf072d294300aa4b28'
- 'fec639de0d99967ed3e67289eff5ff78fff0c5829d350e73bed536a8391f1daa1d118d72dbdc1f480ffd33fc22b72f4817d0973bd09ec7f182fd26ad87b24355'
+ '691acebb243b9cd7fb63272662f34bdb9aead710c69aee9361ab2322f9f108600ad5b0214fc00b7cb2d9c95db8abd748030625d60d6567efd98663c56ba28c65'
+ 'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
'70b3f1d6aaa9cd4b6b34055a587554770c34194100b17b2ef3aaf4f16f68da0865f6b3ae443b3252d395e80efabd412b763259ffb76c902b60e23b6b522e3cc8'
'6c6f579644ea2ebb6b46ee274ab15110718b0de40def8c30173ba8480b045d403f2aedd15b50ad9b96453f4ad56920d1350ff76563755bb9a80b10fa7f64f1d9'
'a50bc85061a9a16d776235099867bc1a17c17dddb74c1ecf5614c849735a9779c5e34e5ddca8ca6af4b59a40f57c08ecf219b98cab09476ddb0f110e6a35e45c'
@@ -54,36 +61,40 @@ sha512sums=('SKIP'
'9d27d97f172a503f5b7044480a0b9ccc0c4ed5dbb2eb3b2b1aa929332c3bcfe38ef0c0310b6566f23b34f9c05b77035221164a7ab7677784c4a54664f12fca22'
'0f4efddd25256e09c42b953caeee4b93eb49ecc6eaebf02e616b4dcbfdac9860c3d8a3d1a106325b2ebc4dbc6e08ac46702abcb67a06737227ccb052aaa2a067'
'10190fba9f39a8f4b620a0829e0ba8ed63bb4dbeca712966011ee7807880d01ab2abff1a80baafeb6674db70526a473fe585db8190e864f318fc4d6068552618'
- '89f9b2d3918c679ce4f76c2b10dc7fcb7e04f1925a5f92542f06891de2a123a91df7eb67fd4ce71506a8132f5440b3560b7bb667e1c1813944b115c1dfe35e3f'
- 'b993a42c5534582631f7b379d54f6abc37e3aaa56ecf869a6d86ff14ae5a52628f4e447b6a30751bc1c14c30cec63a5c6d0aa268362d235ed477b639cac3a219'
- '68478403433aafc91a03fda5d83813d2ed1dfc6ab7416b2927a803314ecf826edcb6c659587e74df65de3ccb1edf958522f56ff9ac461a1f696b6dede1d4dd35'
- '50888d94636427ca97bfa5355226163fb6458f2a60303967cf74a8fd085f3c450d276b7c556fea93da387c6bb6f5ecbdb6d9b2a571b6723f27a41c8fb612d27b'
- 'fc8b874279db428a342387147ef6a849c0621eb0326ad5c4eb12c2ceb98b46477ed1e07c076a8b0abae6b323d4d7f4c70d45998c3338fb89903f51b3f653458b'
- 'fd928f5d10a5f95bdbab7720b465cbea8b47cf1a376e1ba292c4759d3f1473c80bd4444729dc5b6f6d884e342db7d07a5dad093d345ccccf2c5fb22dfcdacbd8'
- '723db0e4980727594c88d2fc92ffde10cf7c5cd05fbd88a31dadb813a3c839c3a92b3e5789f936de356b9f5e2d43d67e95fd02627be53ffa46b3d86dfabc4e5b'
- '77161e2f57237ca589d576924ec0877f379047c6fd90ca47cb6686e4f22cc9e2171ae4306bd5a9fd8e707e297b826e0f7df52dcdcb04e99df7ebd0eb45ac89eb'
- 'caa5eb7e52b83549bc7d00e343bbb204334b49f2d14005ac1fb592c6f17c6c860edafd88abe619fe54cb0086725385c1f48fd437670a31a08abdac8485ed2073')
+ 'e85c5564348253e1bc49d943f0456c38ebef0c50a5a7782ea6ebb1f45bd624a69430d79693fe1223b0adace9f07c167b84133a003a09a8b61ae48d1b70610277'
+ '0ad718e9441798a4479600ffce364c2f0e582fd0ccf7762dde90f99755dee4569bcee8299ea2ccbf3a010966c8d48c59fcd0b1f93c9b8a479332c2c128fc2b2a'
+ '03ec8cfde36a0a7413993118707e32b0d8b693d366da8cb22a6e71e1c10178d1df05b2e2d1d5a2a298d49af005f3cdf80bfd8d40959d3e53310491b6ada39fed'
+ '9c13df718d4db2592c50c348c7b6340bbd7dd6ee6951da0f2bbd9c1878e0f034b975dfa9b28081b57e76f91c49f0bbcce314d0baaf1c5916dcff11e98d426372'
+ 'b45c4e40f626a02951a852ea4cd2304f00a172dc64b5c38a97f5c68e4a89ceb4f4164cc9221533c4a5c52662e0b9629a82c521514bfcc21f0c11ce517643c2c1'
+ 'f5c4cbeecac8f9d8f009deb4ac1d0b797210bcd1a91fcc6bf8ec110320ad6ceb8fd2a28b184ca037d73078d09a22f224ad3fc46f4bbf972432cce23263b2e1dc'
+ 'e276fd1aedd7718333324fa9d99493fe99d951f446e3b590a99e2cc9562a0bd0e29693907997cb52096c39168c5be62ded3feedf93bacd3c9659d58775b6ca8d')
validpgpkeys=(
'63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering
'99195DD3BB6FE10A2F36ED8445698744D4FFBFC9' # Luke Shumaker
)
_backports=(
- '843d5baf6aad6c53fc00ea8d95d83209a4f92de1' # core: don't use the unified hierarchy for the systemd cgroup yet (#4628)
- 'abd67ce74858491565cde157c7b08fda43d3279c' # basic/virt: fix userns check on CONFIG_USER_NS=n kernel (#4651)
- '4318abe8d26e969ebdb97744a63ab900233a0185' # build-sys: do not install ctrl-alt-del.target symlink twice
- 'd112eae7da77899be245ab52aa1747d4675549f1' # device: Avoid calling unit_free(NULL) in device setup logic (#4748)
- 'cfed63f60dd7412c199652825ed172c319b02b3c' # nspawn: fix exit code for --help and --version (#4609)
- '3099caf2b5bb9498b1d0227c40926435ca81f26f' # journal: make sure to initially populate the space info cache (#4807)
- '3d4cf7de48a74726694abbaa09f9804b845ff3ba' # build-sys: check for lz4 in the old and new numbering scheme (#4717)
- # Compatibility for new versions of build deps:
- 'c9f7b4d356a453a01aa77a6bb74ca7ef49732c08' # (gperf 3.1) build-sys: add check for gperf lookup function signature (#5055)
- 'dc66f33a16596c2886a24da12e56ec096214e124' # (linux 4.10) sparse: avoid clash with __bitwise and __force from 4.10 linux/types.h (#5061)
- 'ec251fe7d5bc24b5d38b0853bc5969f3a0ba06e2' # (gcc 7) tree-wide: adjust fall through comments so that gcc is happy
+ # build-sys: make RPM macros installation path configurable
+ 'ff2e33db54719bfe8feea833571652318c6d197c'
+ # resolved: do not start LLMNR or mDNS stack when no network enables them
+ '2c7ef56459bf6fe7761595585aa4eed5cd183f27^..2c7ef56459bf6fe7761595585aa4eed5cd183f27^2'
+ # networkd: RFC compliant autonomous prefix handling (#5636)
+ '6554550f35a7976f9110aff94743d3576d5f02dd'
+ # core: do not print color console message about gc-ed jobs
+ '047d7219fde661698d3487fc49e9878c61eefd77'
+ # (glibc 2.26) fix includes
+ '284d1cd0a12cad96a5ea61d1afb0dd677dbd147e'
+)
+
+_reverts=(
+ # core: store the invocation ID in the per-service keyring
+ 'b3415f5daef49642be3d5f417b8880c078420ff7'
+ # core: run each system service with a fresh session keyring
+ '74dd6b515fa968c5710b396a7664cac335e25ca8'
)
_validate_tag() {
- local success fingerprint trusted status tag=v$_sdver
+ local success fingerprint trusted status tag=v${_pkgver%.*}
parse_gpg_statusfile /dev/stdin < <(git verify-tag --raw "$tag" 2>&1)
@@ -110,46 +121,48 @@ _validate_tag() {
}
prepare() {
- cd "$_pkgname"
+ cd "$_pkgname-stable"
+
+ git remote add upstream ../systemd/
+ git fetch --all
_validate_tag || return
- if (( ${#_backports[*]} > 0 )); then
- git cherry-pick -n "${_backports[@]}"
- fi
-
- # https://github.com/systemd/systemd/issues/4789
- patch -Np1 <../0001-nspawn-don-t-hide-bind-tmp-mounts.patch
-
- # these patches aren't upstream, but they make v232 more useable.
-
- # https://github.com/systemd/systemd/issues/4575
- patch -Np1 <../0001-disable-RestrictAddressFamilies-on-i686.patch
+ local _commit
+ for _commit in "${_backports[@]}"; do
+ git cherry-pick -n "$_commit"
+ done
+ for _commit in "${_reverts[@]}"; do
+ git revert -n "$_commit"
+ done
- # https://github.com/systemd/systemd/issues/4595
- # https://github.com/systemd/systemd/issues/3826
- patch -Np1 <../0001-Revert-nspawn-try-to-bind-mount-resolved-s-resolv.co.patch
+ # nss-resolve: drop the internal fallback to libnss_dns
+ git show '5486a31d287f26bcd7c0a4eb2abfa4c074b985f1' -- \
+ 'Makefile.am' 'src/nss-resolve/nss-resolve.c' | git apply --index
+
+ # Resolved packet size (#6214) (FS#54619, CVE-2017-9445)
+ git show '751ca3f1de316ca79b60001334dbdf54077e1d01' \
+ 'db848813bae4d28c524b3b6a7dad135e426659ce' \
+ '88795538726a5bbfd9efc13d441cb05e1d7fc139' \
+ '64a21fdaca7c93f1c30b21f6fdbd2261798b161a' \
+ -- . ':!src/resolve/meson.build' | git apply --index
# apply FSDG patches
- local patchfile
- for patchfile in "$srcdir"/????-FSDG-*.patch; do
- patch -Np1 -i "$patchfile"
+ local _patch
+ for _patch in "$srcdir"/????-FSDG-*.patch; do
+ patch -Np1 -i "$_patch"
done
- # Rename "Linux Boot Manager" -> "Systemd Boot Manager"
- sed -i 's|Linux Boot Manager|Systemd Boot Manager|' src/boot/bootctl.c
-
# apply notsystemd patches
- for patchfile in "$srcdir/$pkgname-$pkgver"/????-*.patch; do
- [[ "${patchfile##*/}" != 0000-* ]] || continue
- patch -Np1 -i "$patchfile"
+ for _patch in "$srcdir/$pkgname-$pkgver"/????-*.patch; do
+ patch -Np1 -i "$_patch"
done
./autogen.sh
}
build() {
- cd "$_pkgname"
+ cd "$_pkgname-stable"
local timeservers=({0..3}.arch.pool.ntp.org)
@@ -174,6 +187,9 @@ build() {
--with-default-dnssec=no
--with-dbuspolicydir=/usr/share/dbus-1/system.d
--without-kill-user-processes
+ --with-rpmmacrosdir=no
+ # TODO(dreisner): consider changing this to unified
+ --with-default-hierarchy=hybrid
)
if [ "$CARCH" != "armv7h" ]; then
configure_options+=(--enable-gnuefi)
@@ -203,9 +219,11 @@ build() {
mv "$srcdir/dest"/systemd/usr/share/man/man3/*udev* -t "$srcdir/dest"/libudev/usr/share/man/man3/
local nssmodule
- for nssmodule in myhostname mymachines resolve; do
+ for nssmodule in systemd myhostname mymachines resolve; do
install -dm755 "$srcdir/dest/nss-$nssmodule"/usr/{lib,share/man/man8}
- mv -T "$srcdir/dest"/{systemd,nss-$nssmodule}/usr/share/man/man8/nss-$nssmodule.8
+ mv -t "$srcdir/dest"/nss-$nssmodule/usr/share/man/man8/ -- \
+ "$srcdir/dest"/systemd/usr/share/man/man8/nss-$nssmodule.8 \
+ "$srcdir/dest"/systemd/usr/share/man/man8/libnss_$nssmodule.*.8
mv "$srcdir/dest"/systemd/usr/lib/libnss_$nssmodule.so* -t "$srcdir/dest"/nss-$nssmodule/usr/lib/
done
@@ -218,14 +236,13 @@ build() {
package() {
pkgdesc="system and service manager"
- depends=('acl' 'bash' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
+ depends=('acl' 'bash' 'cryptsetup' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
'libgcrypt' 'libsystemd' 'libidn' 'lz4' 'pam' 'libelf' 'libseccomp'
'util-linux' 'xz')
- provides=("systemd-tools=$_sdver" "udev=$_sdver" "eudev" "eudev-systemd")
+ provides=("systemd-tools=$_pkgver" "udev=$_pkgver")
replaces=('systemd-tools' 'udev')
conflicts=('systemd-tools' 'udev')
- optdepends=('cryptsetup: required for encrypted block devices'
- 'libmicrohttpd: remote journald capabilities'
+ optdepends=('libmicrohttpd: remote journald capabilities'
'quota-tools: kernel-level quota management'
'systemd-sysvcompat: symlink package to provide sysvinit binaries'
'polkit: allow administration as unprivileged user')
@@ -244,19 +261,17 @@ package() {
pkgdesc+=", modified to work with other init systems"
conflicts+=("$_pkgname")
- provides+=("$_pkgname=$_sdver")
-
+ provides+=("$_pkgname=$_pkgver-$_pkgrel")
+
cp -rT -d --no-preserve=ownership,timestamp "$srcdir/dest/$_pkgname" "$pkgdir"
# don't write units to /etc by default. some of these will be re-enabled on
# post_install.
rm -r "$pkgdir/etc/systemd/system/"*.wants
-
- # get rid of RPM macros
- rm -r "$pkgdir/usr/lib/rpm"
+ rm -r "$pkgdir/etc/systemd/system/"*.service
# add back tmpfiles.d/legacy.conf
- install -m644 "$_pkgname/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
+ install -m644 "$_pkgname-stable/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
# Replace dialout/tape/cdrom group in rules with uucp/storage/optical group
sed -i 's#GROUP="dialout"#GROUP="uucp"#g;
@@ -275,12 +290,20 @@ package() {
chown root:systemd-journal "$pkgdir/var/log/journal"
chmod 2755 "$pkgdir/var/log/journal"
+ # match directory owner/group and mode from extra/polkit
+ chown root:102 "$pkgdir/usr/share/polkit-1/rules.d"
+ chmod 0750 "$pkgdir/usr/share/polkit-1/rules.d"
+
# we'll create this on installation
rmdir "$pkgdir/var/log/journal/remote"
# ship default policy to leave services disabled
echo 'disable *' >"$pkgdir"/usr/lib/systemd/system-preset/99-default.preset
+ # allow core/filesystem to pristine nsswitch.conf
+ rm "$pkgdir/usr/share/factory/etc/nsswitch.conf"
+ sed -i '/^C \/etc\/nsswitch\.conf/d' "$pkgdir/usr/lib/tmpfiles.d/etc.conf"
+
# add example bootctl configuration
install -Dm644 "$srcdir/parabola.conf" "$pkgdir"/usr/share/systemd/bootctl/parabola.conf
install -Dm644 "$srcdir/loader.conf" "$pkgdir"/usr/share/systemd/bootctl/loader.conf