summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-06-21 17:08:18 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-06-21 17:08:18 -0300
commitdab025caac04d6d58081736aeb7c830f2a327382 (patch)
treef7344d7278a1f2d7e7ee9729cbfdb58d8f06d76a /libre/linux-libre/PKGBUILD
parent05080cb2f478d39a436551b9ce1cedc621c0a6ad (diff)
downloadabslibre-dab025caac04d6d58081736aeb7c830f2a327382.tar.gz
abslibre-dab025caac04d6d58081736aeb7c830f2a327382.tar.bz2
abslibre-dab025caac04d6d58081736aeb7c830f2a327382.zip
linux-libre: updating version and adding some features
* Update 3.9.7 version to i686 and x86_64 * Update 3.9.6 version to mips64el * Add config files for 3.10 series * Remove not needed checks in install file
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 401ba3018..c133f12a1 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,19 +1,19 @@
-# $Id: PKGBUILD 188461 2013-06-14 12:19:09Z tpowa $
+# $Id: PKGBUILD 188791 2013-06-21 06:32:50Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
-# Maintainer (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
-# Maintainer (Parabola): Sorin-Mihai Vârgolici <smv@yobicore.org>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
-# Maintainer (Parabola): Michał Masłowski <mtjm@mtjm.eu>
-# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
+# Contributor (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
+# Contributor (Parabola): Sorin-Mihai Vârgolici <smv@yobicore.org>
+# Contributor (Parabola): Michał Masłowski <mtjm@mtjm.eu>
+# Contributor (Parabola): Márcio Silva <coadde@lavabit.com>
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.9
-_sublevel=6
+_sublevel=7
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.5 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.6 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -31,7 +31,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'change-default-console-loglevel.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('120df29f88622dabf7015a22c7cc8e25'
- '7dba3beb8f739ca133be09f92ff1dc67'
+ '4f5c670da16dc80fe9482892b636f99d'
'b3458a2d80ce102b384586d4bddfddf0'
'52c2de7d1cb41727679e8061baef1741'
'e49ac236dfeef709f91a3d993ea7b62c'
@@ -39,7 +39,7 @@ md5sums=('120df29f88622dabf7015a22c7cc8e25'
'8267264d9a8966e57fdacd1fa1fc65c4'
'04b21c79df0a952c22d681dd4f4562df'
'f3def2cefdcbb954c21d8505d23cc83c'
- '50c2274bf466dffc149332fc2f5efd40')
+ '0375f682754ef52216fd522494875301')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]