summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-10-14 19:28:23 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-10-14 19:28:23 -0200
commitc2bc1d09c2eeaac9abf7164e5ddbeeca74e29df7 (patch)
treee83586602e22b822ad272bb340f706a1a5bcf938 /libre/linux-libre/PKGBUILD
parentd8515787714f5b5911269f7d70896fbbfcec3e33 (diff)
downloadabslibre-c2bc1d09c2eeaac9abf7164e5ddbeeca74e29df7.tar.gz
abslibre-c2bc1d09c2eeaac9abf7164e5ddbeeca74e29df7.tar.bz2
abslibre-c2bc1d09c2eeaac9abf7164e5ddbeeca74e29df7.zip
linux-libre-3.11.5-1: updating version
* update version to 3.11.4 for mips64el * increase NR_CPU to 32 for i686 and 128 for x86_64 * fix NR_CPU on i686 * add 3.12 config files * 3.12 config: build in scsi, sd_mod, libata and enable asynchronous scsi scanning * add lustre_fs to 3.12 config * disable MTD_NAND and CHIPIDEA * revert builtin scsi modules * set SCSI_SCAN_ASYNC=y
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 8a493e182..b6a40aa75 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 195930 2013-10-05 19:44:24Z tpowa $
+# $Id: PKGBUILD 196455 2013-10-14 06:53:31Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
@@ -10,10 +10,10 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.11
-_sublevel=4
+_sublevel=5
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.3 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.4 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -33,9 +33,9 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'3.11-haswell-intel_pstate.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('7ec84223c7adcf01a5287eb7af96b7e7'
- 'd09e8017d22370b873628942f3ece3b0'
- 'b7718a81faf845ab53234336122ad631'
- 'f7ee88ffc93b665345b6ee89ff192e1f'
+ 'bcd700aa1ae7f13107a14885923358eb'
+ '0084545e67de0e321d90b11405ab3988'
+ '615084511f033782ca7d29ab6165e5a1'
'e49ac236dfeef709f91a3d993ea7b62c'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
@@ -43,7 +43,7 @@ md5sums=('7ec84223c7adcf01a5287eb7af96b7e7'
'98beb36f9b8cf16e58de2483ea9985e3'
'd50c1ac47394e9aec637002ef3392bd1'
'1040ae6c10d4a68f89899f94a2318a17'
- 'e6db810c0d41180acca55f545b1681fb')
+ 'e92d4241b533fdd7165b5d47197f7162')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]