summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-04-28 23:04:48 -0300
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-04-28 23:04:48 -0300
commit8a653457388d29ed6f5e607e5df823c6a187a0fe (patch)
tree8835011fa52c20c9799b7a430ddf40255a75073a /libre/linux-libre/PKGBUILD
parent20a6b4a6cfe6813572f80525e0daad07ee112a38 (diff)
downloadabslibre-8a653457388d29ed6f5e607e5df823c6a187a0fe.tar.gz
abslibre-8a653457388d29ed6f5e607e5df823c6a187a0fe.tar.bz2
abslibre-8a653457388d29ed6f5e607e5df823c6a187a0fe.zip
linux-libre-3.3.4-1: updating version
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD26
1 files changed, 7 insertions, 19 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 47dfecba8..2022e0e50 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -12,9 +12,9 @@ pkgname=('linux-libre' 'linux-libre-headers' 'linux-libre-docs') # Build stock -
# pkgname=linux-custom # Build kernel with a different name
_kernelname=-LIBRE
_basekernel=3.3
-_sublevel=3
+_sublevel=4
pkgver=${_basekernel}.${_sublevel}
-_lxopkgver=${_basekernel}.1 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.4 # nearly always the same as pkgver
pkgrel=1
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
@@ -32,24 +32,20 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'i915-fix-ghost-tv-output.patch'
- 'fix-memblock-3.3.x.patch'
- 'fix-r8712u-3.3.2.patch'
'ext4-options.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('5487da14ca81715a469c7594d39722fa'
- 'b3584346eba0031be9e08c0c6d64fa85'
- '8c97845fa581b5d8172694d85577d817'
- '60c740318d677350ac5251300f6cbe73'
- 'a8a3843046926eb7ab81312cd438c5c5'
+ 'ce7d959667b9f158b1fb814b5806950a'
+ '225fc118e655b0e4031aaf45656b872c'
+ 'e6b45d3ba0415d2dfbda9cdbf6dbf6f4'
+ 'e49ac236dfeef709f91a3d993ea7b62c'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
'04b21c79df0a952c22d681dd4f4562df'
'9d3c56a4b999c8bfbd4018089a62f662'
'263725f20c0b9eb9c353040792d644e5'
- 'bfbac6688a9031372638438adccd4595'
- '4be6f77e4c1533c4587dd48cfd50759e'
'bb7fd1aa23016c8057046b84fd4eb528'
- '107729418380124db470dda99425fdce')
+ 'c22b03a6351698b07cd08767d8ddeacd')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -76,14 +72,6 @@ build() {
patch -Np1 -i "${srcdir}/i915-fix-ghost-tv-output.patch"
# Patch submitted upstream, waiting for inclusion:
- # fix https://bugzilla.kernel.org/show_bug.cgi?id=43098
- # Arch Linux bug report #29351
- patch -Np1 -i "${srcdir}/fix-memblock-3.3.x.patch"
-
- # Patch submitted upstream, waiting for inclusion:
- # Arch Linux bug report #29339
- # probably 3.3.4 will include it
- patch -Np1 -i "${srcdir}/fix-r8712u-3.3.2.patch"
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)