summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-11-14 13:31:23 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-11-14 13:31:23 -0200
commit545b181dc6c3cde6138f275caab18b9f4aceb732 (patch)
tree52610a006f01fa6d1cc52b65091f65ac87f304ef /libre/linux-libre/PKGBUILD
parent0b4975cbd52c90766760aa612b159ca9ffea210d (diff)
downloadabslibre-545b181dc6c3cde6138f275caab18b9f4aceb732.tar.gz
abslibre-545b181dc6c3cde6138f275caab18b9f4aceb732.tar.bz2
abslibre-545b181dc6c3cde6138f275caab18b9f4aceb732.zip
linux-libre-3.12-1: updating version
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD32
1 files changed, 13 insertions, 19 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 2d288c73c..586a5d683 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 196776 2013-10-18 23:07:51Z thomas $
+# $Id: PKGBUILD 199009 2013-11-06 08:26:56Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -9,18 +9,19 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.11
-_sublevel=6
-pkgver=${_basekernel}.${_sublevel}
+_basekernel=3.12
+#_sublevel=6
+#pkgver=${_basekernel}.${_sublevel}
+pkgver=${_basekernel}
pkgrel=1
-_lxopkgver=${_basekernel}.6 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.0 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
+ #"http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
# the main kernel config files
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -30,20 +31,18 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'criu-no-expert.patch'
- '3.11-haswell-intel_pstate.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
-md5sums=('7ec84223c7adcf01a5287eb7af96b7e7'
- '15dc0cd2ab1348d1af3475e7c539deb2'
- '0084545e67de0e321d90b11405ab3988'
- '615084511f033782ca7d29ab6165e5a1'
+md5sums=('254f59707b6676b59ce5ca5c3c698319'
+ #'15dc0cd2ab1348d1af3475e7c539deb2'
+ '7cadb85598587ca85b84005420836a01'
+ '8e9c701b77f0319d6f95046d6ab2f3e1'
'e49ac236dfeef709f91a3d993ea7b62c'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
- '36e90334b12b2e9d53fd92129ee98f5b'
+ '44260d2cb1a8b51c119d2ce1f83e457a'
'98beb36f9b8cf16e58de2483ea9985e3'
'd50c1ac47394e9aec637002ef3392bd1'
- '1040ae6c10d4a68f89899f94a2318a17'
- '9ddc5a221ab7cd26bc27aab164a6f843')
+ 'b866344d7dd8d8c8b06974e8a6494f9a')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -68,11 +67,6 @@ prepare() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
- # add intel haswell support to intel_pstate
- # https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/patch/?id=6cdcdb793791f776ea9408581b1242b636d43b37
- # will be in 3.12
- patch -Np1 -i "${srcdir}/3.11-haswell-intel_pstate.patch"
-
# allow criu without expert option set
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"