summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-03-17 23:04:48 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-03-17 23:04:48 -0300
commit5394897be24bc09c46c9bbe29f60bcb30af2a74a (patch)
tree9da28736cca021297236a73936083dc0b557b4d8 /libre/linux-libre/PKGBUILD
parent71e7b5a2b69e84cfbcd503f9d7ced8f89eee3910 (diff)
downloadabslibre-5394897be24bc09c46c9bbe29f60bcb30af2a74a.tar.gz
abslibre-5394897be24bc09c46c9bbe29f60bcb30af2a74a.tar.bz2
abslibre-5394897be24bc09c46c9bbe29f60bcb30af2a74a.zip
linux-libre: updating revision
* Update to 3.8.3 version for mips64el * Fix intel drm https://bugs.archlinux.org/task/34327
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 9a9bd3ea3..d242c7cc8 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 180054 2013-03-15 08:10:52Z tpowa $
+# $Id: PKGBUILD 180114 2013-03-17 13:00:07Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
@@ -12,8 +12,8 @@ pkgbase=linux-libre # Build stock -LIBRE kernel
_basekernel=3.8
_sublevel=3
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1
-_lxopkgver=${_basekernel}.2 # nearly always the same as pkgver
+pkgrel=2
+_lxopkgver=${_basekernel}.3 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -29,6 +29,8 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'Kbuild.platforms'
'boot-logo.patch'
'change-default-console-loglevel.patch'
+ 'drm-i915-enable-irqs-earlier-when-resuming.patch'
+ 'drm-i915-reorder-setup-sequence-to-have-irqs-for-output-setup.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('84c2a77910932ffc7d958744ac9cf2f5'
'a762b6f22a64473a0b4d8dc5366b25d3'
@@ -39,7 +41,9 @@ md5sums=('84c2a77910932ffc7d958744ac9cf2f5'
'8267264d9a8966e57fdacd1fa1fc65c4'
'04b21c79df0a952c22d681dd4f4562df'
'f3def2cefdcbb954c21d8505d23cc83c'
- '72a7d05df8498c0e45632f083403605a')
+ '40e7b328977ad787a0b5584f193d63fe'
+ '8b9159931fab0c191a86dbd5a46fa328'
+ '6dcf31e2ad8625ab2864af257e86564b')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -64,6 +68,11 @@ build() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
+ # revert 2 patches which breaks displays
+ # FS 34327
+ patch -Rp1 -i "${srcdir}/drm-i915-enable-irqs-earlier-when-resuming.patch"
+ patch -Rp1 -i "${srcdir}/drm-i915-reorder-setup-sequence-to-have-irqs-for-output-setup.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \