summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-28 19:15:42 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-04-28 19:15:42 -0300
commit44c19d76159111c76a1bf24fe52c767d447193a2 (patch)
tree31008b8785dba159c3cb35d126ccfcad6040bc65 /libre/linux-libre/PKGBUILD
parent4ec82fd2d3a786cf36be8e6684f75b6287e31e34 (diff)
downloadabslibre-44c19d76159111c76a1bf24fe52c767d447193a2.tar.gz
abslibre-44c19d76159111c76a1bf24fe52c767d447193a2.tar.bz2
abslibre-44c19d76159111c76a1bf24fe52c767d447193a2.zip
linux-libre-3.14.2-1: updating version
* added fixes for i810 hang, uefi xsdt issue, saa7134, tun speed
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD41
1 files changed, 34 insertions, 7 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index bfeda0206..e2f35b5cd 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 210383 2014-04-14 19:13:09Z tpowa $
+# $Id: PKGBUILD 211803 2014-04-27 09:34:35Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -10,10 +10,10 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.14
-_sublevel=1
+_sublevel=2
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.0 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.1 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -37,11 +37,15 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'0006-genksyms-fix-typeof-handling.patch'
'0007-x86-efi-Correct-EFI-boot-stub-use-of-code32_start.patch'
'0010-iwlwifi-mvm-delay-enabling-smart-FIFO-until-after-be.patch'
+ '0011-kernfs-fix-removed-error-check.patch'
+ '0012-fix-saa7134.patch'
+ '0013-net-Start-with-correct-mac_len-in-skb_network_protocol.patch'
+ '0015-fix-xsdt-validation.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
md5sums=('c108ec52eeb2a9b9ddbb8d12496ff25f'
- '2b4862b3c76011e66e536f18fbf0fb27'
- '13ee684b40757b16beae1f0192fd6003'
- '43355af4f467ca93a0bc5f7209fc4810'
+ '77c34d5c5c2663d0daaf8ad3761fbaf3'
+ 'f6590a383c973b40f1c0f2baf7fa6fb5'
+ 'a0d21f858031209634578334dbfeb6ac'
'e49ac236dfeef709f91a3d993ea7b62c'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
@@ -55,7 +59,11 @@ md5sums=('c108ec52eeb2a9b9ddbb8d12496ff25f'
'16a161979f846b049e90daea907c35dd'
'00727251b0d337a25d3ca392218afdf4'
'353b553d69da810ef954618aca60e1e2'
- '385f03abf27baa73731d27721eafd1c1')
+ 'b3f98eba6322463ed6644784c56893be'
+ '4f547d79fa1b2bb855dc2996be2a515e'
+ '21d25aef69f9da33c6087b7ffd97783e'
+ '278417ab07b6f5fe8e3e0ed656f35f3e'
+ '3ab22a28f075ec92bca1b7598e8280e1')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -111,6 +119,25 @@ prepare() {
# https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/iwlwifi-fixes.git/commit/?id=12f853a89e29f50b17698e17e73c328a35f1498d
# FS#39815
patch -p1 -i "${srcdir}/0010-iwlwifi-mvm-delay-enabling-smart-FIFO-until-after-be.patch"
+
+ # fix Xorg crash with i810 chipset due to wrong removed error check
+ # References: http://lkml.kernel.org/g/533D01BD.1010200@googlemail.com
+ patch -Np1 -i "${srcdir}/0011-kernfs-fix-removed-error-check.patch"
+
+ # fix saa7134 video
+ # https://bugs.archlinux.org/task/39904
+ # https://bugzilla.kernel.org/show_bug.cgi?id=73361
+ patch -Np1 -i "${srcdir}/0012-fix-saa7134.patch"
+
+ # fix tun/openvpn performance
+ # https://bugs.archlinux.org/task/40089
+ # https://bugzilla.kernel.org/show_bug.cgi?id=74051
+ patch -Np1 -i "${srcdir}/0013-net-Start-with-correct-mac_len-in-skb_network_protocol.patch"
+
+ # fix xsdt validation bug
+ # https://bugs.archlinux.org/task/39811
+ # https://bugzilla.kernel.org/show_bug.cgi?id=73911
+ patch -Np1 -i "${srcdir}/0015-fix-xsdt-validation.patch"
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile