summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-09-17 05:28:54 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2013-09-17 05:28:54 -0300
commit2242c4e1e92b5279b8507a7ee735c6d3cbe56eac (patch)
treecf7dca14492918e6efe0370917790b21d1534508 /libre/linux-libre/PKGBUILD
parent9a5b6b59db9c3603fa392d984195a75faa81ceb9 (diff)
downloadabslibre-2242c4e1e92b5279b8507a7ee735c6d3cbe56eac.tar.gz
abslibre-2242c4e1e92b5279b8507a7ee735c6d3cbe56eac.tar.bz2
abslibre-2242c4e1e92b5279b8507a7ee735c6d3cbe56eac.zip
linux-libre-3.11.1-1: move to libre repo
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD27
1 files changed, 11 insertions, 16 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index be564df01..70d9f739b 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 193761 2013-08-30 11:11:43Z tpowa $
+# $Id: PKGBUILD 194378 2013-09-15 09:16:34Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
@@ -9,11 +9,11 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.10
-_sublevel=10
+_basekernel=3.11
+_sublevel=1
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.10 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.0 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -30,20 +30,18 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'boot-logo.patch'
'change-default-console-loglevel.patch'
'criu-no-expert.patch'
- '3.10.6-logitech-dj.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
-md5sums=('d562fd52580a3b6b18b6eeb5921d1d5c'
- '673ae6d60b4ce8acad930a06f9fe2e3f'
- '8ec987449e0e42a1c98d8ce92b9019c2'
- '8efbd1f17f37bdaa8649c8a63761bf07'
+md5sums=('7ec84223c7adcf01a5287eb7af96b7e7'
+ '7b051faf375c76d4763a24048c52600b'
+ 'b7718a81faf845ab53234336122ad631'
+ 'f7ee88ffc93b665345b6ee89ff192e1f'
'e49ac236dfeef709f91a3d993ea7b62c'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
- '04b21c79df0a952c22d681dd4f4562df'
- 'f3def2cefdcbb954c21d8505d23cc83c'
+ '36e90334b12b2e9d53fd92129ee98f5b'
+ '98beb36f9b8cf16e58de2483ea9985e3'
'd50c1ac47394e9aec637002ef3392bd1'
- '3ff40ca684cfe719723e627e2cef7cea'
- '714134bcb52e243898036beacca2e7b7')
+ '135ff203ec680a91e87eed4df72f453d')
if [ "$CARCH" != "mips64el" ]; then
# don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -71,9 +69,6 @@ prepare() {
# allow criu without expert option set
# patch from fedora
patch -Np1 -i "${srcdir}/criu-no-expert.patch"
-
- # fix https://bugs.archlinux.org/task/35991 - [linux] 3.10.x renders Logitech Unified Receivers useless
- patch -Np1 -i "${srcdir}/3.10.6-logitech-dj.patch"
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile