summaryrefslogtreecommitdiff
path: root/libre/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2019-12-06 18:23:34 -0300
committerDavid P <megver83@parabola.nu>2019-12-06 18:23:34 -0300
commit5671964771ac01eaf06670be4b14c0262dee1362 (patch)
tree0b4e634911715d59de06bb6a236a83912d3fd305 /libre/linux-libre-pae/PKGBUILD
parent7b1d70a5aba3bba4d34122feace465c8bb6fe610 (diff)
downloadabslibre-5671964771ac01eaf06670be4b14c0262dee1362.tar.gz
abslibre-5671964771ac01eaf06670be4b14c0262dee1362.tar.bz2
abslibre-5671964771ac01eaf06670be4b14c0262dee1362.zip
updpkg: libre/linux-libre-pae 5.4.2-1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/linux-libre-pae/PKGBUILD')
-rw-r--r--libre/linux-libre-pae/PKGBUILD55
1 files changed, 26 insertions, 29 deletions
diff --git a/libre/linux-libre-pae/PKGBUILD b/libre/linux-libre-pae/PKGBUILD
index 60e5a5207..b5655e5df 100644
--- a/libre/linux-libre-pae/PKGBUILD
+++ b/libre/linux-libre-pae/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: David P <megver83@parabola.nu>
+# Maintainer: David P. <megver83@parabola.nu>
# Contributor: André Silva <emulatorman@hyperbola.info>
# Contributor: Márcio Silva <coadde@hyperbola.info>
@@ -9,22 +9,22 @@ _replacesoldkernels=() # '%' gets replaced with kernel suffix
_replacesoldmodules=() # '%' gets replaced with kernel suffix
pkgbase=linux-libre-pae
-pkgver=5.3.13_gnu
+pkgver=5.4.2
pkgrel=1
pkgdesc='Linux-libre PAE (physical address extension)'
url='https://linux-libre.fsfla.org/'
arch=(i686)
license=(GPL2)
makedepends=(
- xmlto kmod inetutils bc libelf
- python-sphinx python-sphinx_rtd_theme graphviz imagemagick
+ bc kmod libelf
+ xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick
cpio
)
options=('!strip')
-_srcname=linux-5.3
+_srcname=linux-5.4
source=(
"https://linux-libre.fsfla.org/pub/linux-libre/releases/${_srcname##*-}-gnu/linux-libre-${_srcname##*-}-gnu.tar.xz"{,.sign}
- "https://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver//_/-}/patch-${_srcname##*-}-gnu-${pkgver//_/-}.xz"{,.sign}
+ "https://linux-libre.fsfla.org/pub/linux-libre/releases/$pkgver-gnu/patch-${_srcname##*-}-gnu-$pkgver-gnu.xz"{,.sign}
"https://repo.parabola.nu/other/linux-libre/logos/logo_linux_"{clut224.ppm,vga16.ppm,mono.pbm}{,.sig}
config # the main kernel config files
@@ -35,18 +35,20 @@ source=(
# https://labs.parabola.nu/issues/877
# http://www.fsfla.org/pipermail/linux-libre/2015-November/003202.html
0002-fix-Atmel-maXTouch-touchscreen-support.patch
-
- # Arch's custom linux patches
+ # extracted patches from Arch Linux kernel sources
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-Bluetooth-hidp-Fix-assumptions-on-the-return-value-o.patch
+ 0002-lib-devres-add-a-helper-function-for-ioremap_uc.patch
+ 0003-mfd-intel-lpss-Use-devm_ioremap_uc-for-MMIO.patch
+ 0004-PCI-pciehp-Do-not-disable-interrupt-twice-on-suspend.patch
+ 0005-PCI-pciehp-Prevent-deadlock-on-disconnect.patch
)
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78' # David P.
)
-sha512sums=('85d83c973ef96ab414354414da70ab3e1c3df19c3088458498cec1594952878b7967a8988bd9e36d4e728cc573a36e6eac056dbcab2f9aa742f18cbb4fb3164f'
+sha512sums=('0d0915133864eb031adfc6700066147dcf3e768a50a31c39754950c95ef4fd322dc701cd50af49c403ef0325adfcb07e354d5e46c1be3dcdd719a7a55c963f37'
'SKIP'
- '3e9c95825f6852a0721a940c80b01b9772c17ae1680c1ce5a151e4f5b577a4a50f030aa0f2fbbc2b53b898b081bf33e67bfdeb513fe5535f95c4b479452264c3'
+ '0b177b5ab5e7b65769c7b1176590f9fadd134f32af4db2bd0fa362dccfefb28d7fd0865b46418f54f10f039623d86012b49bcfb968bae77274447d7a97da35f5'
'SKIP'
'13cb5bc42542e7b8bb104d5f68253f6609e463b6799800418af33eb0272cc269aaa36163c3e6f0aacbdaaa1d05e2827a4a7c4a08a029238439ed08b89c564bb3'
'SKIP'
@@ -54,11 +56,14 @@ sha512sums=('85d83c973ef96ab414354414da70ab3e1c3df19c3088458498cec1594952878b796
'SKIP'
'267295aa0cea65684968420c68b32f1a66a22d018b9d2b2c1ef14267bcf4cb68aaf7099d073cbfefe6c25c8608bdcbbd45f7ac8893fdcecbf1e621abdfe9ecc1'
'SKIP'
- '6573f6f2a1cc3c2b3b084e57c70849b8153c4f1cdb745bfed596811e8b04e0080d7c2217b8f94ac254972b20a4ef9d60fe24ac8ef4c7b9ea330ab451c4d1f794'
+ '63f3c3bfe27eb66391dfa2120193476f03cf668bbd9edf4b7cc5dcb8c53295b830ecb6afd10b9a89c190d7f02597529b484c22dbb849d221ef975af8db1d8049'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
- '5c48b0092ab6a31453e27e6345347fd2d066e1c306c4c8a9144260bf37d0d13879b5cfe688906a06627d39a40a37e229e5300a479b2c9159e93e05ea7adc6b0a'
- 'b07d84cac1c784f5652a4681efd54ef89ce9cb0778bd2a633709b7150f9fb59db978dc290b92bcb69b8d211471c22a0be2a81a129318cd7efff601a3c591483c')
+ '5bb7fa615301014045383b5421901892565ba7f7fd67da93e34a2b032d3721f6f3e677f8fc87072a33d0d79089541e37b5a34a14bfab2a71b587e3abe3e9743f'
+ '3ff6fc2cdf541b73e53b22213dd1b218544b15f363d6ce15f42a6ac2deb928dd8f536962a8162a648751cadde827d25427105d0bac4e596288ef839943b71f3a'
+ 'cfa690ea2e500b4a9670cfff96c9ffc675ffd34799b6ee41a7e173fb71d4fb915a8ff8b50f8802bbc59d1e9fe1ac458bdbdd3f0af249fbc44d3cc80b09a9da75'
+ 'd71a80d180f4f0a5491fc87dcda6237e53cb309d21d497a76a4f914ce376b53885cd767db2603e6a7ee5b0e6c1f926ac85865614f0997122a73e1e8d1c127749'
+ '56e94bb21c2f233c61f91336b08263bfc28a755e65cd8ddad89186e8f157417f51925927182bca106f03ddae6a5139e78647c48b6961b669444c4337c7b64731')
_replacesarchkernel=("${_replacesarchkernel[@]/\%/${pkgbase#linux-libre}}")
_replacesoldkernels=("${_replacesoldkernels[@]/\%/${pkgbase#linux-libre}}")
@@ -71,9 +76,9 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
cd $_srcname
- if [ "${_srcname##*-}-gnu" != "${pkgver//_/-}" ]; then
+ if [ "${_srcname##*-}" != "$pkgver" ]; then
msg2 "Applying upstream patch..."
- patch -p1 -i ../patch-${_srcname##*-}-gnu-${pkgver//_/-}
+ patch -Np1 -i ../patch-${_srcname##*-}-gnu-$pkgver-gnu
fi
msg2 "Adding freedo as boot logo..."
@@ -218,7 +223,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Kernel hacker's manual for the $pkgdesc kernel"
+ pkgdesc="Documentation for the $pkgdesc kernel"
provides=("${_replacesarchkernel[@]/%/-docs=${pkgver%%_*}}")
conflicts=("${_replacesarchkernel[@]/%/-docs}" "${_replacesoldkernels[@]/%/-docs}")
replaces=("${_replacesarchkernel[@]/%/-docs}" "${_replacesoldkernels[@]/%/-docs}")
@@ -227,20 +232,12 @@ _package-docs() {
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing documentation..."
- mkdir -p "$builddir"
- cp -t "$builddir" -a Documentation
-
- msg2 "Removing unneeded files..."
- rm -rv "$builddir"/Documentation/{,output/}.[^.]*
-
- msg2 "Moving HTML docs..."
local src dst
while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
+ dst="${src#Documentation/}"
+ dst="$builddir/Documentation/${dst#output/}"
+ install -Dm644 "$src" "$dst"
+ done < <(find Documentation -name '.*' -prune -o ! -type d -print0)
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"