summaryrefslogtreecommitdiff
path: root/libre/linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-05-09 15:44:13 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-05-09 15:44:13 -0300
commit38c4074ea8ab6039cbdbb03052f73fcf65666e50 (patch)
treee6177d7a640b6a4caea2c6ecf063c2e2570bbbd8 /libre/linux-libre-lts/PKGBUILD
parent55a48004dd3e6ec98df57254cf3be4b4a7dba38b (diff)
downloadabslibre-38c4074ea8ab6039cbdbb03052f73fcf65666e50.tar.gz
abslibre-38c4074ea8ab6039cbdbb03052f73fcf65666e50.tar.bz2
abslibre-38c4074ea8ab6039cbdbb03052f73fcf65666e50.zip
linux-libre-lts-3.14.41_gnu-1: updating version
* build with testing gcc-5; apply some upstream fixes for gcc-5 related build problems, disable a few modules that are not trivial to fix and where no simple upstream fix is available
Diffstat (limited to 'libre/linux-libre-lts/PKGBUILD')
-rw-r--r--libre/linux-libre-lts/PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/libre/linux-libre-lts/PKGBUILD b/libre/linux-libre-lts/PKGBUILD
index fa2557be6..8c7aa4b08 100644
--- a/libre/linux-libre-lts/PKGBUILD
+++ b/libre/linux-libre-lts/PKGBUILD
@@ -9,7 +9,7 @@
pkgbase=linux-libre-lts # Build kernel with -lts localname
_pkgbasever=3.14-gnu
-_pkgver=3.14.40-gnu
+_pkgver=3.14.41-gnu
_replacesarchkernel=('linux%') # '%' gets replaced with _kernelname
_replacesoldkernels=('kernel26%' 'kernel26-libre%') # '%' gets replaced with _kernelname
@@ -38,15 +38,16 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
'0002-module-allow-multiple-calls-to-MODULE_DEVICE_TABLE-p.patch'
'0003-module-remove-MODULE_GENERIC_TABLE.patch'
'0006-genksyms-fix-typeof-handling.patch'
+ 'gcc5_buildfixes.diff'
# loongson-community patch: http://linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/
'3.14.26-8475f027b4-loongson-community.patch')
sha256sums=('477555c709b9407fe37dbd70d3331ff9dde1f9d874aba2741f138d07ae6f281b'
'SKIP'
- 'ce132b3c3e72019cea2ab9bf5cb11871531ee60f06157e9ed8edf2115fa07693'
+ '120e97db433d48fb6d099497baa0da5b335eeb5ec48882a5c6911e93b6b08781'
'SKIP'
- 'a3d5c9546d61a84c93e59ba0a5cd725715b87cb1171aa224ff1ff960331e3fb1'
- '66edce909f5e051966c42ed104effb2fb706ef1340a4e248b184059f0ae90ab8'
- '18a94cb727c2cae80b1dbd3cddbb1e5484458d4c01b026b69cea68bc2df162d7'
+ 'b4cc9c49948fc1d571c27ddeddd93b5b499ccc17fb06fa75bfe41ecddfbc12e4'
+ '3fa8ce26aea9b5e596ccfc842baa3f2a8be8ef4a62bc13d75e8da2bafd89141c'
+ 'f15f2cf744d402e575713e4d500b82e7bcf8983aef5c97f82dcc9400ba4487f0'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'bfd4a7f61febe63c880534dcb7c31c5b932dde6acf991810b41a939a93535494'
'6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
@@ -56,6 +57,7 @@ sha256sums=('477555c709b9407fe37dbd70d3331ff9dde1f9d874aba2741f138d07ae6f281b'
'52dec83a8805a8642d74d764494acda863e0aa23e3d249e80d4b457e20a3fd29'
'65d58f63215ee3c5f9c4fc6bce36fc5311a6c7dbdbe1ad29de40647b47ff9c0d'
'cf2e7a2d00787f754028e7459688c2755a406e632ce48b60952fa4ff7ed6f4b7'
+ '470d6d019d288dce02b4a9758a34ea71d41715663a19a164749212a470a131e7'
'7c2d1e257acce0ea6f260f3acf18e30e21c12a9a6b3d7d1d4097dafd287388e2')
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
@@ -83,6 +85,12 @@ prepare() {
install -m644 -t drivers/video/logo \
"${srcdir}/logo_linux_"{clut224.ppm,vga16.ppm,mono.pbm}
+ # buildfixes for gcc5
+ # https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/drivers/scsi/qla2xxx/qla_nx2.c?id=9493c2422cae272d6f1f567cbb424195defe4176
+ # https://lkml.org/lkml/2014/11/9/27
+ # https://lkml.org/lkml/2014/12/14/55
+ patch -p1 -i "${srcdir}/gcc5_buildfixes.diff"
+
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git