summaryrefslogtreecommitdiff
path: root/libre/linux-libre-lts/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-10-23 00:26:55 -0200
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-10-23 00:26:55 -0200
commit21304f39a204aa02f76d9befd1aed9d6b1b5ffae (patch)
tree1f836e4d6d2b06d8d699bfd84e68e1a7b618342b /libre/linux-libre-lts/PKGBUILD
parent953fefe97b9f3cb7eea05daff1351fc347c9ef63 (diff)
downloadabslibre-21304f39a204aa02f76d9befd1aed9d6b1b5ffae.tar.gz
abslibre-21304f39a204aa02f76d9befd1aed9d6b1b5ffae.tar.bz2
abslibre-21304f39a204aa02f76d9befd1aed9d6b1b5ffae.zip
linux-libre-lts-3.0.47-1: updating version, adding module initialisation patches
Diffstat (limited to 'libre/linux-libre-lts/PKGBUILD')
-rwxr-xr-xlibre/linux-libre-lts/PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/libre/linux-libre-lts/PKGBUILD b/libre/linux-libre-lts/PKGBUILD
index d544abb26..65e5e55b0 100755
--- a/libre/linux-libre-lts/PKGBUILD
+++ b/libre/linux-libre-lts/PKGBUILD
@@ -7,10 +7,10 @@
pkgbase=linux-libre-lts # Build stock -LIBRE-LTS kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
_basekernel=3.0
-_sublevel=46
+_sublevel=47
pkgver=${_basekernel}.${_sublevel}
pkgrel=1
-_lxopkgver=${_basekernel}.45 # nearly always the same as pkgver
+_lxopkgver=${_basekernel}.46 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
@@ -28,9 +28,11 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'change-default-console-loglevel.patch'
'i915-fix-ghost-tv-output.patch'
'ext4-options.patch'
+ 'module-symbol-waiting-3.0.patch'
+ 'module-init-wait-3.0.patch'
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('5f64180fe7df4e574dac5911b78f5067'
- 'a2ced38cb23963b9efef79100f5885c5'
+ '6ad7f8f5b7230d1425dcb2c0bc336cf8'
'aed25ab047e1c0b020a1516c235c6a74'
'7d37e8ce0f4bd5a957172b12ae742ea0'
'c072b17032e80debc6a8626299245d46'
@@ -40,7 +42,9 @@ md5sums=('5f64180fe7df4e574dac5911b78f5067'
'9d3c56a4b999c8bfbd4018089a62f662'
'263725f20c0b9eb9c353040792d644e5'
'f36222e7ce20c8e4dc27376f9be60f6c'
- '2fb6f217d649733bd5d977bf32c1f292')
+ '670931649c60fcb3ef2e0119ed532bd4'
+ '8a71abc4224f575008f974a099b5cf6f'
+ '546d9b9893e49bddf13a106f890caf94')
if [ "$CARCH" != "mips64el" ]; then
# Don't use the Loongson-specific patches on non-mips64el arches.
unset source[${#source[@]}-1]
@@ -78,6 +82,11 @@ build() {
# https://bugs.archlinux.org/task/28653
patch -Np1 -i "${srcdir}/ext4-options.patch"
+ # fix module initialisation
+ # https://bugs.archlinux.org/task/32122
+ patch -Np1 -i "${srcdir}/module-symbol-waiting-3.0.patch"
+ patch -Np1 -i "${srcdir}/module-init-wait-3.0.patch"
+
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre-lts|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \