summaryrefslogtreecommitdiff
path: root/libre/licenses-libre/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-04-07 00:46:34 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-04-07 00:46:34 -0400
commit619b8d955269f2fe74386e98fac07675c8b55352 (patch)
treef3e2610a39c99a7e43bc2b345280b04e398b986a /libre/licenses-libre/PKGBUILD
parent2b04539ac9310541a4e563460aed0cb7715770d2 (diff)
parent7d4e98b2d6f2fd4d42ebb55105bab8a05e34ab94 (diff)
downloadabslibre-619b8d955269f2fe74386e98fac07675c8b55352.tar.gz
abslibre-619b8d955269f2fe74386e98fac07675c8b55352.tar.bz2
abslibre-619b8d955269f2fe74386e98fac07675c8b55352.zip
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/abslibre
Diffstat (limited to 'libre/licenses-libre/PKGBUILD')
-rw-r--r--libre/licenses-libre/PKGBUILD110
1 files changed, 58 insertions, 52 deletions
diff --git a/libre/licenses-libre/PKGBUILD b/libre/licenses-libre/PKGBUILD
index 8a3d62929..634d345c1 100644
--- a/libre/licenses-libre/PKGBUILD
+++ b/libre/licenses-libre/PKGBUILD
@@ -1,15 +1,16 @@
-# $Id: PKGBUILD 82120 2010-06-08 16:36:51Z dan $
+# $Id: PKGBUILD 176952 2013-02-03 00:38:36Z dan $
# Maintainer: Dan McGee <dan@archlinux.org>
# Maintainer (Parabola): fauno <fauno@kiwwwi.com.ar>
# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
+# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
pkgname=licenses-libre
-pkgver=2.9
-pkgrel=1
+pkgver=20130203
+pkgrel=1.1
pkgdesc="The standard licenses distribution package"
arch=('any')
license=('custom:none')
-url="http://parabolagnulinux.org"
+url="https://parabolagnulinux.org/"
groups=('base')
provides=("licenses=${pkgver}")
conflicts=('licenses')
@@ -29,100 +30,105 @@ source=(apache-2.0.txt::http://www.apache.org/licenses/LICENSE-2.0.txt
http://www.gnu.org/licenses/fdl-1.2.txt
http://www.gnu.org/licenses/fdl-1.3.txt
http://www.latex-project.org/lppl.txt
- http://www.mozilla.org/MPL/MPL-1.1.txt
+ mpl-1.1.txt::http://www.mozilla.org/MPL/1.1/index.txt
perlartistic.txt
http://www.perlfoundation.org/attachment/legal/artistic-2_0.txt
php-3.0.txt::http://www.php.net/license/3_0.txt
- ruby-license.txt::http://www.ruby-lang.org/en/LICENSE.txt
+ ruby-license.txt::http://www.ruby-lang.org/en/about/license.txt
cpl-1.0.txt
python-2.txt
+ w3c.txt
ZopePublicLicense.txt)
+md5sums=('3b83ef96387f14655fc854ddc3c6bd57'
+ 'ffb24d1bbf8b83d373f0b8edc3feb0c6'
+ '5367190077e12a7f55403d531ef3998e'
+ '77651e5c686cbc0f8cec5ac7e6504235'
+ '6cb35f3976cd093011967fa1abbce386'
+ 'f300afd598546add034364cd0a533261'
+ '73f1eb20517c55bf9493b7dd6e480788'
+ 'b234ee4d69f5fce4486a80fdaf4a4263'
+ 'd32239bcb673463ab874e80d47fae504'
+ '4fbd65380cdd255951079008b364516c'
+ 'e6a600fd5e1d9cbde2d983680233ad02'
+ '24ea4c7092233849b4394699333b5c56'
+ '10b9de612d532fdeeb7fe8fcd1435cc6'
+ '9f4337828d782bdea41f03dd2ad1b808'
+ 'bfe1f75d606912a4111c90743d6c7325'
+ 'd09c120ca7db95ef2aeecec0cb08293b'
+ 'b4a94da2a1f918b217ef5156634fc9e0'
+ 'a45bb1bbeed9e26b26c5763df1d3913d'
+ 'f24b942d957112d759762054b6e7cf34'
+ 'f083e41c43db25e18f36c91e57750b64'
+ 'a055911c32fb4ed6e96c453ceaeba857'
+ '6f2095b5d61770740852873b195a4d21'
+ 'dc8502850eab9e1ff330a12d7ca18a19')
-build() {
- cd $pkgdir
+package() {
+ cd "$pkgdir"
mkdir -p usr/share/licenses/common
cd usr/share/licenses/common
mkdir AGPL3
- cp $srcdir/agpl-3.0.txt AGPL3/license.txt
+ cp "$srcdir"/agpl-3.0.txt AGPL3/license.txt
ln -s AGPL3 AGPL
mkdir Apache
- cp $srcdir/apache-2.0.txt Apache/license.txt
+ cp "$srcdir"/apache-2.0.txt Apache/license.txt
ln -s Apache APACHE
mkdir Artistic2.0
- cp $srcdir/artistic-2_0.txt Artistic2.0/license.txt
+ cp "$srcdir"/artistic-2_0.txt Artistic2.0/license.txt
mkdir CCPL
- cp $srcdir/cc-by-3.0.txt CCPL/
- cp $srcdir/cc-by-sa-3.0.txt CCPL/
- cp $srcdir/cc-readme.txt CCPL/
+ cp "$srcdir"/cc-by-3.0.txt CCPL/
+ cp "$srcdir"/cc-by-sa-3.0.txt CCPL/
+ cp "$srcdir"/cc-readme.txt CCPL/
mkdir CDDL
- cp $srcdir/cddl-1.0.txt CDDL/license.txt
+ cp "$srcdir"/cddl-1.0.txt CDDL/license.txt
mkdir CPL
- cp $srcdir/cpl-1.0.txt CPL/license.txt
+ cp "$srcdir"/cpl-1.0.txt CPL/license.txt
mkdir EPL
- cp $srcdir/eclipse-1.0.txt EPL/license.txt
+ cp "$srcdir"/eclipse-1.0.txt EPL/license.txt
mkdir {GPL2,GPL3}
- cp $srcdir/gpl-2.0.txt GPL2/license.txt
- cp $srcdir/gpl-3.0.txt GPL3/license.txt
+ cp "$srcdir"/gpl-2.0.txt GPL2/license.txt
+ cp "$srcdir"/gpl-3.0.txt GPL3/license.txt
ln -s GPL2 GPL
mkdir {FDL1.2,FDL1.3}
- cp $srcdir/fdl-1.2.txt FDL1.2/license.txt
- cp $srcdir/fdl-1.3.txt FDL1.3/license.txt
+ cp "$srcdir"/fdl-1.2.txt FDL1.2/license.txt
+ cp "$srcdir"/fdl-1.3.txt FDL1.3/license.txt
ln -s FDL1.2 FDL
mkdir {LGPL2.1,LGPL3}
- cp $srcdir/lgpl-2.1.txt LGPL2.1/license.txt
- cp $srcdir/lgpl-3.0.txt LGPL3/license.txt
+ cp "$srcdir"/lgpl-2.1.txt LGPL2.1/license.txt
+ cp "$srcdir"/lgpl-3.0.txt LGPL3/license.txt
ln -s LGPL2.1 LGPL
mkdir LPPL
- cp $srcdir/lppl.txt LPPL/license.txt
+ cp "$srcdir"/lppl.txt LPPL/license.txt
mkdir MPL
- cp $srcdir/MPL-1.1.txt MPL/license.txt
+ cp "$srcdir"/mpl-1.1.txt MPL/license.txt
mkdir PerlArtistic
- cp $srcdir/perlartistic.txt PerlArtistic/license.txt
+ cp "$srcdir"/perlartistic.txt PerlArtistic/license.txt
mkdir PHP
- cp $srcdir/php-3.0.txt PHP/license.txt
+ cp "$srcdir"/php-3.0.txt PHP/license.txt
mkdir PSF
- cp $srcdir/python-2.txt PSF/license.txt
+ cp "$srcdir"/python-2.txt PSF/license.txt
mkdir RUBY
- cp $srcdir/ruby-license.txt RUBY/license.txt
+ cp "$srcdir"/ruby-license.txt RUBY/license.txt
+
+ mkdir W3C
+ cp "$srcdir"/w3c.txt W3C/license.txt
mkdir ZPL
- cp $srcdir/ZopePublicLicense.txt ZPL/license.txt
+ cp "$srcdir"/ZopePublicLicense.txt ZPL/license.txt
}
-md5sums=('3b83ef96387f14655fc854ddc3c6bd57'
- 'ffb24d1bbf8b83d373f0b8edc3feb0c6'
- '5367190077e12a7f55403d531ef3998e'
- '77651e5c686cbc0f8cec5ac7e6504235'
- '6cb35f3976cd093011967fa1abbce386'
- 'f300afd598546add034364cd0a533261'
- '73f1eb20517c55bf9493b7dd6e480788'
- 'b234ee4d69f5fce4486a80fdaf4a4263'
- 'd32239bcb673463ab874e80d47fae504'
- '4fbd65380cdd255951079008b364516c'
- 'e6a600fd5e1d9cbde2d983680233ad02'
- '24ea4c7092233849b4394699333b5c56'
- '10b9de612d532fdeeb7fe8fcd1435cc6'
- '9f4337828d782bdea41f03dd2ad1b808'
- 'bfe1f75d606912a4111c90743d6c7325'
- 'd09c120ca7db95ef2aeecec0cb08293b'
- 'b4a94da2a1f918b217ef5156634fc9e0'
- 'a45bb1bbeed9e26b26c5763df1d3913d'
- 'bfecdc446cd2a6a4410ac9e6d0064b3a'
- 'f083e41c43db25e18f36c91e57750b64'
- 'a055911c32fb4ed6e96c453ceaeba857'
- 'dc8502850eab9e1ff330a12d7ca18a19')