summaryrefslogtreecommitdiff
path: root/libre/libkgapi/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-26 16:51:56 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-26 19:51:55 +0100
commit454b7c9151ee3c96655b6f9ce1c3713cc4119390 (patch)
treee268f78b14e87717f16f37abe2359fd186410bbf /libre/libkgapi/PKGBUILD
parent0b43f9d21211bdd9f501d8260afce00bff66d868 (diff)
downloadabslibre-454b7c9151ee3c96655b6f9ce1c3713cc4119390.tar.gz
abslibre-454b7c9151ee3c96655b6f9ce1c3713cc4119390.tar.bz2
abslibre-454b7c9151ee3c96655b6f9ce1c3713cc4119390.zip
libre/libkgapi: added
Diffstat (limited to 'libre/libkgapi/PKGBUILD')
-rw-r--r--libre/libkgapi/PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/libre/libkgapi/PKGBUILD b/libre/libkgapi/PKGBUILD
new file mode 100644
index 000000000..53cc89971
--- /dev/null
+++ b/libre/libkgapi/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
+# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
+
+# parabola changes and rationale:
+# - reverting from qt5-webengine back to qt5-webkit
+
+pkgname=libkgapi
+pkgver=18.12.2
+pkgrel=1
+pkgrel+=.parabola1
+pkgdesc="A KDE-based library for accessing various Google services via their public API"
+pkgdesc+=" (without nonfree qt5-webengine)"
+url='https://www.kde.org/'
+arch=(x86_64)
+arch+=(i686 armv7h)
+license=(GPL LGPL FDL)
+depends=(kcalcore kcontacts qt5-webkit kio)
+makedepends=(extra-cmake-modules qt5-tools)
+source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
+ libre.patch)
+sha256sums=('041aa032397e254d6c8f20240d5c3de072a8e06521143c5a614c78ebe04696a7'
+ 'SKIP'
+ '7ca4817130bc78822798c1fc54e6800db4283da858ba2a142fc5110c48221000')
+validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
+ F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
+
+prepare() {
+ mkdir -p build
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/libre.patch
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}