summaryrefslogtreecommitdiff
path: root/libre/kile/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-05 00:58:57 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-05 00:58:57 -0300
commit7988d6b367de8e5983d7571dd962dc77863eaa60 (patch)
tree7c1fee93750f2972e54ec95ddadcd830092fff5e /libre/kile/PKGBUILD
parentc8b1e23a1567aea2f24f105081d8b699731d9a66 (diff)
downloadabslibre-7988d6b367de8e5983d7571dd962dc77863eaa60.tar.gz
abslibre-7988d6b367de8e5983d7571dd962dc77863eaa60.tar.bz2
abslibre-7988d6b367de8e5983d7571dd962dc77863eaa60.zip
kile: remove libre suffix and add complex pkgrel
Diffstat (limited to 'libre/kile/PKGBUILD')
-rw-r--r--libre/kile/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/libre/kile/PKGBUILD b/libre/kile/PKGBUILD
new file mode 100644
index 000000000..c909db92b
--- /dev/null
+++ b/libre/kile/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 216381 2014-07-03 06:23:23Z fyan $
+# Maintainer (Arch): Ronald van Haren <ronald.archlinux.org>
+# Contributor (Arch): Damir Perisa <damir.perisa@bluewin.ch>
+# Maintainer: Michał Masłowski <mtjm@mtjm.eu>
+# Contributor: André Silva <emulatorman@parabola.nu>
+
+pkgname=kile
+pkgver=2.1.3
+pkgrel=3.parabola1
+pkgdesc="A user friendly TeX/LaTeX frontend for KDE, without nonfree Adobe Reader recommendation"
+arch=("i686" "x86_64")
+license=('GPL2')
+url="http://kile.sourceforge.net/"
+depends=('kdebase-runtime' 'texlive-core' 'kdebase-katepart')
+makedepends=('cmake' 'automoc4')
+optdepends=('kdebase-konsole: embedded terminal')
+conflicts=('kile-libre')
+replaces=('kile-libre')
+install=${pkgname}.install
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
+ "libre.patch")
+sha1sums=('1a80748d5f01f359b5e5c28140ec90691f0166c5'
+ '9bbe5d1b0e2a78b13667fcf4e5e21f801447f9d6')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # Remove nonfree Adobe Reader recommendation
+ patch -Np1 -i "${srcdir}/libre.patch"
+ cd ..
+ mkdir build
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/build
+ make DESTDIR="${pkgdir}" install
+}