summaryrefslogtreecommitdiff
path: root/libre/kdevelop/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2021-06-04 08:56:42 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2021-06-04 18:18:30 -0400
commitd554e494086f2d95b85c5673533b53db6b0be60e (patch)
treeb8280bc741b3cb8b1e02f1d13043994e30550dcc /libre/kdevelop/PKGBUILD
parent3435f24c14fd196529471669562ed85f8c79dd47 (diff)
downloadabslibre-d554e494086f2d95b85c5673533b53db6b0be60e.tar.gz
abslibre-d554e494086f2d95b85c5673533b53db6b0be60e.tar.bz2
abslibre-d554e494086f2d95b85c5673533b53db6b0be60e.zip
[kdevelop]: upgrade to v5.6.2
Diffstat (limited to 'libre/kdevelop/PKGBUILD')
-rw-r--r--libre/kdevelop/PKGBUILD65
1 files changed, 34 insertions, 31 deletions
diff --git a/libre/kdevelop/PKGBUILD b/libre/kdevelop/PKGBUILD
index 354f4f2f5..e5a0b010f 100644
--- a/libre/kdevelop/PKGBUILD
+++ b/libre/kdevelop/PKGBUILD
@@ -1,54 +1,57 @@
-# $Id$
-# Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
-# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
-# Contributor (Arch): Giovanni Scafora <giovanni@archlinux.org>
+# Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+
+
+# parabola changes and rationale:
+# - arch package links to qt5-webengine
+# - no changes necessary - simply rebuild without qt5-webengine in the environment
+
pkgname=kdevelop
-pkgver=5.3.2
-_clangver=8.0.0
-pkgrel=1.parabola2
-pkgdesc='C++ IDE using KDE technologies, without qt5-webengine dependency'
-arch=(x86_64 i686 armv7h)
+pkgver=5.6.2
+_clangver=11.1.0
+pkgrel=3
+pkgrel+=.parabola1
+pkgdesc='C++ IDE using KDE technologies'
+pkgdesc+=', without qt5-webengine dependency'
+arch=(x86_64)
+arch+=(armv7h i686)
url='http://www.kdevelop.org/'
license=(GPL)
-depends=(clang=$_clangver libksysguard kitemmodels knotifyconfig ktexteditor grantlee libkomparediff2 qt5-webkit
+depends=(clang=$_clangver libksysguard kitemmodels knotifyconfig ktexteditor grantlee libkomparediff2
kcmutils threadweaver knewstuff)
-makedepends=(extra-cmake-modules kdoctools kdevelop-pg-qt llvm qt5-tools plasma-framework krunner okteta python mesa
- boost purpose subversion)
+makedepends=(extra-cmake-modules kdoctools kdevelop-pg-qt llvm qt5-tools plasma-framework krunner okteta boost purpose subversion astyle)
optdepends=('konsole: embedded terminal'
- 'git: Git support' 'subversion: SVN support' 'cvs: CVS support'
+ 'git: Git support' 'subversion: SVN support'
'gdb: GNU debugger support' 'lldb: LLDB debugger support'
'qt5-doc: Qt documentation integration'
'cmake: cmake integration'
+ 'meson: meson integration'
'qt5-tools: qthelp plugin'
'okteta: GNU debugger support'
'plasma-framework: for the plasma addons'
'purpose: patch review plugin'
+ 'astyle: astyle plugin'
'cppcheck: code analyzer' 'heaptrack: memory profiler'
- 'kdevelop-clang-tidy: clang-tidy analyzer plugin' 'clazy: clazy analyzer plugin')
+ 'clazy: clazy analyzer plugin')
conflicts=(kdevelop-qmljs kdevplatform)
-replaces=(kdevelop-qmljs kdevplatform)
-source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.asc})
-sha256sums=('08ccd575514187dcbd01ac976a619803410c26bdfabf5d2d5fd52c95b76d6f2a'
+replaces=(kdevelop-qmljs kdevplatform kdevelop-clang-tidy)
+source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
+sha256sums=('0f86bc3fe53f761c1e3e3f7544577a0c41433be8bff310cf2e729f76f4363bf6'
'SKIP')
validpgpkeys=('329FD02C5AA48FCC77A4BBF0AC44AC6DB29779E6' # Sven Brauch <mail@svenbrauch.de>
- '364EFA5F639572907D392999C64CF56B13CACE5D') # Kevin Funk <kfunk@kde.org>
-
-prepare() {
- mkdir -p build
-}
+ '364EFA5F639572907D392999C64CF56B13CACE5D' # Kevin Funk <kfunk@kde.org>
+ 'E191FD5BE6F46870F09E82B2024E7FB43D015474' # Friedrich W. H. Kossebau <kossebau@kde.org>
+ '0A48BC961075B4BA8523E3790A345FB086E797D9' # https://share.kde.org/s/8dKaJTw8pR8iiwJ
+ 'C51B45A532F17FA401D099A0A0C6B72C4F1C5E7C') # Milian Wolff <mail@milianw.de>
build() {
- cd build
- cmake ../$pkgname-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
-# -DBUILD_TESTING=OFF #turrned off because [extra/umbrello] needs libKDevPlatformTests.so.xx
- make
+ cmake -B build -S $pkgname-$pkgver \
+ -DBUILD_TESTING=OFF
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}