summaryrefslogtreecommitdiff
path: root/libre/kdepim-runtime/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-26 19:54:24 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-26 22:50:35 +0100
commitd76fa0afa1dbf7f4c4cb34b70d4892afb2fdbf8e (patch)
tree44518b31fa777f227197129eab3ca3007598a8b6 /libre/kdepim-runtime/PKGBUILD
parentd8f62f3141ec2517b6b41efdbd8dbd6d1771628c (diff)
downloadabslibre-d76fa0afa1dbf7f4c4cb34b70d4892afb2fdbf8e.tar.gz
abslibre-d76fa0afa1dbf7f4c4cb34b70d4892afb2fdbf8e.tar.bz2
abslibre-d76fa0afa1dbf7f4c4cb34b70d4892afb2fdbf8e.zip
libre/kdepim-runtime: updated to 18.12.2
Diffstat (limited to 'libre/kdepim-runtime/PKGBUILD')
-rw-r--r--libre/kdepim-runtime/PKGBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/libre/kdepim-runtime/PKGBUILD b/libre/kdepim-runtime/PKGBUILD
index 90a24ee94..ce4a0a782 100644
--- a/libre/kdepim-runtime/PKGBUILD
+++ b/libre/kdepim-runtime/PKGBUILD
@@ -1,25 +1,30 @@
-# $Id: PKGBUILD 290221 2017-03-09 16:12:45Z arojas $
# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
+# Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
# Contributor (Arch): Pierre Schmitz <pierre@archlinux.de>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Contributor: André Silva <emulatorman@hyperbola.info>
pkgname=kdepim-runtime
-pkgver=16.12.3
-pkgrel=1.parabola2
-pkgdesc='Extends the functionality of kdepim (built without nonfree qt5-webengine)'
-arch=('i686' 'x86_64' 'armv7h')
-url='https://community.kde.org/KDE_PIM'
-license=('GPL' 'LGPL' 'FDL')
-depends=(libkgapi libkolab akonadi-calendar knotifyconfig kross kalarmcal kmbox kimap hicolor-icon-theme)
-makedepends=(extra-cmake-modules kdoctools boost python kdesignerplugin)
+pkgver=18.12.2
+pkgrel=1
+pkgrel+=.parabola1
+pkgdesc='Extends the functionality of kdepim'
+pkgdesc+=' (built without nonfree qt5-webengine)'
+arch=(x86_64)
+arch+=(i686 armv7h)
+url='https://kontact.kde.org'
+license=(GPL LGPL FDL)
+depends=(libkolabxml kdav akonadi-calendar knotifyconfig kalarmcal kmbox pimcommon akonadi-notes kdelibs4support)
+makedepends=(extra-cmake-modules kdoctools boost kdesignerplugin qca qt5-networkauth)
+optdepends=('qca: EWS resource' 'qt5-networkauth: EWS resource')
conflicts=(kio-pim)
source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
'libre.patch')
-sha256sums=('e1ad03f80737bc4afaa101f108430b011ad2e2c1349e477a66ce59bc901fac48'
+sha256sums=('b7d5cd9e03688f62f4b36f1867ba681a2ce8d806817d3d2be1c615f07b3f6e45'
'SKIP'
- 'b98d522c5335692a724b76491e14aedb343301227ff59560381eabf871e6b36f')
-validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7) # Albert Astals Cid <aacid@kde.org>
+ '312d76a56e3b39151465a8cd7e96b522f05eb53bac7f7d984fa09858498f4a2b')
+validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
+ F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <cfeck@kde.org>
prepare() {
mkdir -p build
@@ -30,10 +35,9 @@ prepare() {
build() {
cd build
cmake ../$pkgname-$pkgver \
- -DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=OFF \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib
make
}