summaryrefslogtreecommitdiff
path: root/libre/kdepim-runtime/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-03-10 07:07:12 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-03-10 07:07:12 -0300
commit13369879ec8ee731b86b7aab2719d2dd1962fe84 (patch)
tree469234a0be5f827d68b8b3a41d6415ac3be785e4 /libre/kdepim-runtime/PKGBUILD
parent77e3a5d98c49586f34cbf5588cb9d63c9b6627a0 (diff)
downloadabslibre-13369879ec8ee731b86b7aab2719d2dd1962fe84.tar.gz
abslibre-13369879ec8ee731b86b7aab2719d2dd1962fe84.tar.bz2
abslibre-13369879ec8ee731b86b7aab2719d2dd1962fe84.zip
kdepim-runtime: add new package to [libre]
Diffstat (limited to 'libre/kdepim-runtime/PKGBUILD')
-rw-r--r--libre/kdepim-runtime/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/libre/kdepim-runtime/PKGBUILD b/libre/kdepim-runtime/PKGBUILD
new file mode 100644
index 000000000..38d87eb31
--- /dev/null
+++ b/libre/kdepim-runtime/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id: PKGBUILD 290221 2017-03-09 16:12:45Z arojas $
+# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
+# Contributor (Arch): Andrea Scarpino <andrea@archlinux.org>
+# Contributor (Arch): Pierre Schmitz <pierre@archlinux.de>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+pkgname=kdepim-runtime
+pkgver=16.12.3
+pkgrel=1.parabola1
+pkgdesc='Extends the functionality of kdepim, without nonfree qt5-webengine support'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://community.kde.org/KDE_PIM'
+license=('GPL' 'LGPL' 'FDL')
+depends=(libkgapi libkolab akonadi-calendar knotifyconfig kross kalarmcal kmbox kimap hicolor-icon-theme)
+makedepends=(extra-cmake-modules kdoctools boost python kdesignerplugin)
+conflicts=(kio-pim)
+source=("https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig}
+ 'libre.patch')
+sha256sums=('e1ad03f80737bc4afaa101f108430b011ad2e2c1349e477a66ce59bc901fac48'
+ 'SKIP'
+ 'b98d522c5335692a724b76491e14aedb343301227ff59560381eabf871e6b36f')
+validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7) # Albert Astals Cid <aacid@kde.org>
+
+prepare() {
+ mkdir -p build
+ cd $pkgname-$pkgver
+ patch -p1 -i ../libre.patch
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTING=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}