summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-07-14 09:39:10 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2019-08-01 21:12:16 -0400
commit4a999b141760f984d0372c69ee855dead8689239 (patch)
tree5b3907c13d0f13b51e4237e20057f86d78a5eb03 /libre/iceweasel/PKGBUILD
parent74c33b00f724d1ca6bc215f0b5a6011fd7093379 (diff)
downloadabslibre-4a999b141760f984d0372c69ee855dead8689239.tar.gz
abslibre-4a999b141760f984d0372c69ee855dead8689239.tar.bz2
abslibre-4a999b141760f984d0372c69ee855dead8689239.zip
[iceweasel]: upgrade to v68.0.1
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD117
1 files changed, 71 insertions, 46 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index b7765ccad..f21eb290f 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -36,12 +36,13 @@
#
# [1]: https://www.mozilla.org/en-US/foundation/trademarks/policy/
+
pkgname=iceweasel
replaces=('firefox')
epoch=1
-pkgver=67.0
+pkgver=68.0.1
pkgrel=1
-pkgrel+=.parabola1
+pkgrel+=.parabola2
_brandingver=67.0
_brandingrel=2
pkgdesc="Libre standalone web browser based on Mozilla Firefox"
@@ -55,7 +56,8 @@ depends+=(sqlite icu)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2
python nodejs python2-psutil cbindgen nasm)
-makedepends+=(mozilla-searchplugins quilt libxslt imagemagick)
+# FIXME: 'mozilla-serarchengines' package needs re-working
+makedepends+=(quilt libxslt imagemagick)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -63,33 +65,34 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !debug)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
- 0001-bz-1521249.patch
$pkgname.desktop
https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
- libre-searchengines.patch
- libre.patch
arm.patch
- build-arm-libopus.patch)
-sha256sums=('2cb937db00e35162393aa5b65d1f2280be1e62d5ee33d3e9997cccba542d791b'
+ build-arm-libopus.patch
+ newtab.patch
+ libre.patch
+ searchengines.patch)
+# FIXME: branding tarball needs re-working
+source+=(aboutlogins.svg)
+sha256sums=('6037f77bdab29d79ca5e3fbd1d32f6c209e09d2066189a13dc7f7491227f5568'
'SKIP'
- 'd0673786a6a1f1b9f6f66a3a1356afa33f1f18f59dabd92bd193c88c52a1d04c'
'e439117380218898cd5c60a8da8947847efbd0fe64cc06b129d6ca20a392cb3d'
'0151b49e9f5d3bdce64ac0854d84fa5157a65df2d7e16eb683366cbeee021805'
'SKIP'
- '7b53a5528bbc24bb8d981b6298929a44e8ff01724eee0eedfebc2627dd56b565'
- 'a315507efe495ba55ab4ae52b1e2b3a0c1e7ac54b7ed976899da1dcd03532f95'
- 'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
- '2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9')
+ '2bb1f6b9b66a00f4f98eb5cdb2f25972018efe042153503cbc8c494780d7225e'
+ '2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
+ '294c88a7aa970f63c44dcb15cd0be12f73679b446804846825a16e4fb4a5d40f'
+ '783e1b7c2f6f8719cc8a0751aacc823a5029c2326ac0b5ff7c659d831e286387'
+ 'dfed11d97f1d4198a3dc608be159b6b53a11054f376cdb73bb0fe9a487ae9418')
+sha256sums+=('SKIP')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353' # Mozilla Software Releases
'BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
prepare() {
+ [[ -d mozbuild ]] && rm -rf mozbuild
mkdir mozbuild
cd firefox-$pkgver
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
- patch -Np1 -i ../0001-bz-1521249.patch
-
cat >.mozconfig <<END
ac_add_options --enable-application=browser
@@ -147,9 +150,9 @@ END
cat >> .mozconfig <<END
ac_add_options --enable-optimize="-O2"
-ac_add_options --disable-webrtc
ac_add_options --disable-elf-hack
ac_add_options --disable-av1
+mk_add_options MOZ_MAKE_FLAGS="$MAKEFLAGS"
END
fi
@@ -169,50 +172,72 @@ END
fi
## Rebranding
- local brandingdir="$srcdir/$pkgname-$_brandingver"
- rm -rf -- browser/branding/$pkgname
- cp -aT -- $brandingdir/branding browser/branding/$pkgname
- # patching
- export QUILT_PATCHES=$brandingdir/patches
- export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
- export QUILT_DIFF_ARGS='--no-timestamps'
- quilt push -av
+ local brandingsrcdir="${srcdir}/${pkgname}-${_brandingver}"
+ local brandingdestdir=browser/branding/${pkgname}
+ rm -rf -- ${brandingdestdir}
+ cp -aT -- ${brandingsrcdir}/branding ${brandingdestdir}
+# TODO: dont know what aboutlogins.svg is supposed to be or what it is for
+cp ${brandingdestdir}/iceweasel_logo.svg ${brandingdestdir}/content/aboutlogins.svg
+
+ # FIXME: the newtab page (aka "Start Page") has changed significantly
+ # some of the branding components (commented out) above may no longer be used
+ # the following section aims to restore something similar
+ # as the previous parabola-branded "start page"
+ # this is untested - once it is working well, all of these comments should be removed
+ # and any unused branding components may be deleted from the branding package
+ # this is essentially re-branding, so perhaps 'newtab.patch' should eventually
+ # be moved into the branding tarball
# Put "Start Page" branding images in the source code
#install -m644 -t browser/base/content/abouthome -- \
- # "$brandingdir/branding"/{drm-free,gnu_headshadow,parabola-banner}.png
+ # "${brandingsrcdir}/branding"/{drm-free,gnu_headshadow,parabola-banner}.png
#install -m644 -t browser/extensions/onboarding/content/img -- \
- # "$brandingdir/branding/watermark.svg"
+ # "${brandingsrcdir}/branding/watermark.svg"
+ # custom new tab page
+ local newtabdestdir=browser/components/newtab/data/content/assets/
+ patch -Np1 -i "${srcdir}/newtab.patch"
+ install -m644 "${brandingsrcdir}"/branding/iceweasel_logo.svg ${newtabdestdir}
+ install -m644 "${brandingsrcdir}"/branding/parabola-banner.png ${newtabdestdir}
+
# produce icons
for i in 16 22 24 32 48 64 128 192 256 384; do
- rsvg-convert -w $i -h $i "$brandingdir/branding/${pkgname}_icon.svg" \
- -o "browser/branding/iceweasel/default$i.png"
+ rsvg-convert -w $i -h $i "${brandingsrcdir}/branding/${pkgname}_icon.svg" \
+ -o "${brandingdestdir}/default$i.png"
done
+ ## Patching
+ export QUILT_PATCHES="${brandingsrcdir}"/patches
+ export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
+ export QUILT_DIFF_ARGS='--no-timestamps'
+ quilt push -av
+
# Remove remaining non-free bits
patch -Np1 -i "$srcdir/libre.patch"
- #sed -i 's/Adobe Flash/SWF Player/g' -- \
- # browser/base/content/pageinfo/permissions.js \
- # browser/base/content/browser-plugins.js
- #sed -e '/"displayName": "Flash"/ s/Flash/SWF Player/' \
- # -e '/"displayName": "Shockwave"/ s/Shockwave/DCR Player/' \
- # -e '/"displayName": "QuickTime"/ s/QuickTime/MOV Player/' \
- # -e '/installLinux/ s/true/false/' \
- # -i -- browser/base/content/browser-plugins.js
- # re-use 'abouthome' page for 'newtab' page
- #install -d browser/base/content/newtab
- #cat browser/base/content/abouthome/aboutHome.xhtml > browser/base/content/newtab/newTab.xhtml
-
- # Load our searchplugins
- patch -Np1 -i "$srcdir/libre-searchengines.patch"
- rm -rvf -- browser/components/search/searchplugins/{*.xml,images/}
- cp -av -- /usr/lib/mozilla/searchplugins/* browser/components/search/searchplugins/
-
# Disable various components at the source level
sed -i 's/;1/;0/' toolkit/components/telemetry/components.conf
#sed -i 's/;1/;0/' browser/experiments/Experiments.manifest
#sed -i '/pocket/d' browser/extensions/moz.build
#sed -i '/activity-stream/d' browser/extensions/moz.build
+
+ # Load custom searchplugins
+ # FIXME: no longer applicable - replace with (broken) replacement fo libre/mozilla-searchplugins
+ # https://git.parabola.nu/packages/iceweasel.git/tree/branding-dev-build/mozilla-searchplugins?h=68.0
+# rm -rvf -- browser/components/search/searchplugins/{*.xml,images/}
+# cp -av -- /usr/lib/mozilla/searchplugins/* browser/components/search/searchplugins/
+
+ # Patch search-engines config
+ # FIXME: custom searchplugins ID per new format above ("ddg" is standard)
+ # browser/components/search/extensions/<ID>/
+# local _remove_engines_sed='s|.*oogle.*| "ddg", "duckduckgo-html", "duckduckgo-lite", "internet-archive", "parabola-labs", "parabola-packages", "parabola-wiki-en", "searx", "wikipedia", "yacy"|g'
+ local _remove_engines_sed='s|.*oogle.*| "ddg", "wikipedia"|g'
+ local _search_config_file=browser/components/search/extensions/list.json
+ patch -Np1 -i "$srcdir/searchengines.patch"
+ sed -i "${_remove_engines_sed}" ${_search_config_file}
+
+ # Sanity-check search-engines patching
+ _removed_engines_regex='Bing|Google|Seznam|Twitter|Yahoo|Yandex|Яндекс|amazon|bing|google|ebay|twitter'
+ _err_msg="search-engines patch needs re-working"
+ ! grep -E ${_removed_engines_regex} ${_search_config_file} > /dev/null || ! echo "${_err_msg}"
}
build() {