summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-08-15 13:49:04 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2013-08-15 13:49:04 -0300
commit7f3594a559885bd5c963d252e20ff382595bddbb (patch)
tree0d6438add0d9270c08bc71fdb0f4cc9c29d9dffa /libre/iceweasel-libre/PKGBUILD
parent88acb10b717bb3ed9fc4c0a3542b095451b8846c (diff)
downloadabslibre-7f3594a559885bd5c963d252e20ff382595bddbb.tar.gz
abslibre-7f3594a559885bd5c963d252e20ff382595bddbb.tar.bz2
abslibre-7f3594a559885bd5c963d252e20ff382595bddbb.zip
iceweasel-libre-23.0.2-2: disable missing nonfree flash notification by default
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index a4c9ef5b1..824a815a4 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -22,7 +22,7 @@ debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
_pkgname=iceweasel
pkgname=iceweasel-libre
pkgver=$_debver.$_debrel
-pkgrel=1
+pkgrel=2
pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 mips64el)
@@ -57,11 +57,11 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
md5sums=('567bfd5b1bc0639b4f2e53a6e921ed5d'
'1681363327ec8642ddb615bc20cb41c2'
'2d7ac85c32df6a4ccfcc6de7a1420bf7'
- '383e8e2a97a8b13fe56d153adb6878b6'
+ 'df08eaa1ac3bc6c2356be4fbf8ec8932'
'4f656688fe7bc0b11899369e0e23e516'
'7b9e5996dd9fe0b186a43a297db1c6b5'
'abf5ecb74caa857abb42bcfbb3442d9c'
- '98e8904f72cc1cf5674730ca9746ee3e'
+ '0b88d6142f6131711dcb1a2d87a12ad2'
'52e52f840a49eb1d14be1c0065b03a93'
'a8fc4658d45b6bf9350023e5c3f34e56'
'6e335a517c68488941340ee1c23f97b0'
@@ -168,14 +168,14 @@ build() {
fi
if $_pgo; then
- export DISPLAY=:99
Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
- _fail=0
- make -f client.mk build MOZ_PGO=1 || _fail=1
+ if ! make -f client.mk build MOZ_PGO=1; then
+ kill $!
+ return 1
+ fi
kill $! || true
- return $_fail
else
make -f client.mk build
fi