summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-06-02 22:54:10 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-06-02 22:54:10 -0300
commit4ce84837520f8c56ae998d5d2d98380faf3e3eb5 (patch)
treeb22e90f4dc9b313fbc814852c874e4fb31a8d0c7 /libre/iceweasel-libre/PKGBUILD
parent5f74139e49aec90fef556447373608db10d9f1e6 (diff)
parent96b3ccdea0907e8df071273f302e1640b05d07c6 (diff)
downloadabslibre-4ce84837520f8c56ae998d5d2d98380faf3e3eb5.tar.gz
abslibre-4ce84837520f8c56ae998d5d2d98380faf3e3eb5.tar.bz2
abslibre-4ce84837520f8c56ae998d5d2d98380faf3e3eb5.zip
Merge branch 'master' of ssh://gparabola/srv/git/abslibre
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD34
1 files changed, 23 insertions, 11 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index fdca2f627..63519ceb9 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -13,7 +13,7 @@ _pgo=false
# We're getting this from Debian Sid
_debname=iceweasel
_debver=12.0
-_debrel=3
+_debrel=7
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -27,11 +27,12 @@ if $_pgo; then
pkgname+='-pgo'
fi
-pkgdesc="A libre version of Debian Iceweasel, the browser based on Mozilla Firefox."
+pkgdesc="A libre version of Debian Iceweasel, the Browser based on Mozilla Firefox."
arch=('i586' 'i686' 'x86_64' 'mips64el')
license=('GPL2' 'MPL' 'LGPL')
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'mozilla-searchplugins' 'nss>=3.13.1' 'sqlite3' 'startup-notification')
-makedepends=( 'autoconf2.13' 'diffutils' 'imagemagick' 'libidl2' 'librsvg' 'libxslt' 'mesa' 'pkg-config' 'python2' 'quilt' 'unzip' 'wireless_tools' 'yasm' 'zip')
+makedepends=( 'autoconf2.13' 'diffutils' 'imagemagick' 'libidl2' 'librsvg' 'libxslt' 'mesa' 'pkg-config' 'python2' 'quilt' 'unzip' 'wireless_tools' 'zip')
+[ "$CARCH" != "mips64el" ] && makedepends+=('yasm')
if $_pgo; then
makedepends+=('xorg-server-xvfb')
options=(!ccache)
@@ -48,19 +49,17 @@ source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
libre.patch
iceweasel-install-dir.patch
region.properties
- vendor.js
- gcc47.patch)
+ vendor.js)
md5sums=('b45f57bfe21b0e6db4f0683e794917cb'
- '2b66fb2e51631ef3b07de89ef9d17d0c'
- '552adcf5da3b07757e7fe29c8bd2ec2d'
- '34786fca48963a7bea5d55d17a406c35'
+ '08aa0a949d9cbb26116490f7878a62fe'
+ 'd7ad1c025d2442427a06cc702906ef0d'
+ 'eab149c1994ab14392e55af3abb08e80'
'ac29b01c189f20abae2f3eef1618ffc0'
'a485a2b5dc544a8a2bd40c985d2e5813'
'64be2fab525189c285ee04495d628035'
'e529742c0a425648087bc3ce537fe4c5'
'f1c76e7e244257856a386ca2de69bdf0'
- '0d053487907de4376d67d8f499c5502b'
- '79e471e0bd03b1d4e84fd3a6776bd619')
+ '0d053487907de4376d67d8f499c5502b')
if [ "$_pkgname" != "$pkgname" ]; then
provides+=("$_pkgname=$pkgver")
@@ -97,7 +96,6 @@ if [ $NOEXTRACT -eq 0 ]; then
cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
- patch -Np1 -i "$srcdir/gcc47.patch" # fix to compile with gcc47
patch -Np1 -i "$srcdir/xulrunner-copy-stub.patch" # small fix
patch -Np1 -i "$srcdir/libre.patch"
fi
@@ -124,6 +122,20 @@ fi
sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
browser/base/Makefile.in
+ # This is a bug, we should fix it.
+ if [ "$CARCH" = "mips64el" ]; then
+ # Fix MIPS N32 support.
+ sed -i 's/defined(_ABIO32)/(defined(_ABIO32) || defined(_ABIN32))/' \
+ js/src/assembler/wtf/Platform.h
+ # Disable JIT.
+ sed -ri 's/#define ENABLE_(JIT|ASSEMBLER) 1/#define ENABLE_\1 0/' \
+ js/src/assembler/wtf/Platform.h
+ sed -ri 's/ENABLE_(JIT|ASSEMBLER)=1/ENABLE_\1=0/' js/src/Makefile.in
+ echo 'ac_add_options --disable-methodjit' >> .mozconfig
+ echo 'ac_add_options --disable-tracejit' >> .mozconfig
+ echo 'ac_add_options --disable-jemalloc' >> .mozconfig
+ fi
+
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$_pkgname"
export PYTHON="/usr/bin/python2"