summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-06-05 22:11:10 -0300
committerAndré Fabian Silva Delgado <andre@pc-01.localdomain>2012-06-05 22:11:10 -0300
commit36c538f1b0b84cc8fe8895553f9348ba68f1b09e (patch)
tree3e63886adb58c426db6cfa4e2a84ed2f29c031a0 /libre/iceweasel-libre/PKGBUILD
parent04c8955a74d466f3642e94a8da2aecc23b7a7b0e (diff)
downloadabslibre-36c538f1b0b84cc8fe8895553f9348ba68f1b09e.tar.gz
abslibre-36c538f1b0b84cc8fe8895553f9348ba68f1b09e.tar.bz2
abslibre-36c538f1b0b84cc8fe8895553f9348ba68f1b09e.zip
iceweasel-libre-13.0.1-1: fixing issues
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 8d0c63f13..bc2066080 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -3,6 +3,7 @@
# Contributor: Figue <ffigue at gmail>
# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
# Contributor (Parabola): vando <facundo@esdebian.org>
+# Contributor (Parabola): André Silva <andre.paulista@adinet.com.uy>
# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
# Thank you very much to the older contributors:
# Contributor: evr <evanroman at gmail>
@@ -49,17 +50,19 @@ source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
libre.patch
iceweasel-install-dir.patch
region.properties
- vendor.js)
+ vendor.js
+ Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch)
md5sums=('e440446bb92dc1c0311346c68024590b'
'cb8bfb543002a5d78db7e8661f9f87ec'
'a9848e41461776bc4bf8d2de824b1204'
'eab149c1994ab14392e55af3abb08e80'
'ac29b01c189f20abae2f3eef1618ffc0'
'a485a2b5dc544a8a2bd40c985d2e5813'
- '64be2fab525189c285ee04495d628035'
+ '1c23b150a9c2eeb378f167a1dfa09d89'
'e529742c0a425648087bc3ce537fe4c5'
'f1c76e7e244257856a386ca2de69bdf0'
- '0d053487907de4376d67d8f499c5502b')
+ '0d053487907de4376d67d8f499c5502b'
+ '41ce105f0c1877fe22e0c0ec45e09565')
if [ "$_pkgname" != "$pkgname" ]; then
provides+=("$_pkgname=$pkgver")
@@ -71,6 +74,7 @@ dpkg-source() {
export QUILT_PATCHES=debian/patches
export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
export QUILT_DIFF_ARGS='--no-timestamps'
+ export DEBIAN_BRANDING_DIR="debian/branding"
mv mozilla-release "${_debname}-${_debver}"
mv debian "${_debname}-${_debver}"
cd "${_debname}-${_debver}"
@@ -78,6 +82,9 @@ dpkg-source() {
# Doesn't apply and seems unimportant
rm -v debian/patches/l10n/Place-google-and-gmail-before-yandex.patch || true
+# This patch doesn't works in some parts due that has patches for others locales languages, source code doesn't has it
+ rm -v debian/patches/debian-hacks/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch || true
+
quilt push -a
find .pc -name .timestamp -delete # why isn't "--no-timestamps" doing this?
cd ..
@@ -98,6 +105,10 @@ if [ $NOEXTRACT -eq 0 ]; then
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
patch -Np1 -i "$srcdir/xulrunner-copy-stub.patch" # small fix
patch -Np1 -i "$srcdir/libre.patch"
+
+# Adding fixed Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
+ patch -Np1 -i "$srcdir/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch"
+
fi
cd "$srcdir/mozilla-build"