summaryrefslogtreecommitdiff
path: root/libre/icedove/PKGBUILD
diff options
context:
space:
mode:
authoroaken-source <oaken-source@parabola.nu>2019-11-18 01:12:58 +0100
committeroaken-source <oaken-source@parabola.nu>2019-11-18 01:12:58 +0100
commitf1b8b764d2da0b4a1de7fee1e3cfa70125e13ddc (patch)
treee6b4aaef2e86e7f56cbca1ea48d7b2884491e889 /libre/icedove/PKGBUILD
parentb39a37bac27bd816cdf0b1d574cf00073ded362a (diff)
downloadabslibre-f1b8b764d2da0b4a1de7fee1e3cfa70125e13ddc.tar.gz
abslibre-f1b8b764d2da0b4a1de7fee1e3cfa70125e13ddc.tar.bz2
abslibre-f1b8b764d2da0b4a1de7fee1e3cfa70125e13ddc.zip
libre/icedove: updated to 68.2.2
Diffstat (limited to 'libre/icedove/PKGBUILD')
-rw-r--r--libre/icedove/PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/libre/icedove/PKGBUILD b/libre/icedove/PKGBUILD
index 8d5afb25c..3e9963888 100644
--- a/libre/icedove/PKGBUILD
+++ b/libre/icedove/PKGBUILD
@@ -19,17 +19,16 @@
_pkgname=thunderbird
pkgname=icedove
replaces=("$_pkgname")
-pkgver=68.1.0
-pkgrel=1
+pkgver=68.2.2
+pkgrel=2
pkgrel+=.parabola1
-_brandingver=60.5
+_brandingver=68.2
_brandingrel=1
-pkgdesc="Libre standalone mail and news reader based on Mozilla Thunderbird"
+pkgdesc='Standalone mail and news reader based on Mozilla Thunderbird'
url="https://wiki.parabola.nu/$pkgname"
arch=(x86_64)
arch+=(i686 armv7h)
license=(MPL GPL LGPL)
-
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
nss hunspell sqlite ttf-font icu) # libvpx
makedepends=(unzip zip diffutils python python2 yasm nasm mesa imake libpulse inetutils xorg-server-xvfb
@@ -39,20 +38,26 @@ optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags)
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz{,.asc}
$pkgname.desktop
- https://repo.parabola.nu/other/icedove/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz{,.sig}
- libre-searchengines.patch)
-sha256sums=('de0e5c7d1d5576f451e386e4779f155b7af97621a4e22caac0c6dee3c9d76eef'
+ thunderbird-rust-1.39.patch)
+source+=(
+ https://repo.parabola.nu/other/icedove/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz{,.sig}
+ libre-searchengines.patch)
+sha256sums=('c17edbcde0e9e7599cda16b69b130039f69113b498ea394057cedfae153f0dd3'
'SKIP'
'af8199a12ebe09189d143458bd1e2d0071aff3410ed121dc2329a448a56632f0'
- '590862b39ba7baf60e47240e33de5839a8e85b6831c839ea57481968c9020241'
+ '08834ef1c2dd685edd40dea20dfa9d4b889f5c387385ac329a162eeff6cf90be'
+ 'b36792a6fcbe68841bc842723222c88ecf1f54f7f75bd634b216b61f3ae422f2'
'SKIP'
- '9ef9dd18ac1f76ccc3d5d2ace866bb40199fd00a1192da83aef376c585be2ec3')
+ '072bba9d9ef4cfcb03b3776a15e52020e05c685add38329bd041f680026f5898')
validpgpkeys=(14F26682D0916CDD81E37B6D61B7B526D98F0353) # Mozilla Software Releases <release@mozilla.com>
validpgpkeys+=(BFA8008A8265677063B11BF47171986E4B745536) # Andreas Grapentin
prepare() {
cd $_pkgname-$pkgver
+ patch -p1 -i ../thunderbird-rust-1.39.patch # Fix build with rust 1.39 (Gentoo)
+
+
cat >.mozconfig <<END
ac_add_options --enable-application=comm/mail
ac_add_options --enable-calendar
@@ -78,11 +83,9 @@ ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
-# FIXME: does not build against libvpx-1.8.0 or libvpx-1.8.1
# ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
@@ -151,8 +154,8 @@ END
comm/mail/themes/linux/mail/preview.png
# Load our searchplugins
- rm -rv comm/mail/locales/en-US/searchplugins
- cp -av /usr/lib/mozilla/searchplugins comm/mail/locales/en-US/
+ rm -rv comm/suite/locales/en-US/searchplugins
+ cp -av /usr/lib/mozilla/searchplugins comm/suite/locales/en-US/
}
build() {
@@ -235,7 +238,6 @@ END
"$pkgdir/usr/share/applications/$pkgname.desktop"
# Use system-provided dictionaries
- rm -r "$pkgdir/usr/lib/$pkgname/dictionaries"
ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"